iPhone: internet works only with facebook and gmail, shows "No internet data" with the rest

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Ben777, Nov 3, 2016.

  1. Ben777 macrumors newbie

    Joined:
    Jun 24, 2013
    #1
    Hi,

    I am using iPhone SE.

    All sites work well with WiFi - facebook, gmail, youtube, browsers, Appstore, weather apps and rest.

    But if I am using internet with "Mobile Data" on (Settings > Mobile data "on") for some reason only Facebook and Gmail works. Browsers, Youtube, Weather apps show "No internet connection". But I know that there is an internet connection, as it works with facebook and Gmail.

    How to fix this, please?

    Thank you!
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Perhaps something with your carrier and/or the plan you have with them?
     
  3. Ben777 thread starter macrumors newbie

    Joined:
    Jun 24, 2013
    #3
    Can plan or carrier block everything except facebook and gmail? I can ask my carrier but this sounds weird. Either it works or not. And here it works but not with everything...
     
  4. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #4
    I'd potentially try to reset network settings to see if that makes a difference. Perhaps take out and put the SIM back in and restart. If none of that is working and things are fine on WiFi but not with mobile data, seems like the carrier would be a fair thing to consider.
     
  5. Ben777 thread starter macrumors newbie

    Joined:
    Jun 24, 2013
  6. beernut macrumors 6502

    Joined:
    Jan 13, 2016
    #6
    under settings --> cellular, are your other apps enabled under "use cellular data for" section?
     
  7. Ben777 thread starter macrumors newbie

    Joined:
    Jun 24, 2013
    #7
    Thank you very much!!! This seems to be the problem. I the past I have turned off some apps for spotlight search to keep spotlight search uncluttered and cleaner. It seems this automatically disabled those apps in "Mobile data". I turned them on again and Mobile internet works well.

    P.S. on my phone it is called "Mobile Data" (not "cellular").
     

Share This Page