Iphone no sound during calls(on the phone)

Discussion in 'iPhone' started by johnsonxray, Jun 30, 2011.

  1. johnsonxray macrumors member

    Joined:
    Apr 20, 2011
    #1
    Hey peeps, it happened to me recently..my iphone4 has no sound at all when im on the phone..its not like, the ringtone doesn't ring when there's incoming calls, no, it rang, everything works fine with the speaker and microphone, playing music and games BGM were all fine..but..after i picked up the call..it has no sound at all..like..'hello hello hello???' no sound at all, I cant hear anything from my friend. I thought my friends were giving me a prank call..after i hang up then he called again and asked me..why do you keep hello and hang up my call? lol
    sometimes its even worse, the conversation went mute suddenly in the middle of the call..and then i have to hang up and call again..
    Is this considered as a hardware failure or what is this actually..i tried reset all settings, reboot, hard reset..but still..it happened few minutes ago =(
     
  2. johnsonxray thread starter macrumors member

    Joined:
    Apr 20, 2011
  3. wordoflife macrumors 604

    wordoflife

    Joined:
    Jul 6, 2009
    #3
    The ringer, speakerfone, and games all come from the speaker on the bottom of the phone. When you are taking a call, the sound comes from the earpiece.

    Since sounds works perfectly fine except for when using the earpiece, I would assume that the earpiece is broken.

    You'd need to take it to an Apple Store and they'll replace it for you. When did you buy your iPhone? It comes with a One year warranty so you may or may not be eligible depending on when you bought it.

    https://selfsolve.apple.com/agreementWarrantyDynamic.do
     
  4. Legion93 macrumors 6502a

    Legion93

    Joined:
    Apr 6, 2011
    Location:
    Death Star, Rishi Maze
    #4
    Have you considered taking it to an Apple retail store for replacement? They will most likely repair or replace it when you demonstrate them the issue.

    Alternatively, you can try contacting your network provider and explain the issue.

    Has this been happening a while now? Did you try putting it to airplane mode on and off?
     
  5. jaytee61 macrumors newbie

    Joined:
    Jul 6, 2011
    #5
    Try a blast of pressurized air

    This just happened to me, too. I blasted the headphone jack (which is where I suspect the problem was; the phone had just fallen under my car seat so could have gotten carpet fiber or dust in the jack, so the phone may have "thought" I had headphones/aux cord in) with a can of pressurized air, the stuff you clean your computer keyboard with. I did not see anything come out, but voila, sound from the earpiece again!
     

Share This Page