Iphone won't restore error 14 & error 21

Discussion in 'iPhone Tips, Help and Troubleshooting' started by duffsrp, Feb 17, 2009.

  1. duffsrp macrumors member

    Oct 29, 2004
    I've tried countless times to restore my iphone with apple's legit software. Not trying to jailbreak it. Every time I get an error. Either 14 or 21 when it goes to verify the software. I've tried reboot, switching the usb ports and even a Windows machine. Nothing is working. Any suggestions? Right now it's stuck in restore mode.
  2. mohicanspap macrumors regular

    Jul 19, 2008
    Try using a powered USB hub. That might go around the error message.
  3. duffsrp thread starter macrumors member

    Oct 29, 2004
    Thanks for the suggestion. I've tried it a couple times with a hub. No success.
  4. Moi un Mouton macrumors 68000

    Mar 18, 2008
    Bracknell UK
  5. Moi un Mouton macrumors 68000

    Mar 18, 2008
    Bracknell UK
    Which iPhone and which firmware are you using?

    Have you looked at this page on Apple: http://support.apple.com/kb/TS1275? There are a lot of troubleshooting steps there.

    By the way, is your usb hub powered? i.e. it has it's own power lead from the electricity supply?
  6. duffsrp thread starter macrumors member

    Oct 29, 2004
    iPhone is first gen. 8 gig and I'm trying to install 2.2.1. The most recent. It's my friends phone and I have no idea what he was running prior to this issue. Tried another one of my computers, PowerBook running 10.4.9 (no hub) still nothing. And yes the hub I have been using is powered.
    I've looked all over the web. I think even the link you posted. I'll double check it in a sec.

    Just checked the link. And I've been through all that already. I think it's time for the mac genius.
  7. Gix1k macrumors 68030


    Jun 16, 2008
    Try a diff PC or a diff user acct/profile on that PC. Sounds odd, but I had the same issue with my Touch. That corrected it.
  8. duffsrp thread starter macrumors member

    Oct 29, 2004
    This one is a killer. I've jailbroken and restored a ton of phones. Never see anything like this.
    Gix1k, I've tried the a different user and new isp on that user. Even switched usb ports.

    I think he dropped the phone and it's really busted.

    Enough time spent on this phone. I'm going to have my buddy make an appointment.
    Thanks everyone.
  9. DPA macrumors 65816


    Well, since you have given up and are going to make an appointment at the Genius Bar, for any other viewers with this problem, try this:

    Hard Reset:
    1) Power iPhone on.
    2) Hold the Home and Sleep/Wake buttons for about 7 seconds, or until the screen turns black.
    3) Your iPhone should reboot. If it doesn't don't worry, just hold the Sleep/Wake button for about 2 seconds.

    Recovery Mode Restore:
    1) Turn iPhone off by holding down the Sleep/Wake Button for about 5 seconds or until the Slide to Power Off slider appears.
    2) Slide Power Off slider. If iPhone is unresponsive, follow the Hard Reset instructions up to Step 3.
    3) Open iTunes on your computer (Mac or PC).
    4) Hold the Home Button down while you connect your iPhone to your computer via a USB cable.
    5) iTunes should prompt you with a message saying an iPhone has been detected in Recovery Mode and that you must Restore it to before it can be used with iTunes.
    6) Click Ok.
    7) Click Restore a message should appear confirming that you want to Restore and Update.
    8) Click Restore and Update. The restore has been initiated. Leave your iPhone connected until you iPhone reboots and syncs with iTunes.


    P.S. - I was at the Genius Bar a few days ago and saw someone with a similar, if not identical, problem. The genius was (trying to) restore it but it was stuck at the Waiting For iPhone (I think that's what it said) stage with the loading bar on the iPhone. The Genius asked if he tried a restore before and the man replied, "yes and it just stays at this forever, I even tried leaving it there for about 6 hours and nothing happened". Since the man's iPhone was out of warranty, the Genius told him he couldn't fix it. He did, however, say that it seemed like a hardware issue and he could send it into a place like iResQ that would fix it for him. iResQ gives you an estimate on how much it will cost to fix something, when you send it in, and they will fix it if you would like them to. For somethings, like broken DIgitizers and screens, they already have how much it costs to fix it. From what I've seen they are pretty reasonable, especially for doing the labor to. You can also take the information that they give you and attempt to fix it yourself.

  10. duffsrp thread starter macrumors member

    Oct 29, 2004
    FCP guy. Thanks for the info. I tried it again and no dice. Maybe I'll look up iResQ. Thanks again.
  11. DPA macrumors 65816


    This 99% confirms that it is a hardware issue. If you want to make it a DIY fix then send it into iResQ just for a quote. Then you can ask them to send it back to you. You can buy the parts from them, Mission Repair, PDAParts or anywhere else that sells iPhone replacement parts.

  12. H2KOG macrumors newbie

    Feb 18, 2009
    Im getting the same error message on my Iphone that I got today. Im taking it to the AT&T Store tomorrow and the Apple store if I have to.
  13. djrumar macrumors newbie

    Jun 18, 2009
    hi!! i had to register to this forum just to help out, iv had the same problem with my 1st gen iphone, the same error as well as not being able to restore it , i was using a MAC with the latest itunes , i then plugged my iphone into my old laptop (XP service pack 3) updated the itunes, then to my surprise it restored without any problem , once the new firmware was installed and factory settings set , i plugged the iphone into my MAC and synced all my previous settings etc, hope this helps
  14. UnbornApple macrumors regular


    Jun 18, 2009
    Minneapolis, MN
    I had this issue earlier today on my mac. What you need to do is create a new user account and re-download the software. You said you were trying to go to 2.2.1.

    Your computer is going to try to download 3.0 just so you know. If your worried about a jailbreak or something you should still be fine because you can still jailbreak the phone.

    Let me know if this works!
  15. g1sdaname macrumors newbie


    Jun 11, 2009
    Marietta, GA
    Thanks for the post. This did help except I didn't have another computer to be able to sync it with. I had to take it to an Apple store on my lunch break!

    Good news I still got to eat when I came back. :D
  16. stewartws, Jun 19, 2009
    Last edited: Nov 19, 2013
  17. UnbornApple macrumors regular


    Jun 18, 2009
    Minneapolis, MN
    I think that error is an issue with the ipsw file and it just needs to be redownloaded.

    So you could go about this one of two ways.

    One: make the new user account on the computer and re-download it like that.

    Two: go in and delete the ipsw file and then redownload it that way.

    Its up to you.
  18. iGHoST-- macrumors newbie

    Jul 18, 2010

    I recently had this problem when updating my ipod touch 2nd Generation
    I was trying to update it from 3.1.5 to 4.0.1 and my ipod went into recovery mode it wouldn't restore and everytime I tried it would say "ipod cannot restore error (21)"

    I tried reinstalling and rebooting itunes and mac respectively.
    Furthermore it wouldn't enter dfu mode


    I connected it to my laptop (windows XP) and it said the same as the mac. However when i went to restore it it began to download an ipod software update and then restored my ipod back to the previously installed software.

    I haven't yet retried updating to OS 4.0.1 but I will post the results.

    (all my music and stuff was gone but that was all saved on my mac so no problems)
  19. umeshgaire macrumors newbie

    Sep 2, 2010
    Solved Error 14, 21 restoring iPhone 4.3.2, 4.3.3

    Don't be worry friends Just See what happened to us, Get out the error 14: Read Here
  20. GoDuke macrumors newbie

    Jun 12, 2011
    solving error 14

    Long time reader, first time poster.

    I think I've got a fairly good solution to error 14, and it doesn't involve lots of computers, or cables or anything like that.

    I've got an iphone 4 and was updating to 4.3.3 when I received the dread error 14 through all my panic I freaked out and thought that I would be absolutely S.O.L.

    My remedy involves downloading TinyUmbrella, a small trip on terminal and then lastly deleting some files. As I recall this is exactly what I did.

    1) Close iTunes, but keep your iPhone stuck in Recovery attached to the computer
    2) Download and Open Tiny Umbrella
    3) Click Start TSS Server
    4) Put Phone into DFU mode this will enable the Fix recovery button at the top of TinyUmbrella
    5) When Phone shows up, Click Fix Recovery and let it run, it should show some code and say GreenP0ison initialized in small text
    6) While it still has code up, open Terminal write this Code:

    sudo /Applications/TextEdit.app/Contents/MacOS/TextEdit /etc/hosts

    7)Press Enter
    8)Delete all lines that reference gs.apple.com
    9)Save File
    10) After file saved with Phone still showing code, do a hard reset.
    11) Open iTunes and the Phone will show up in recovery mode
    12) Hit Restore and let it do it's thing.

    After a lot of panic and reading that there was no way to recover I was able to get my phone up and working with no problems at all.

    If I've missed a step or if anyone has questions feel free to PM me! Thanks!!
  21. error 14 fixed macrumors newbie

    Oct 15, 2011
    here's a long shot

    For those with USB wireless dongles (might possibly work for normal cabled PCs but I doubt it)

    My setup: Windows 7, USB 2.0, normal apple cable, netgear rangemax wireless WN111v2 USB adapter, no jailbreaking or special iphone setup

    Having tried all the usual solutions (different cables, msconfig turn off services, try different USB cables, reinstall everything, reboot) and always with an error 14 somewhere during the 'restore' (usually pretty early, involving iphone dying first then itunes giving up), I've finally found something that works on this PC (upgrades work OK on my work PC so this fix is specific to particular PCs).

    This *really* shouldn't work, but it's finally given me my iphone back.

    Put the iphone on a USB port near (preferably same hub as) your wireless USB dongle.
    Fire up at least 5 youtubes in browsers and find videos that are longer than 1/2 an hour. Set them all running. I used Big Brother, although this didn't really improve the experience to be honest.
    Run your update from itunes as usual
    your 'restoring iphone software' bar gets much further (hopefully to the end!). Depending on how much you know about how the process, marvel at how wrong things must be for this to work
  22. lamfrazier macrumors newbie

    Oct 16, 2011
    I'll assume you are being sarcastic

  23. error 14 fixed, Oct 18, 2011
    Last edited: Oct 18, 2011

    error 14 fixed macrumors newbie

    Oct 15, 2011
    Actually no, this worked. It really did. My iphone made it to the end of the restore on the first go using the short cable, and I finally got ios 5 running. Nothing else I tried worked on that Windows 7 PC (another WinXP laptop was OK).

    I've worked in software/firmware/product design for 10 years so I realise this shouldn't have worked. I've never seen a USB device side connection so poor that messing with the resources available from the windows side improved it (at least, not in a product we would have released :). I can only assume that occasional 300ms gaps in data bursts while windows decides to do something else helps the iphone keep up. Or maybe the slower data transfer means the iphone doesn't overdraw power even more beyond the USB spec and then get cut dead by the driver (possibly more likely as you can see the iphone die before itunes notices when the error hits). I would investigate from the Windows side but if my life flashes before my eyes I'd prefer to be watching something else tbh.

    Something inherently dodgy about the USB transfer might explain why they only ship with a 1m sync cable for added 'USB confidence' though - even this solution didn't work with a (normally uncontroversial) USB 2m extension cable between iphone and PC
  24. NewSlang, Oct 21, 2011
    Last edited: Oct 24, 2011

    NewSlang macrumors newbie

    Oct 21, 2011
    I registered here just so I can thank you as your strange nonsensical method worked! I tried everything to fix error 14, tried different programs like iReb or Sn0wbreeze, different ports, cords, and even different computers, all ending with error 14. This is the only method that actually worked for me... Thank you so much!

    EDIT: Just an update. The restore worked with this, but my ipod 3g 32gbcrashes when trying to run apps like safari or even app store..
  25. elliwhi macrumors member


    Oct 30, 2011
    Thank you! I was trying to restore my iPod Nano 5th Gen and the kina of same message was showing up. I tryed what you wrote and it worked! Thank you sooo much! :) ;)

Share This Page