iPhone won't send iMessages on wifi

Discussion in 'iPhone' started by nhlfreak98, Dec 1, 2013.

  1. nhlfreak98 macrumors 6502

    Joined:
    Apr 16, 2013
    #1
    Hi I have an iPhone 5 7:0.4 and everytime I try to send an iMessage on my home wifi it takes 10-15 minutes to send or it sends as a text message. Why does this happen? It doesn't happen to my other family members in my house who have a 5
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #2
    Have you tried restating the phone? What about enabling and disabling iMessage if not resetting network or even all settings on the phone?
     
  3. nhlfreak98 thread starter macrumors 6502

    Joined:
    Apr 16, 2013
    #3
    Did all of that and it works sometimes but most of the time it takes awhile to send
     
  4. PNutts macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #4
    I haven't heard of this issue before. I assume the folks with phones that don't have the issue have successfully sent a message to the same person that is delayed for you?

    Since you've done the right stuff already, I'd log out and disable everything iCloud related on the phone and remove the phone from your iCloud account, then log back in on the phone.

    A real head-scratcher.
     
  5. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #5
    What are you sending with imessage that takes a while to send?
    Is it just text or pictures or video?
     
  6. bushman4 macrumors 68000

    Joined:
    Mar 22, 2011
    #6
    Restart your Router. Then reset 'network settings on your iPhone. General >Reset> Reset Network Settings. Then sign back in to your WiFi account.
     
  7. nhlfreak98 thread starter macrumors 6502

    Joined:
    Apr 16, 2013
    #7
    Anything in general pics texts

    ----------

    This happend right as my data plan expired that had unlimited texting with it. Like before when I had the plan, and was on wifi they would send fine now since I switched plans to soemthing that doesn't have data and unlimited texting they won't seem to send on my home wifi
     
  8. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #8
    Weird.
    If its pics it would take longer than plain texts to send but it should still go out.
    How fast is your wifi?
     
  9. nhlfreak98 thread starter macrumors 6502

    Joined:
    Apr 16, 2013
    #9
    It's like 16up 2-4 down i have tmobile and I hand like $2 in my account I just added $30 now let's see if that helps maybe bc I had low funds
     
  10. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #10
    It shouldn't have anything to do with low funds in the account. As long as its on wifi it should send either way.
    Does it do the same in other wifi routers or just the one at your house?
     
  11. nhlfreak98 thread starter macrumors 6502

    Joined:
    Apr 16, 2013
    #11
    at my schools wifi I think it sends right away but there speed is like 20-25 down
     
  12. nhlfreak98 thread starter macrumors 6502

    Joined:
    Apr 16, 2013
    #12
    I tried it at school and it seemed to send fast on there wifi. But once I got home stuck on sending ....
     
  13. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #13
    Might be something with that router or port forwarding or that particular internet provider.
     
  14. nhlfreak98 thread starter macrumors 6502

    Joined:
    Apr 16, 2013
    #14
    How do I fix the port forwarding? And I can't switch routers I just got this one like a month ago from them and it's basically new
     
  15. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #15
    Not sure what port numbers imessages use to send so you can go into configuration to make sure they're open.
    At least you know its not the phone but that particular wifi.
     
  16. nhlfreak98 thread starter macrumors 6502

    Joined:
    Apr 16, 2013
    #16
    How do I check on that? Because I just tested it with my iPhone 4 which doesn't have a data plan and is on tmobile and the messages sent quickly same with my siblings who have an iPhone 5 from Verizon messages on wifi send right away idk why my iphone doesn't send messages on wifi
     
  17. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #17
    I hear you. It doesn't make sense.
    The only other thing I would think to try is to restore and setup as new to see if that fixes it.
    It is a software glitch somewhere.
     
  18. NickRichyRich macrumors member

    Joined:
    Jun 27, 2013
    #18
    Is the phone only slow at sending iMessages while on your own personal wifi or is the internet slow as well? If it is just iMessage and you have already tried resetting network settings then I would say that it is something with the router. You could always go buy a new router and keep the receipt if it does not work.
     
  19. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #19
    That's what I was thinking too but doesn't explain how other iphone's connected on that same router send imessages fast and with no probs and only his iphone doesn't send or gets stuck.
     
  20. big samm macrumors 65816

    Joined:
    Oct 27, 2008
    #20
    Op should restore the iphone and set as new and see what's up, that's what i would do... Pretty sure it will work fine...
     
  21. NickRichyRich macrumors member

    Joined:
    Jun 27, 2013
    #21
    I agree, this way we can be sure that the software on the iPhone has been taken out of the question.
     
  22. sparzokm macrumors newbie

    Joined:
    Dec 4, 2013
  23. nhlfreak98 thread starter macrumors 6502

    Joined:
    Apr 16, 2013
    #23
    I did that yesterday now I'm not receiving iMessages sent to me and when I try and send a message to someone who has an iPhone it's in green
     
  24. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #24
    Your Wifi network must be having problems connecting to Apple's servers.

    If you have a data plan, the phone will fall back to cellular to send iMessages if local Wifi is not working. Since your data plan expired there's nothing to fall back to, so now it just fails outright.

    Check your router and network configuration; make sure there aren't blocked ports or other issues.
     
  25. nhlfreak98 thread starter macrumors 6502

    Joined:
    Apr 16, 2013
    #25
    Can you teach me how to check if the ports are blocked
     

Share This Page