Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

datszach4u

macrumors newbie
Original poster
Nov 4, 2009
1
0
Hey, I have a 2g Iphone that has firmware 3.0 and wont start up. When I try and hold the power button the apple logo comes up but then the screen goes black after about 30 seconds. It is not detected on my computer and I cannot put it in DUI mode. I have also tried holding down the home button with Itunes and nothing. Please help me.
 

Gav2k

macrumors G3
Jul 24, 2009
9,216
1,607
Tried leaving it on charge for a good amount of time??
 
Comment

spykar

macrumors newbie
Nov 4, 2009
1
0
3GS not starting, just logo comes up & nothing happens

I've recently jailbroken my 3GS iPhone with pwnage tool but then in Settings tab on iPhone, I've selected to delete all the data & settings, after that when I start my phone, just Apple logo comes in the startup but don't move ahead.

Can't even detected by PC & also can't even go to recovery mode.

PLEASE HELP.
:(
 
Comment

-aggie-

macrumors P6
Jun 19, 2009
16,795
51
Where bunnies are welcome.
I've recently jailbroken my 3GS iPhone with pwnage tool but then in Settings tab on iPhone, I've selected to delete all the data & settings, after that when I start my phone, just Apple logo comes in the startup but don't move ahead.

Can't even detected by PC & also can't even go to recovery mode.

PLEASE HELP.
:(

You erased all your data, so no wonder you're having problems. Don't ever do that in the future, unless you plan on giving the phone back to Apple.

@OP and spykar:

You need to get your phone in DFU mode. Look at my sig and do EXACTLY what the link says. Watch some videos on how to do DFU mode, if need be. Just do it. The OP has a chance of getting into DFU mode. IDK about spykar. Deleting all your data can be problematic.
 
Comment

ralphcastle

macrumors newbie
Nov 4, 2009
16
0
You erased all your data, so no wonder you're having problems. Don't ever do that in the future, unless you plan on giving the phone back to Apple.

@OP and spykar:

You need to get your phone in DFU mode. Look at my sig and do EXACTLY what the link says. Watch some videos on how to do DFU mode, if need be. Just do it. The OP has a chance of getting into DFU mode. IDK about spykar. Deleting all your data can be problematic.

i did that too
 
Comment

ralphcastle

macrumors newbie
Nov 4, 2009
16
0
I've recently jailbroken my 3GS iPhone with pwnage tool but then in Settings tab on iPhone, I've selected to delete all the data & settings, after that when I start my phone, just Apple logo comes in the startup but don't move ahead.

Can't even detected by PC & also can't even go to recovery mode.

PLEASE HELP.
:(

i mean this i did that too.but mine is stuck with a pineapple sorry for double posting
 
Comment

-aggie-

macrumors P6
Jun 19, 2009
16,795
51
Where bunnies are welcome.
Well, if DFU mode won't work, try this. First open iTunes and connect your USB cord to your computer, but do not plug it into your iPhone. Then press and hold the home button on your phone while connecting the USB cord into your iPhone, while continuing to hold down the home button. Then click restore in iTunes.
 
Comment

winrawr

macrumors newbie
Nov 12, 2009
4
0
i am also having the same issue that the apple logo comes on for a short amount of time then turns off i can get into DFU mode but i get error 23 and i also can turn my iphone on when its not plugged into something :/ oh i have the 3G 8gb
please any help will be greatly appreciated
 
Comment

chrisco91

macrumors newbie
Mar 1, 2010
1
0
Similar issue!

I have just replaced my back housing on my iphone, started it up and it was fine... one minute later, it dies in the arse, i try and turn it on again but it doesn't turn on unless it is plugged into the wall charger (usb does not register), and when it does turn on, it stays on the apple logo for 10 seconds and dies again. it was charged before I replaced the housing, and I can't get it into recovery mode or anything, because it shuts off as soon as I unplug the USB and connect to the PC. I then have to reset the phone again (connected to power).
So, tried DFU mode, iTunes doesn't detect it. Also, and very quiet, high pitched squeal is coming from the back of the phone, is this just my iphone or do they all do it, but I simply haven't noticed before? I have thought of trying to find a USB dock with a seperate power supply but now sure if they exist of if this will help.
Determined to fix this as I think the phone is great, if only Apple can sort out the battery life issues!
Hope someone can help.

I am willing to crack open the iphone again and do whatever inside, as long as I'm not wasting money buying parts that won't fix it..
 
Comment

ajmeelan

macrumors newbie
Mar 4, 2010
1
0
Exact Same Problem

Hey, I have a 2g Iphone that has firmware 3.0 and wont start up. When I try and hold the power button the apple logo comes up but then the screen goes black after about 30 seconds. It is not detected on my computer and I cannot put it in DUI mode. I have also tried holding down the home button with Itunes and nothing. Please help me.

I'm having the exact same problem. The phone will turn on, but only for about 30 of the apple image, then it shuts off. Can't get iTunes to recognize it.

Did you ever get your problem resolved?
 
Comment

rec2150

macrumors newbie
May 15, 2010
1
0
try this

If you opened it and its starting to do that, then it might be that the battery is not well connected or adjusted, try removing it and placing it correctly in the spot, also what it might be and you might try first, the screws from where it says do not remove and the one above that one might be to tight or to loose, try messing with them first to see if the connection of the battery is not connecting with the board.
 
Comment

Ratatta

macrumors newbie
May 14, 2010
1
0
Same problem here... 3.1.2 3GS

Used blackrain. no problems until i erased all settings and content...

Then appel logo for a few minutes and black, then all over again.
Irecovery does not work, this message comes.

"Got USB
No IPhone/iPod found."

have been trying meny different DFU attempts.

so any other suggestions???

all give 20 $ on paypal. if anybody find the solution.
 
Comment

-aggie-

macrumors P6
Jun 19, 2009
16,795
51
Where bunnies are welcome.
Used blackrain. no problems until i erased all settings and content...

Then appel logo for a few minutes and black, then all over again.
Irecovery does not work, this message comes.

"Got USB
No IPhone/iPod found."

have been trying meny different DFU attempts.

so any other suggestions???

all give 20 $ on paypal. if anybody find the solution.

See my sig on how to do DFU. Don’t ever click on “erase all content…” again.
 
Comment

Maskinare

macrumors newbie
May 15, 2010
1
0
I have just replaced my back housing on my iphone, started it up and it was fine... one minute later, it dies in the arse, i try and turn it on again but it doesn't turn on unless it is plugged into the wall charger (usb does not register), and when it does turn on, it stays on the apple logo for 10 seconds and dies again. it was charged before I replaced the housing, and I can't get it into recovery mode or anything, because it shuts off as soon as I unplug the USB and connect to the PC. I then have to reset the phone again (connected to power).
So, tried DFU mode, iTunes doesn't detect it. Also, and very quiet, high pitched squeal is coming from the back of the phone, is this just my iphone or do they all do it, but I simply haven't noticed before? I have thought of trying to find a USB dock with a seperate power supply but now sure if they exist of if this will help.
Determined to fix this as I think the phone is great, if only Apple can sort out the battery life issues!
Hope someone can help.

I am willing to crack open the iphone again and do whatever inside, as long as I'm not wasting money buying parts that won't fix it..

Funny (not), I have done exactly the same... Hade you found any solotion yet?
 
Comment

mfrias

macrumors newbie
May 18, 2010
2
0
Iphone recovery

I would like to buy one of this iphones from you guys if it does not turn on anymore. I would like to try a theory to see if I can find the solution to this problem.
If any of you wouldn't mind selling your non-working iphone pls. let me know.

you can reach me at frias1009@yahoo.com

Thanks again!
 
Comment

hammeros

macrumors newbie
Jul 16, 2010
2
0
I have just replaced my back housing on my iphone, started it up and it was fine... one minute later, it dies in the arse, i try and turn it on again but it doesn't turn on unless it is plugged into the wall charger (usb does not register), and when it does turn on, it stays on the apple logo for 10 seconds and dies again. it was charged before I replaced the housing, and I can't get it into recovery mode or anything, because it shuts off as soon as I unplug the USB and connect to the PC. I then have to reset the phone again (connected to power).
So, tried DFU mode, iTunes doesn't detect it. Also, and very quiet, high pitched squeal is coming from the back of the phone, is this just my iphone or do they all do it, but I simply haven't noticed before? I have thought of trying to find a USB dock with a seperate power supply but now sure if they exist of if this will help.
Determined to fix this as I think the phone is great, if only Apple can sort out the battery life issues!
Hope someone can help.

I am willing to crack open the iphone again and do whatever inside, as long as I'm not wasting money buying parts that won't fix it..

I have exactly the same problem after replace back housing. Is anybody know how to fix?
 
Comment

MasterTeeee

macrumors newbie
Aug 8, 2010
1
0
Not sure if anyone who posted originally in this thread is still interested or not.

But I have/had an iPhone with this problem. It would turn on ONLY when connected to a power supply, the Apple logo would appear for a little while, then the phone would turn off in a rather unglamorous fashion. The best way I can describe the way it turns off is... Did anyone own one of the original yellow & black lcd gameboy's? The big white brick things? Well when the phone died it was like turning off one of those, you'd get the apple logo freeze and a couple of lines come across the screen for a couple of seconds, then total shutdown.

I tried doing a DFU restore on it, receiving the error 23 message near the start of the update...

Error 23 refers to an Hardware issue (can't be arsed to find the link, but it's documented on Apple's site), more to the point, error 23 usually refers to a connectivity error.

So, I fiddled with battery screws as advised here, no joy. I proceeded to replace the battery as it could've been a dud (bought the phone 2nd hand as faulty, so had no idea on its history. Also the sticker was removed from the MB). No joy, same results.

So, going back to my point about error 23 being a connectivity error, I assumed that the USB port must of been faulty, only allowing through a very small amount of electricity as to barely charge the battery. Then, once it's turned on, it uses all it's power and dies. Picked one up on ebay for £5, stuck it in, and bingo.

Works like a charm now. So if you're reading this, and your phone doesn't appear to be accepting charge, and iTunes can pick it up in DFU, but can't restore because of error 23, this is probably your solution.

Hope this helps someone.

Peace!
 
Comment

ASP272

macrumors 6502
Sep 14, 2004
352
0
Nashville, TN
I've fixed this problem twice now

I've fixed this exact problem for two iPhone 3Gs and I am fixing another tonight. All three phones were dropped or hit at some point which caused the front bevel to start coming away from the back of the phone. This allowed dust, lint, etc. to get into the phone's innards and cause a faulty connection with the battery and likely at the 30 pin connection port, as noted above by MasterTeeee.
I fixed the first two by taking them apart, using the proper tools and knowing what I was doing because of iFixIt guides, cleaning them thoroughly with 99% alcohol at any dirty connections and at the battery and 30pin port connections specifically. I then reassembled them slowly, ensuring all screws and connections were made properly. Once reassembled, both iPhones were still stuck in the Recovery Loop that cuts them off at the Apple logo. This is where I did a DFU recovery and restored them to factory firmware. Once that was done both phones were in perfect working order. The first phone had a corrupt backup on the users machine so it couldn't be restored from the backup, however the second user was able to use their backup to restore their apps and all other data from their last save.

The point here is that you probably have a bad battery connection or a bad 30pin connector from it being damaged or too dirty to charge the phone properly. If a DFU fails then a take-apart, cleaning, reassembly ensuring good connections and then DFU should do the trick. You can also simply try to take some 99% alcohol on a Qtip and clean the 30pin connector port from the outside, though I doubt you'd have any success with that.

Hope this helps! Good luck! :)
 
Comment

Amylittlehands

macrumors newbie
Feb 4, 2011
9
0
I have just replaced my back housing on my iphone, started it up and it was fine... one minute later, it dies in the arse, i try and turn it on again but it doesn't turn on unless it is plugged into the wall charger (usb does not register), and when it does turn on, it stays on the apple logo for 10 seconds and dies again. it was charged before I replaced the housing, and I can't get it into recovery mode or anything, because it shuts off as soon as I unplug the USB and connect to the PC. I then have to reset the phone again (connected to power).
So, tried DFU mode, iTunes doesn't detect it. Also, and very quiet, high pitched squeal is coming from the back of the phone, is this just my iphone or do they all do it, but I simply haven't noticed before? I have thought of trying to find a USB dock with a seperate power supply but now sure if they exist of if this will help.
Determined to fix this as I think the phone is great, if only Apple can sort out the battery life issues!
Hope someone can help.

I am willing to crack open the iphone again and do whatever inside, as long as I'm not wasting money buying parts that won't fix it..

Did you find a way to fixing this? Alot of people are saying it's hardware problems but other people say it's in recovery loop?! I can't even get into recovery mode, DFU mode or even keep the thing on. Someone please help!
My skpe is: amym.baldwin
email: muffin-madness@live.co.uk
 
Comment

tat24me

macrumors newbie
Mar 24, 2011
1
0
herre;s the method

Used blackrain. no problems until i erased all settings and content...

Then appel logo for a few minutes and black, then all over again.
Irecovery does not work, this message comes.

"Got USB
No IPhone/iPod found."

have been trying meny different DFU attempts.

so any other suggestions???

all give 20 $ on paypal. if anybody find the solution.
hi mate,open itunes,download redsnow and open it,load the ipsw into redsnow you want to use.plug usb end into pc and then dock end into dock ,iphone powers up,if its only 30 secs dont worry.now hold at same time the power button and the home button for 10 secsnow press power button to see if it starts to power up again.if it does good.disconnect from dock and reconnect to power up again and press again together power button and home button.phone will go off.now start red snow and follow the directions;eg,press power button for 3 secs then without releasing it press and hold home button for 10 secs then without releasing home button release power button keep home button pressed for 15 secs.if done correctly phone will start to flash firmware(jailbreak data)then will load settings.redsnow will say done and youwill see loads of script on phone.when this has finnished phone will turn off and then reboot and should then be ok.if not ok it will at worst be in recovery so you can recover in itunes.if the phone dies whilst the script is running you have a hardware power problem usually the battery or dock connector but seeing as it powers when connected it wont be the dock.if you connect to itunes and have hardware prob it will say error 23.you can sometimes with this prob get out of recovery with tiny umbrella.using the same precedure as above you can also put the phone into dfu mode but best for itunes is to plug in cable til powers up and press together home and power button for 10 secs til off then press power for 3 secs then without releasing it hold home as well for 10 secs then phone will be in recovery.
 
Comment

Applejuiced

macrumors Westmere
Apr 16, 2008
40,672
6,532
At the iPhone hacks section.
hi mate,open itunes,download redsnow and open it,load the ipsw into redsnow you want to use.plug usb end into pc and then dock end into dock ,iphone powers up,if its only 30 secs dont worry.now hold at same time the power button and the home button for 10 secsnow press power button to see if it starts to power up again.if it does good.disconnect from dock and reconnect to power up again and press again together power button and home button.phone will go off.now start red snow and follow the directions;eg,press power button for 3 secs then without releasing it press and hold home button for 10 secs then without releasing home button release power button keep home button pressed for 15 secs.if done correctly phone will start to flash firmware(jailbreak data)then will load settings.redsnow will say done and youwill see loads of script on phone.when this has finnished phone will turn off and then reboot and should then be ok.if not ok it will at worst be in recovery so you can recover in itunes.if the phone dies whilst the script is running you have a hardware power problem usually the battery or dock connector but seeing as it powers when connected it wont be the dock.if you connect to itunes and have hardware prob it will say error 23.you can sometimes with this prob get out of recovery with tiny umbrella.using the same precedure as above you can also put the phone into dfu mode but best for itunes is to plug in cable til powers up and press together home and power button for 10 secs til off then press power for 3 secs then without releasing it hold home as well for 10 secs then phone will be in recovery.

Why you're bringing up a thread from Nov 4, 2009?
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.