iPhone won't work on home wifi but works everywhere else. HELP!

Discussion in 'iPhone' started by taramcmahon, May 20, 2013.

  1. taramcmahon macrumors newbie

    Joined:
    May 20, 2013
    #1
    ok, so I feel like ive tried every troubleshoot and my iPhone 4s has truly stumped me.
    I cant connect to the wifi in my home, it just says "unable to connect the network "network name"
    The thing is, it works everywhere else i go and all my other devices at home work like my ipad and macbook.
    when i do go into the wifi on my phone I dont have the option to "forget this network"
    ive tried restoring my phone back to brand new, ive tried restarting my modem.. NOTHING!
    i would really appreciate it if someone is able to help as i feel like tearing my hair in frustration.
     
  2. teleromeo macrumors 65816

    teleromeo

    Joined:
    Dec 2, 2006
    Location:
    kidnapped by aliens
  3. taramcmahon thread starter macrumors newbie

    Joined:
    May 20, 2013
    #3
    I tried, it didn't work.
     
  4. Zmanbaseball2 macrumors 68040

    Zmanbaseball2

    Joined:
    Aug 24, 2012
    Location:
    New York, USA
    #4
    Try a different security setting. Like use WPA instead of WEP visa versa.


    Sent from my iPhone 5 using Tapatalk 2
     
  5. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #5
    As above really. I'd try turning security off and connecting. Then if it connects try wpa2 security. Older routers will be an issue.

    Also does the router have a push to connect button??
     
  6. Barbara786 macrumors newbie

    Joined:
    Oct 23, 2013
    #6
    I have this EXACT problem. Taramcmahon, did any of the suggestions work?
     
  7. redlinux macrumors regular

    redlinux

    Joined:
    Sep 25, 2013
    #7
    What is your router's frequency and what security are you using? To make it simple, try running at 2.4GHz with WPA2.
     
  8. Barbara786 macrumors newbie

    Joined:
    Oct 23, 2013
    #8
    frequency is 2.4Ghz and security is WPA2. Other people in the house successfully use wifi, on a mac, a pc, ipads, iphone 5C (but this is sort of spotty too). My iphone 4s has ios7 and problems with wifi here since. iPad with ios7 has no trouble.
     
  9. mtptlyx macrumors newbie

    mtptlyx

    Joined:
    Nov 15, 2011
    #9
    About a year ago, I had a wireless connectivity problem In our small (2 person) office. Our computers, printer, & NAS were wired, but we used wifi for our iPhones. I set an easily remembered wifi passphrase on the router, entered it on our iPhones, & bam worked flawlessly; our phones would automatically connect as soon as we entered the office.

    Over time visitors coming to the office would ask for the passphrase & connect with their laptop; most were successful, some were not. In the ensuing weeks I noticed a pattern. The ones that could not connect were all MacBooks.

    My associate's son was in the office with his Macbook one day, & this gave me the opportunity to get to the bottom of our connectivity problem. After exhausting all the usual steps, including updating router firmware, I stumbled upon the idea of changing the router passphrase.

    That cured the problem.
    It seems that some devices had a problem with the previous thirteen character passphrase. The new passphrase was fourteen characters, and worked with everything that tried to connect.

    Might be worth a shot trying on your router.
     
  10. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #10
    Have you made sure the network is compatible with the iPhone's radio?
     
  11. Samanosuke macrumors 6502

    Joined:
    Mar 21, 2013
    #11
    I set up a 5ghz Mac Address blocked, WPA2, Password protected, hidden network for my iPhone 5s and I have 0 issues with it.

    Try giving it a dedicated network.
     
  12. fallenapple99 macrumors member

    Joined:
    Nov 1, 2013
    #12
    I have had issues in the past at home with my iPhone 5s, 5 and 2 ipad 2's. For me the problem has always been the number of total clients using the router at one time. Anything above 10-11 of combined wifi/Ethernet and random devices lose connection. A simple fix is to turn off wifi on a wireless device that is on but currently doesn't need wifi access which frees up a wifi slot for your phone. Rebooting the router works too, but I find it best to just not leave wifi on if I don't need it on my idevice at that time.
     

Share This Page