Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

jhearty99

macrumors 6502a
Original poster
Sep 17, 2012
512
538
Long Island, NY
Is anyone else experiencing a slight delay in the screen shutting off after pressing the lock button? I noticed it on launch day when i was setting up the phone but dismissed the issue. Thought maybe it was normal, but then saw a youtube video and saw the screen was turning off immediately after the lock button was hit.

I also compared side by side to my wifes 7 and her phone shuts off immediately and mine takes close to a full second for the screen to turn off. Going to go to the Apple Store after work and compare to the display units.
 
  • Like
Reactions: TinyChip

jefdj

macrumors newbie
Jan 24, 2013
29
20
Yes, I have the same behavior.. Curious to know if it is normal or not ..
 

jhearty99

macrumors 6502a
Original poster
Sep 17, 2012
512
538
Long Island, NY
same for me. figured it was normal?

Ive had plenty of iPhones and knew it wasnt the same but thought maybe it was normal for the X but if you watch any review videos on the phone and watch closely when they lock the phone, the screen locks immediately.
 

yanki01

macrumors 68040
Feb 28, 2009
3,579
1,695
I just watched one and it does have a slight delay. they also have apple pay activated.
 

jhearty99

macrumors 6502a
Original poster
Sep 17, 2012
512
538
Long Island, NY
I would say this is likely due to waiting for a second press to activate Apple Pay. I have just tried and disabled the Apple Pay shortcut, which definitely speeds it up. I wonder if that’s what the person in the YouTube video mentioned has done.

Thank you! Just disabled the double-click side button for Apply Pay feature and it locks immediately. Happy to know its nothing faulty.
 
  • Like
Reactions: TinyChip

sumsh2

macrumors newbie
Nov 9, 2017
2
3
I'm getting the lock delay, but disabling the double click for apple pay doesn't speed it up. Any ideas?
 

klerke

macrumors member
Feb 2, 2010
44
62
Settings > general > accessibility. Turn off the accessibility shortcut at the bottom. This solved it for me.

Having double tap for Apple Pay on or off makes no difference like you said.

Thanks for replying
I don’t have the option to select off or none under accessibility, only other things like magnifier and such.
Figured mine out. Go to settings > general > accessibility > guided access and turn it off. Basically you have to disable anything that would use the side button for a double or triple click.


Ok finally figured it out.
It’s correct you need to turn of All triple click shortcuts like mentioned in this thread (thank you for posting that)
But if you are unable to turn off the shortcuts, then read on.
The way to turn of accessibility all together, is to disable magnifier under accessibility settings, then you’re able to deselect all options under the accessibility shortcut menu (otherwise you cannot I select the magnifier).
Now the response is more like it, when you want to lock the phone.
But if you need the magnifier, you should include it under the costomize control centre. Then you will have the best of both worlds.
 

gabriel.zecheru

macrumors newbie
Sep 20, 2017
8
1
Settings > general > accessibility. Turn off the accessibility shortcut at the bottom. This solved it for me.

Having double tap for Apple Pay on or off makes no difference like you said.

Thanks, this is working for me. Now the delay is gone. And I've added the accessibility shortcut in the control center.
 

Squillace

macrumors 6502
Feb 22, 2016
269
252
Switzerland
Thanks, this was driving me nuts! I couldn't imagine a super fast machine with a sooooo slow action in a button.

I confirm that turning off the triple press for the accessibility option works. No need to turn off Apple Pay or Siri double pless.
 

tonester697

macrumors member
Nov 10, 2017
47
14
My X was exhibiting the same behavior as well--I could definitely tell the difference when I compared it side by side with my wife's X in that the lock sound was immediate when I pressed the lock button on her X but there was roughly a 1/2-second delay in mine. A restore as new didn't mitigate the issue, but oddly enough after some time it somehow went away (on its own) without my having done any of the suggestions mentioned in this thread. The only difference is that I did not add any cards and/or passes to my Apple Pay after the restore, but if indeed Apple Pay isn't the culprit as some folks here speculated, then I have no idea what could have been responsible for the lock button delay.
 

Speed38

macrumors regular
Nov 5, 2011
100
36
WDC Metro area
Is anyone else experiencing a slight delay in the screen shutting off after pressing the lock button? I noticed it on launch day when i was setting up the phone but dismissed the issue. Thought maybe it was normal, but then saw a youtube video and saw the screen was turning off immediately after the lock button was hit.

I also compared side by side to my wife's 7 and her phone shuts off immediately and mine takes close to a full second for the screen to turn off. Going to go to the Apple Store after work and compare to the display units.
I assume it is so that if you accidentally brush that button in pocket or purse, you won't turn on your flashlight and drain your battery. Makes sense to me that you have haptic feedback and have to hold it for a second before it activates.
 

haruhiko

macrumors 603
Sep 29, 2009
6,310
5,176
I would say this is likely due to waiting for a second press to activate Apple Pay. I have just tried and disabled the Apple Pay shortcut, which definitely speeds it up. I wonder if that’s what the person in the YouTube video mentioned has done.
Makes sense.
 

sultanoflondon

macrumors 6502
Dec 3, 2013
333
16
I have been through this thread to no avail. Specifically, I have:

  • Tried disabling Apple Pay.
  • Tried disabling the 'double-click lock button' feature that allows Apple Pay to appear on the iPhone's lock screen after the lock button is double clicked when the iPhone is locked.
  • Tried disabling Magnifier in Settings > General > Accessibility > Magnifier. In fact, Magnifier was never enabled on my iPhone.
  • Tried disabling Guided Access in Settings > General > Accessibility > Guided Access. Similar to Magnifier, Guided Access was never enabled on my iPhone.
  • Tried disabling Accessibility Shortcut in Settings > General > Accessibility > Accessibility Shortcut. I have left this disabled.
  • I switched off haptic feedback as part of my set up procedure because I do not need it.

Can anyone suggest any other possible methods of getting rid of the delay when using the lock button?
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.