iPhone XS Max iPhone Xs Max slow WiFi?

Discussion in 'iPhone' started by Sugadaddy, Sep 21, 2018.

  1. Sugadaddy macrumors regular

    Joined:
    Aug 28, 2010
    #1
    Using the speedtest.net app, my iPad Air 2 and iPhone 6 get full speed from my ISP (130Mbps down), but the new Xs Max is only getting 80 to 100Mbps in the same location. Wifi router is an Airport Extreme 802.11AC.

    Anybody getting similar results?
     
  2. PhillStew macrumors regular

    Joined:
    Sep 23, 2005
    Location:
    Alabama
    #2
    What a coincidence! I just ran the speed test app myself (I have a Xs Max) and was getting 30Mbps down. I’m thinking it’s just a timing thing since I have 130Mbps service so I would probably just test it throughout the day and note any variation.
     
  3. Sugadaddy thread starter macrumors regular

    Joined:
    Aug 28, 2010
    #3
    Seems like a bug... I tried a few different servers, fastest I can get is 101Mbps down. All my other devices are maxing the connection.
     
  4. seezar macrumors regular

    Joined:
    Jan 18, 2018
  5. Packers1958 macrumors 65816

    Joined:
    Apr 16, 2017
    Location:
    South Dakota
    #5
    I'm getting full speed. actually faster than my X.
     
  6. _Refurbished_ macrumors 68000

    _Refurbished_

    Joined:
    Mar 23, 2007
    #6
    I’m paying $70 for 40mbit. My ISP is my real problem!

    No issues maxing out my connection on my Max.
     
  7. Sugadaddy thread starter macrumors regular

    Joined:
    Aug 28, 2010
    #7
    Alright, false alert. I restarted the iPhone and Airport and retested. Now maxing out my connection. :D
     
  8. twennywonn macrumors regular

    Joined:
    Mar 15, 2012
    #8
    Mine is faster than my X for sure.
     

    Attached Files:

  9. mac.cali macrumors 65816

    Joined:
    Mar 16, 2012
    #9
    Make sure you’re connected to 5ghz instead of 2.4ghz.
     
  10. pdxmatts macrumors 68000

    pdxmatts

    Joined:
    Jan 12, 2013
    Location:
    Portland, OR
    #10
    Nevermind. I see you fixed it
     
  11. Sugadaddy thread starter macrumors regular

    Joined:
    Aug 28, 2010
    #11
    Not sure, I'm testing from further away and it's dropping the speed while the iPhone 6 stays the same.


    Yeah, could be the issue, but my airport has the same SSID for 2.4 and 5Ghz, so no way to know. (phone decides the frequency...)
     
  12. mac.cali macrumors 65816

    Joined:
    Mar 16, 2012
    #12
    Turn on the guest network and isolate 2.4 and 5 with unique SSID. Then you can retest.
     
  13. pdxmatts, Sep 21, 2018
    Last edited: Sep 21, 2018

    pdxmatts macrumors 68000

    pdxmatts

    Joined:
    Jan 12, 2013
    Location:
    Portland, OR
    #13
    I was going to say that if you got it today you might want to let it index and settle overnight and try again tomorrow? Plus, reset your network settings and then power off and back on afterwards
     
  14. PBz macrumors 68020

    PBz

    Joined:
    Nov 3, 2005
    Location:
    PVB, Florida
    #14
    Wow. I get Fiber for this rate. Appx 400 up/down on an 8+.
     
  15. _Refurbished_ macrumors 68000

    _Refurbished_

    Joined:
    Mar 23, 2007
    #15
    This is what happens when corporations have too much power. My complex and ISP have a business agreement that only lets one ISP run wires. It’s stuff like this that pisses me off and needs regulation.

    Luckily T-Mobile is trying to merge with Sprint to provide home broadband via 5G, hopefully the government doesn’t block them. I’d gladly use them as my ISP if I could.
     
  16. Sugadaddy thread starter macrumors regular

    Joined:
    Aug 28, 2010
    #16
    Renamed the 5ghz network to something else, and did some tests on each. 2.4 is slower, even at the furthest from the airport.

    I think it was dropping from 5 to 2.4 before.
     
  17. cjake macrumors regular

    Joined:
    Sep 12, 2014
    #17
    I found that when I first connected to my Netgear Orbi WiFi during setup of my XS Max, it connected to the 2.4 network. I went into WiFi settings, forgot the network, and then reconnected; this time on the 5 Ghz network as it should.

    Must be something about the phone's initial setup process that prioritizes 2.4 over 5 Ghz.

    Once connected to 5 GHz I am getting 130 Mbits down even though I am subscribed to 100 Mbit service from Mediacom.
     
  18. R1Lover macrumors newbie

    R1Lover

    Joined:
    Sep 22, 2018
    #18
    Same issue here, its not a access point issue but a phone issue, I have many devices from an SE to iPhone 7 to the xs max, ipad, mpb and more, xs max is the only one with this issue. I can get it to full speed with a freah reboot of the access points, after about 30 minutes it slows to about 50 consistantly

    Hopefully a software update will fix it.
     
  19. JSB1540 macrumors 6502

    Joined:
    Apr 24, 2015
    #19
    fast.com shows 660Mbps and speedtest 428Mbps two rooms from my router. I have GB service, and my wifi is usually in that range. (Nighthawk X10) When I was setting it up yesterday it dropped substantially, but upon rebooting everything, it went back to what I expected.
     
  20. R1Lover macrumors newbie

    R1Lover

    Joined:
    Sep 22, 2018
    #20
    Same results, but.... leave it connected for a few hours and retest, it will drop down in speed eventually. At least that is my results and the max is the only iDevice to perform this way, all ithers remain full speed.
     
  21. JSB1540 macrumors 6502

    Joined:
    Apr 24, 2015
    #21
    It's been pretty steady for 28 hours now. I set it up at noon yesterday.
     
  22. R1Lover macrumors newbie

    R1Lover

    Joined:
    Sep 22, 2018
    #22
    Thats great to hear, perhaps it’s not affecting all varients of access points/routers.
     
  23. blackhawk10 macrumors member

    Joined:
    Feb 28, 2014
    #23
    My Experience with XS Max: After reading your post I checked my speed and it was poor (65Mbps) Tips: 1. Restart phone 2. If you have the choice of 5Ghz network... choose it 3. Go to Wi-Fi settings, click on the blue Info circle, then click on "Forget This Network". 4. Then find your Network in the Wi-Fi settings, click on it and you will need to re-enter the password. This solved the problem for me, the speed was 217 Mbps on a recheck.
     
  24. azhunter macrumors newbie

    azhunter

    Joined:
    Sep 21, 2018
    Location:
    AZ USA
    #24
    Forgetting WiFi network and reconnecting worked for me. Doubled my speed.
     
  25. netnothing macrumors 68040

    netnothing

    Joined:
    Mar 13, 2007
    Location:
    NH
    #25
    Will be interesting if the Forget Network thing fixes it permanently. I too was getting slow speeds on my all Airport network on my Max. Seemed that unless I was right next to the router, it kept connecting on the N band. I did the forget and it’s back, but time will be the real test.
     

Share This Page

67 September 21, 2018