iPhone4 bluetooth stuck "searching"

Discussion in 'iPhone Tips, Help and Troubleshooting' started by flattopwill, Jul 18, 2010.

  1. flattopwill macrumors newbie

    Jun 25, 2010
    My iPhone 4 will not pair with my headset. When I turn on bluetooth it starts searching and then never stops. It never finds my headset and never stops "searching". I have tried restarting the phone with no fix. I have just installed 4.0.1 and it made no difference. Think there is a problem with my bluetooth antenna?
  2. skunk macrumors G4


    Jun 29, 2002
    Republic of Ukistan
    Restart the phone, go to Settings>General>Reset>Reset all settings. Turn off the headset, turn it on again, go to Settings>General>Bluetooth>ON. Make sure both phone and headset are discoverable.
  3. flattopwill thread starter macrumors newbie

    Jun 25, 2010
  4. skunk macrumors G4


    Jun 29, 2002
    Republic of Ukistan
  5. flattopwill thread starter macrumors newbie

    Jun 25, 2010
    It is called a Chatterbox. It is for in-helmet motorcycle communication. I have connected to it using my iPhone 3G hundreds of times.
  6. skunk macrumors G4


    Jun 29, 2002
    Republic of Ukistan
    My Apple earpiece, which I had been using for years with my original iPhone, did not connect at first with my iP4, but following a reset it finally did. It seems the iP4 does have a potential issue making the initial connection. Once it's paired, though, it's fine.
  7. flattopwill thread starter macrumors newbie

    Jun 25, 2010
    Well, Ill keep trying. Thanks for your help. Im going to a town with an Apple store in a few weeks on a trip. While there Ill have a genius look at it.
  8. chazim macrumors newbie

    Aug 10, 2010
    Confirmed BT Issue

    I just received my iPhone yesterday. I have the same problem with my Bluetooth where it gets stuck search for devices.

    The OS version I have is 4.0.1 (8A306).

    An Apple Genius at the Apple store confirmed that it is a known issue and they are working on a software fix.

    I tried the display models at the store. They have the same problem.
  9. CSMchris376 macrumors regular

    Mar 13, 2010
    My son's iPhone 4 pairs with his Jabra Stone and my Motorola H780 just fine. Is this supposed to be a know issue for all iPhone 4's and all bluetooth headsets, because I haven't seen this?
  10. flattopwill thread starter macrumors newbie

    Jun 25, 2010
    Its probably like the reception issue with the iPhone 4 - its not every phone.

    I hadnt had a chance to go to an Apple store to ask about the problem (since its three hours away) but Id figured that was the type of answer Id get. OR just end up with a new phone. Hope they fix this soon.
  11. sanjubhai macrumors newbie

    Aug 20, 2010
    Same issue - iphone 4 bluetooth stuck searching

    flattopwill / chazim,

    any update on your bluetooth issue?
    I got the iphone 4 last week - same problem - it stays stuck searching with the little wheel spinning.

    upgraded to 4.0.2 didnt fix the problem :-(

    is it a hardware or software issue, since not many people seem to face this problem?
  12. flattopwill thread starter macrumors newbie

    Jun 25, 2010
    Sorry sanjubhai, no update on my end. I haven't had a chance to go to a genius bar to talk to them about it.

    I'm thinking it's probably a hardware issue since it's so few phones with the problem. Ultimately we will probably get new iPhone 4s when they figure out the problem and we go to an Apple store to make the complaint.
  13. edtorious macrumors 65816


    Aug 14, 2007
    San Diego, California
    you have to set your bluetooth headset in pairing mode first and then your iphone 4 will find it and then you have to put the code in.
  14. flattopwill thread starter macrumors newbie

    Jun 25, 2010
    I've connected with this headset a thousand times using my 3G. Once you turn this headset on it's in pairing mode. Besides, it won't even find my MacBook. Just sits there searching. With my 3G it would search for a bit then if it didn't find anything after a while it would stop searching. This iP4 just keeps searching forever.
  15. Khaver macrumors newbie

    Jan 7, 2011
    I got exactly same problem with my iPhone 4! Any idea people?
  16. flattopwill thread starter macrumors newbie

    Jun 25, 2010
  17. edtorious macrumors 65816


    Aug 14, 2007
    San Diego, California
    I bought a bluetooth speaker for my car and when I turn it on, it's not on pairing mode, it will search for any device that paired with, so even if I have my iPhone's bluetooth on, they will not connect if I have not set up the pair mode for the first time. I have to put it in pairing mode and then I go to my iPhone bluetooth and once it finds my bluetooth speaker I select it and enter the code.

    After I finished pairing it, the next time I turn on my bluetooth speaker it will search for any device I've paired with it without going on pairing mode and then it gets connected with the iPhone automatically. I only need to do the pairing mode once and only the first time.

    If you're saying you're headset does not have a separate pairing mode, please double check your headset's manual, if there is really no pairing mode then I'm sorry but I can't help you. I don't know what else you can do.
  18. ridiculousq macrumors newbie


    May 4, 2011

    i feel like i should point out that he said it wasn't finding anything at all and that everything you just said didn't help at all

    im also having this problem so if anyone finds a solution please let me know because nothing has worked so far
  19. LittleDarkOne macrumors newbie

    Sep 8, 2011
    Another one...

    Just to report that I have the same problem. :(((
    Im trying to conect my iP4 to my Blackberry and it just won't work. Blackberry finds iP and asks for a numeric passkey and iP is just sat there searching! So blooming annoying!!!
    Did the resetting twice and got the same outcome!

    Has anyone tried talking to Apple about this? Would they replace the phone eventually if it doesn't work?
  20. kennyd macrumors newbie

    Oct 22, 2011
    same problem...with 4S

    Trying to connect my 4s to Ford SYNC (2012 vehicle) and Sync finds the phone's bluetooth and then says, "Please say your pin number after your pin is confirmed back, and say ok."

    It seems I am suppose to have a pin display on my phone that I say back to Sync, but my phone isn't displaying any pin at all. Not in the bluetooth area or main screen...nowhere.

    The phone's Devices just keep searching...always...in the car...away from it....I turn Bluetooth off to stop the searching.

    New car, new phone....no hands-free. Nice.
  21. periyasaame macrumors newbie

    Nov 1, 2011
    iphone bluetooth Devices Searching problme

    I have I phone, when the BT was enabled it keeps on Searching the nearby BT devices. No result.

    The phone was reset and restarted no result. This is not finding any of the BT devices

    Help is needed.

    Chennai, India
  22. echaos1210 macrumors member

    Jul 15, 2010

    I am also having an issue finding bluetooth devices can this be an issue with the operating system? Has anyone gont to an apple store and gotten a replacement of the iphone 4S or have they given a solution
  23. deeddawg, Nov 10, 2011
    Last edited: Nov 10, 2011

    deeddawg macrumors 604

    Jun 14, 2010
    Haven't had an issue here, bluetooth works fine with my car (uConnect on a Jeep).

    Couple thoughts...
    • Pairing an iphone & blackberry together isn't likely to work as neither is likely looking for another phone to pair with.
    • Make sure the devices you're wanting to pair with are in pairing mode
    • I'm not familiar with Ford SYNC, but try here; I had no trouble pairing to my car (non-ford), but I don't remember which side asked for the pairing code. Only thought is see if you're pairing from the phone to the car or vice versa (i.e. which one is searching for the other) and if one direction doesn't work try the other.
    • If you'd previously used an iphone4 with a device, upgraded to iOS5, be sure to delete all the pairing and repair each device you were using.
  24. soulynx, Jan 8, 2012
    Last edited: Jan 8, 2012

    soulynx macrumors newbie

    Jan 8, 2012
    I had the same problem, just kept searching constantlay. I have a Jabra and so i went to the Jabra pairing site, http://www.jabra.com/Sites/Mobile/NA-US/support/pages/pairingguide.aspx , the site is great and it gives every jabra device vs every phone device option to pair with. After you choose it gives specifics: it worked!!!! I suggest going to your bluetooth website if you don't have a jabra. You can't just turn on your jabra, or probably some other bluethooths, to make them pair. That worked because it had already been paired with the previous phone, as mine was. Apparently I have had it so long i forgot how I initially paired it; I too, thought it should pair when I turned it on. This problem is not with the iPhone 4...there is specific pairing instructions for bluethooths, and mine is an expensive one that does also have specific requirements. I did not have to put in the passkey or a pin in my iphone 4s; it worked at the point of #7: "Touch the BT530 in the list." This site has clear pictures with pop up windows at mouse over for the below instructions. Very clear and nice. Hope this helps.

    Pairing Instructions for the Jabra BT530 and Apple IPhone 4S


    Pairing compatibility: Devices tested successfully

    As you follow the instructions below, move your mouse over each step to see an illustration.
    1. Touch Settings
    2. Touch General
    3. Touch Bluetooth
    4. Ensure Bluetooth is turned On
    5. Slide the Power switch to turn the BT530 on
    6. Press and hold the Answer button until you have a constant blue LED
    7. Touch the BT530 in the list
    8. The passkey for the BT530 is 0000 (4 zeros)
    9. Enter the PIN
    10. Touch Done
  25. Kimjo macrumors newbie

    Jan 23, 2012
    Same issue here

    Just bought my boyfriend and I the iPhone 4S, bluetooth does not work on both phones. Since they are brand new, we knew it must be a problem with the phone. We went to the apple store and made an appointment with the genius bar. The "genius" informed us that there was an update for the phone that was only available at the store. Apparently our phones have version 5.0.1 and apple came out with a 2nd version with same exact update number 5.0.1, soo if you connect your iPhone to your iTunes, it will think you are already using the most up to date version. The only way to get this update is at the apple store and it seems that they are very familiar with the Bluetooth issue. After he did the update, he said he would need to reset the phone. We waited 10 min for the phone to reset, he brought out a Bluetooth keyboard and tested the bluetooth. Voila! It worked! He was able to connect to the keyboard with no issues. He then said to make sure we rebooted the phone from iCloud in order to restore our apps and contacts. Of course, this reboot can only be done via wifi and takes about 30 min, so we left and finished the reboot at home. And guess what? As soon as the phone restored, the Bluetooth stopped working. We are extremely frustrated. We just want the damn thing to work without getting that stupid searching icon for hours. So we haven't gone back to the apple store to complain again but we are guessing that when we rebooted our phones from iCloud, it also restored the old version and blocked the Bluetooth again. The only way around it might be to get the update, reset the phone and NOT back up from iCloud. It will be like you just got the phone new, with none of your previous apps or settings (maybe even contacts). Obviously this is still extremely inconvenient. Hope this helps anyone out there with the same bluetooth issues.

Share This Page