iphone4 wont work with os x 10.4.11

Discussion in 'iPhone' started by mulletonabike, Jun 24, 2010.

  1. mulletonabike macrumors newbie

    Joined:
    Oct 15, 2009
    #1
    After waiting in line for over three hours today for the new Iphone Im still yet to get it up and running.
    Im currently using an two year old macbook and running Tiger 10.4.11 which does the job for me.
    When I plug my iphone4 into my mac it says that it cannot be used as it requires 10.5.8 or later.
    Im not happy with Apple as I were unaware that this would be the case. I now need to find a version of OS X that it will work with. Ive been searching for the last 3hrs to solve the problem and had no luck.
    Can anyone assist me what/where to download OS x as I certainly do not want to be paying anymore money as ive already spent £200 today.
    Many thanks.
     
  2. Virtuality macrumors member

    Joined:
    Oct 30, 2007
    #2
    http://www.apple.com/iphone/specs.html

    Always a good thing to check "system requirements" before buying something that expensive. It's on the box too.

    If you have a MacBook, just buy the Snow Leopard Retail (yeah, requires Leopard according to the license, but you can install it just fine on a computer running 10.4).

    29 dollars for such an upgrade is bloody cheap.
     
  3. FSMBP macrumors 68020

    FSMBP

    Joined:
    Jan 22, 2009
    #3
    For something you paid that much money on, it would have been a smart move to look at technicial specs. iPhone 4 only works with Mac OS X Leopard or newer.

    Best move is to get Mac OS X Snow Leopard. That's $30 USD.
     
  4. PoitNarf macrumors 65816

    PoitNarf

    Joined:
    May 28, 2007
    Location:
    Northern NJ
    #4
    No one here is going to assist you with pirating software, against forum rules. Just go out and pick up a copy of snow leopard from the store like others have already said.
     
  5. mulletonabike thread starter macrumors newbie

    Joined:
    Oct 15, 2009
    #5
    Cheers for the advice peeps and apologies for the piracy comment. Im a newbie!
    Had a feeling I would have to get hold of Leopard. I'l get it ordered right now as it isnt too pricey.
    As for looking into the requirements, I never even gave it a thought that i'l need Leopard as I was that excited about making a purchase!
    Why is it that it will only work with 10.5.8 on a mac and will work on windows 7,vista,xp & pro? Pc's can bugger off!
    I may just sell it on ebay as there going for £700 :) Haha
    Thanks again.
     
  6. Virtuality macrumors member

    Joined:
    Oct 30, 2007
    #6
    I'm glad you're considering going out and buying 10.6. :) It's the right way to go.

    As for supporting XP, that is because more than 50% of today's computers are running XP (source). But hardly half a percent uses 10.4.
     
  7. reyno28 macrumors member

    reyno28

    Joined:
    Jun 17, 2010
    #7
    Funny how a Apple product works just fine with Win 7 and not this Mac OS..YOU FAIL..PS Get a PC and Win 7 then you won't fail. My iPhone 4 works fine on my PC :).
     
  8. broncopde macrumors 6502

    Joined:
    May 12, 2007
    Location:
    Conway, AR
    #8
    It's still crazy! That 0.5% of total users is something like 10-15% of Mac users. It just doesn't seem like there is any reason Apple could not have the iPhone 4 support Tiger. Maybe there's something that I don't understand about it, but it smells of simply giving people another reason to pick up Snow Leopard which, as stated, is going to be a great upgrade for the OP, but still, he shouldn't have to).
     
  9. Virtuality macrumors member

    Joined:
    Oct 30, 2007
    #9
    Well, I don't know. Snow Leopard is cheap as it is. Is Apple really looking to make money there? Seems they could've priced it higher and still sold millions of copies anyways.

    The iPad doesn't support Tiger either, by the way.
     
  10. Rodimus Prime macrumors G4

    Rodimus Prime

    Joined:
    Oct 9, 2006
    #10
    still sad. It goes to prove how little apple cares about supporting older software instead of dropping it and forcing obsoletness.

    Hardware wise apple will not support 2003-2004 Apple computer any more compared to it is still supporting computers for windows up to 10 years old. My PC box is over 6 years old now still running strong and fully supported. It is running itunes 9.2. Yet a max the same age is screwed.
     
  11. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #11
    OP - Sucks, I had the same thing happen to me. It never really occured to me to check the OS requierments (Though XP, Vista, and 7 are all supported)

    This was my situation (copied from another thread on this)

    *EDIT - my superdrive is shot, so I couldn't just do the upgrade from home.

    For you though, assuming you have a workable DVD drive, all you need to do is go pick up the $29.00 SL upgrade disc and install. You'll be fine.
     
  12. squall1 macrumors newbie

    Joined:
    May 26, 2004
    Location:
    Austin
    #12
    This is ********...I think I'll return this thing or sell it on Ebay. Such a crappy thing to do to your user base.
     
  13. Filly macrumors newbie

    Joined:
    Jan 18, 2005
    #13
    Another 10.4.11 dummy here.

    iMac G-5...in perfect running condition, not about to trash it. Can't use the Snow Leopard install and the Leopard retail package is $170.00.

    Will be returning my phone. Sad.
     
  14. cdinca macrumors 6502

    Joined:
    Jun 13, 2007
    #14
    OP, this never would have even occurred to me!

    You are right that there is no reason this must be true. iOS4 only needs 9.2 which works fine on 10.4.11.

    Upgrading systems is no small task. That sucks!
     
  15. mulletonabike thread starter macrumors newbie

    Joined:
    Oct 15, 2009
    #15
    Good old Apple hey. Ive had to fork out and purchase Leopard now :-(
    The corporate money grabbing b******* have done it again! Cheers for the support Mr Jobs. Ive spent thousands with you over the years and this is how you repay me?
    I'l give you the benefit of the doubt as Apple reigns supreme over Microsoft any day.
     
  16. BladesOfSteel macrumors regular

    BladesOfSteel

    Joined:
    Jul 13, 2009
    Location:
    St. Paul
    #16
    Repay you?

    Seriously . . .
     
  17. PG-Monkey macrumors regular

    Joined:
    Jun 20, 2010
    #17
    Are you having a moan just for the sake of moaning? Earlier in the thread you had no issues buying a copy of leopard as in your words 'Not to pricey'

    Then you come back and have a moan - Only person to blame is yourself - You didn't check the specs.

    FAIL
     
  18. WiiDSmoker macrumors 65816

    WiiDSmoker

    Joined:
    Sep 15, 2009
    Location:
    Hermitage, TN
    #18
    I like how you are cursing Apple and then go buy another of their product. You're a lost individual.
     
  19. applemama macrumors newbie

    Joined:
    Aug 12, 2010
    #19
    Iphone 4 wont run on 10.4

    I am extremely disappointed. My Iphone 3g died and everyone was so happy to move me up to the iphone 4 (which I will say is awesome) After 5 trips to AT&T and 3 trips to Apple they located a unit, transferred all my upgrades and disabled my "temporary phone". My 3G unit had worked perfectly from my home computer, a 20 inch G5 unit running 10.4.11 I plugged in my iphone 4 ready to sync up and nothing...wait a lovely message saying it needed 10.5.8 or later to run. This would have been mighty valuable information to know in the stores! Not a single person mentioned that the system requirements would be different...not a one. With all the hype on this unit...I've heard nothing about it not being compatible with older macs. I love these phones but don't really want to upgrade my macs (I have an older ibook g4 as well). Is there an option for me to make this connection work with this machine...it is not an intel until (4 months too early...lucky me). Any help would be invaluable...Apple is 45 minutes away and really don't feel like a 4th trip this week. Thanks!
     
  20. ToroidalZeus macrumors 68020

    ToroidalZeus

    Joined:
    Dec 8, 2009
    #20
    Download a copy of 10.5 Leopard from the usual places, It runs on both Intel and PowerPC computers. Apple doesn't require serial numbers so any copy you find will work but you may need a hack if the iBook is below 867mhz for the installer to run.
     
  21. cdinca macrumors 6502

    Joined:
    Jun 13, 2007
    #21
    10.5.8 will install on all of the machines you mentioned.
     
  22. Virtuality macrumors member

    Joined:
    Oct 30, 2007
    #22
    There is something called consumer responsibility/consumer awareness. You cannot go around hoping that someone else will do all the work for you. No one lied to you. The system requirements are clearly listed on the iPhone box and on the website. Please don't try and blame anyone else. 10.4 Tiger was released way back in April 2005, you don't really expect that someone that is being an early adopter of top-of-the-line hardware such as iPhone 4 will still be running such an old OS at home.

    Anyways, as previously mentioned - 10.5.8 should run fine and is still purchasable from Apple, just give them a call. Don't see why you should download it.
     
  23. cdinca macrumors 6502

    Joined:
    Jun 13, 2007
    #23
    I didn't hear anyone ring the "D-Bag Bell".
     
  24. spillproof macrumors 68020

    spillproof

    Joined:
    Jun 4, 2009
    Location:
    USA
    #24
    You just did.

    Virtuality's comments made a good point. The consumer is responsible for checking the requirements, not the cashier.
     
  25. applemama macrumors newbie

    Joined:
    Aug 12, 2010
    #25
    I get the whole consumer responsibility thing but obviously im not a techno guru or I wouldn't still have a power g5 without intel. Mind you also that the APPLE and ATT salespeople coordinated this transaction full well knowing I had an old iphone 3g that needed to be synced with my g5 at home. We talked about it at length. I take responsibility (thats why I'm trying to find way out) I just find it amazing no one thought to ask or mention this. Having a gee whiz phone doesn't mean you automatically have a gee whiz computer operating system. Apple should understand that because they make a great product it will actually last and folks don't have to run out to get the latest greatest. Now...since I'm NOT computer savvy...am I mistaken to believe that I can not run leopard or snow leopard on a power g5...I thought it had to have the intel processor. Thats why I hadn't considered upgrading until now...no real need! Everything still worked. A little help please...and less judgement (I never claimed I wasnt at fault)!
     

Share This Page