iPhysics install - please help

Discussion in 'Jailbreaks and iOS Hacks' started by ikcikc, Mar 12, 2008.

  1. ikcikc macrumors newbie

    Joined:
    Mar 12, 2008
    #1
    Apologies if this is a naive question - I am quite new to the iPhone.

    I am trying to install iPhysics (1.1) but get an error "You must install BSD subsystem or Cydia first". Please can someone tell me what this means?

    I have a Jailbreaked 1.1.4 phone. Most other apps install and work fine (Caterpillar, Summerboard, etc).

    I do not really know what the BSD subsystem is - but get the sense that it is something not to be messed with...?

    Please help.:confused:
     
  2. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #2
    Bsd


    Go to Installer > Install > System > BSDSubsystem
     
  3. ikcikc thread starter macrumors newbie

    Joined:
    Mar 12, 2008
    #3
    There is no "BSD Subsystem" showing under System???

    And... what does it do - are there any risks?

    ??
     
  4. ikcikc thread starter macrumors newbie

    Joined:
    Mar 12, 2008
    #4
    On looking under "uninstall" in teh Installer - I see I already have BSD Subsystem 2.1 installed (must have been through Ziphone).

    So - can anyone PLEASE shed light on why I might not be able to install iPhone - and am getting the error?

    advice appreciated.,..
     
  5. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #5
    Reinstall BSD Subsystem then.
     
  6. ikcikc thread starter macrumors newbie

    Joined:
    Mar 12, 2008
    #6
    If I reinstall it - do I not risk that it fails to install? Do any of my other applications rely on it - and could it lock up the phone?

    e.g. I have Caterpillar (with Dock & 5 icons), Summerboard, etc?

    Is re-installing it likely to help? Surely it is already installed - and being used by other applications? Is the problem with iPhysics?

    Just being cautious?
     
  7. ikcikc thread starter macrumors newbie

    Joined:
    Mar 12, 2008
    #7
    OK - took your advice - reintalled BSD Subsystem - and it worked...

    No idea why - suspect something to do with difference in installing through Installer and via Ziphone...

    Thanks for the help
     

Share This Page