iPod Touch 2g + 4.2.1 and multitasking causes respring

Discussion in 'iPod touch Hacks' started by Nishi100, Nov 24, 2010.

  1. Nishi100 macrumors 6502a

    Joined:
    Mar 27, 2010
    #1
    I have jailbroken my iPod Touch 2g, and i haven't synced anything or installed anything from cydia; however, I have enabled Multitasking, when using redsn0w.

    Every time I launch an app, then double click the home button, whilst still in the app, and then click on a different app, it causes a re-spring.

    Is anyone else having this issue?
     
  2. mhobb macrumors newbie

    Joined:
    Nov 24, 2010
    Location:
    USA
    #2
    Same Issue

    I came across the same issue today. Haven't figured out what the problem is yet.
     
  3. kuwisdelu macrumors 65816

    Joined:
    Jan 13, 2008
    #3
    Same problem here. Also nothing installed except enabling wallpapers and multitasking.
     
  4. wywern209 macrumors 65832

    wywern209

    Joined:
    Sep 7, 2008
    Location:
    do you rly want to know?
    #4
    It would appear that the 2g hardware is at its limits. Namely, the 128mb ram. It just can't keep up with all of these background processes. Either that or if nothing much has changed to warrant this issue, it is only a bug that apple has no inclination to fix as it occurs under circumstances that are not covered by warranty (jailbreaking).
     
  5. gedgeer macrumors newbie

    Joined:
    Nov 23, 2010
    #5
    ^ I dont think its anything to do with the 128mb of ram because i jailbroke my 3G on 4.0 an got multitasking with redsn0w then i jailbroke 4.1 with multitasking and it worked. Now ive done the same with 4.2.1 and it just crashes :'(
    AND I DONT WANNA GET AN iPHONE 4 BECAUSE I DONT WANT TO GIVE IN TO APPLES STUPID MOTOS! "Keep your iphone for a year, then we'll stop supporting it and we'll find ways and means of putting bugs on your phone to make it slower so you can buy are new devices"
     
  6. Nishi100 thread starter macrumors 6502a

    Joined:
    Mar 27, 2010
    #6
    It's NOT the 128mb of RAM, as I tried adding Virtual memory (via iMemory Enhancer) and that didn't help.

    I'm going to guess that, because multitasking was designed for the iPod touch 3g and 4g; then, now, the switch animation uses the GPU, instead of the CPU (hardware acceleration). And the iPod Touch's GPU cannot handle the background wallpapers, so, as a guess, it cannot handle the combination of a complex, live animation, CPU usage spontaneous increase and the system accessing the RAM, all at the same time.
     
  7. Chrysaor macrumors 6502

    Joined:
    May 16, 2006
    #7
    It doesn't have anything to do with RAM or CPU.
    Reason for the crash is, 4.2 introduces a new animation for switching apps, which isn't supported by the iPod touch 2G so it crashes SB along with all the running apps.
    Multitasking still works, but you need to go back to Springboard to launch an app, don't launch from the bottom bar.
     
  8. Nishi100 thread starter macrumors 6502a

    Joined:
    Mar 27, 2010
    #8
    I though the new animation was just for the iPad?!
     
  9. kuwisdelu macrumors 65816

    Joined:
    Jan 13, 2008
    #9
    That makes sense. If it's the new animation that's incompatible, is there any hope for a fix or not?
     
  10. iAppTime macrumors newbie

    Joined:
    May 16, 2009
    #10
    I got a somewhat similar problem. The multitasking is working fine for me, but when I'm in an app (for example mail app) and I click a link that has to be opened in another app, my iPod crashes and resprings. It's really annoying. Does anyone know how I can fix it?
     
  11. tnsmart macrumors 6502

    Joined:
    Aug 23, 2008
    #11
    Same here. Mine causes a respring in both situations. Very annoying.
     
  12. wordoflife macrumors 604

    wordoflife

    Joined:
    Jul 6, 2009
    #12
    I didn't do it through redsnow, I installed something from Cydia, but no resprings here, although its slow. Which is why i decided to remove it and now its good
     
  13. kuwisdelu macrumors 65816

    Joined:
    Jan 13, 2008
    #14
    This worked for me.

    From the link, you need to edit a plist file in System/Library/CoreServices/SpringBoard.app, and app-to-app multitasking works again.

    As shown in the link, there is a bit of a problem with weird lines showing up on buttons, e.g.,

    [​IMG]

    There's a suggested fix for that, too, but it didn't work for me. Oh well, I can live with that if the multitasking tray works as it's supposed to again.
     
  14. 03 Hodag macrumors member

    Joined:
    Nov 16, 2008
    Location:
    Vancouver, BC
    #15
    As for problems with multitasking causing a respring...

    Don't check "enable multitasking/wallpaper/battery percentage" when using Redsn0w. Instead, only install Cydia. Once jailbroken, install Winterboard from Cydia, then open it up and enable multitasking/wallpaper/battery percentage from the "Select Themes" menu.

    I've had no respring issues with multitasking after enabling it this way on my iPod Touch 2g.
     
  15. kuwisdelu macrumors 65816

    Joined:
    Jan 13, 2008
    #16
    Do you have lines on some of the buttons like above? If not, what does your SpringBoard.app/N72AP.plist look like?
     
  16. tnsmart macrumors 6502

    Joined:
    Aug 23, 2008
    #17
    I have restored my iPod, re-jailbroken, and installed WinterBoard, but do not have any of the three themes you list under "Select Themes." I can also not find them in Cydia. Any ideas? Thanks.
     
  17. tnsmart macrumors 6502

    Joined:
    Aug 23, 2008
    #18
    I found how to enable it:
    Go to Cydia and install "Features" under Tweaks in Sections.

    So far, I have not seen any lines on buttons. However, I still have the same crash/respring issue when switching between apps.
     
  18. tnsmart macrumors 6502

    Joined:
    Aug 23, 2008
    #19
    Well an update to "Features" through Cydia finally gave me multitasking without any crashes/resprings. However, I now have lines where other people described them as well as in my scroll bars and third party app buttons that are not standard iOS interface buttons.
     

Share This Page