iPod touch ipod touch 2g MC version "unknown error" (3194) trying to downgrade from 4.0 to 3.1.3

Discussion in 'Jailbreaks and iOS Hacks' started by Kafluke, Jun 24, 2010.

  1. Kafluke macrumors member

    Jun 20, 2010
    Title says it all. I've stupidly upgraded my MC version ipod touch 8gb and cannot jailbreak. I want to restore to 3.1.3 but now matter what I try it fails. I get the unknown error with a code of 3194 directly after it checks the apple server. I've edited my hosts file already before you ask.

    Can anyone help?
  2. Kafluke thread starter macrumors member

    Jun 20, 2010
    Here is the log file after getting the error again on the 4th computer I tried this on.

    2010-06-24 22:33:40.316 [3076:f50]: restore library built Jun 8 2010 at 18:17:31
    2010-06-24 22:33:40.317 [3076:f50]: iTunes: iTunes
    2010-06-24 22:33:40.317 [3076:f50]: iTunes: Software payload version: 7E18 (option key)
    2010-06-24 22:33:40.515 [3076:fc4]: iTunes: Specifying UOI boot image
    2010-06-24 22:33:40.549 [3076:fc4]: requested restore behavior: Erase
    2010-06-24 22:33:40.601 [3076:fc4]: amai: AMAuthInstallPlatformCreateDataFromFileURL: can't resolve file
    2010-06-24 22:33:43.525 [3076:fc4]: amai: tss_submit_job: error from server=94 (This device isn't eligible for the requested build.)
    2010-06-24 22:33:43.549 [3076:fc4]: amai: kAMAuthInstallRequestCacheLocalizedTssError: cached server error text: (3194) This device isn't eligible for the requested build.
    2010-06-24 22:33:43.549 [3076:fc4]: amai: AMAuthInstallRequestSendSync: failed tss submission: This device isn't eligible for the requested build.
    2010-06-24 22:33:43.549 [3076:fc4]: amai: AMAuthInstallBundlePersonalizePartial: server request error: This device isn't eligible for the requested build.
    2010-06-24 22:33:43.549 [3076:fc4]: failed to personalize the restore bundle: This device isn't eligible for the requested build.
    2010-06-24 22:33:43.549 [3076:fc4]: AMRAuthInstallDeletePersonalizedBundle
    2010-06-24 22:33:43.666 [3076:fc4]: removed personalized bundle
    2010-06-24 22:33:43.666 [3076:fc4]: AMDFUModeDeviceCopyAuthInstallPreflightOptions: failed to personalize bundle
    2010-06-24 22:33:43.800 [3076:f50]: iTunes: Restore error 3194
    2010-06-24 22:33:43.801 [3076:f50]: AMRAuthInstallGetLocalizedStringForServerError: no cached text for tss error code 3194
  3. Kafluke thread starter macrumors member

    Jun 20, 2010
    Fixed it.

    Downgraded from 4.0 to 3.1.2 worked just fine. Weird that it wouldn't go to 3.1.3
  4. visishs macrumors newbie

    Jun 25, 2010
    what did you do?

    I'm still stuck at the same error, I can't even use iRecovery or Recboot
  5. cherieaustralia macrumors newbie


    Sep 4, 2009
    I'm also having the same problem. My iPod touch was updated this morning (Australia) and it's now stuck in recovery mode. Message says The iPod "iPod" could not be restored. An unknown error occurred (37) The software then tells me I must restore the iPod before it can be used but I seem to be stuck in a loop.
    Now it just lies there in dark silence. I'm Hoping someone can find a solution.
  6. Kafluke thread starter macrumors member

    Jun 20, 2010
    I didn't do anything special. I just first added the line in my hosts file and then held down shift and clicked restore. Next I chose my 3.1.2 file and it finally worked. I was having the error before when I tried to downgrade to 3.1.3.
  7. cherieaustralia macrumors newbie


    Sep 4, 2009
    I backed up iTunes and re-formatted my computer and it's still coming up with the same unknown error 37. I'm so disappointed.
  8. allejo macrumors newbie

    Jun 23, 2010
    Los Angeles, California
    Have you tried restoring from DFU mode and not recovery mode?
  9. cherieaustralia macrumors newbie


    Sep 4, 2009
    Yes I learned how to do the DFU thing on youtube, I'd not heard of it before. I've followed the instructions and iTunes opens up with an Apple dialogue and I go through the restore/update process but every time the same unknown error 37 is the result and I'm stuck in the "must restore" loop.
    Do you think Apple will bring out a fix? I don't want to have to buy a new iPod.. this could happen again six months down the track with a new iPod.
    I don't believe this is user caused in this case.
  10. Grim Reaper macrumors newbie

    Apr 1, 2010
    Your lucky day?

    This may be your lucky day, here's the fix for the iphone which may also, most likely, apply to your iPod Touch:


  11. dajunke.mac macrumors newbie

    Jul 5, 2010
    Yes, it is a lucky day for ipod touch as well!

    I just wanted to report that the tip from Grim Reaper saved the day for my son's Ipod Touch. It brought it back to life in minutes. However, the instructions were not that clear, luckily I've been through PC bootcamp so it was not a big deal.
  12. sOwL macrumors 6502


    Sep 25, 2007
    Nerd Cave
    Just in case the Op is interested, i think sn0wbreeze 1.7 can now jailbreak MC versions. You might want to check it out

    edit: You're not getting the same error when trying to restore iOS4 are you?
  13. MarhiiNumba3 macrumors newbie

    Jul 6, 2010
    Okay... Well i'm having the original problem (3194) aaaand i've tried both 3.1.3. and 3.1.2. multiple times and it still hasnt worked :(
  14. winston1995 macrumors member

    Oct 6, 2009
    Gold Coast, Australia
    OK, this is what I did to downgrade my friend's iPod touch MC:

    Make sure you have iTunes 9.2 and the firmware for 3.1.2. Version 3.1.3 WILL NOT WORK!

    You have to edit your 'hosts' file so that Apple can "authorise" the downgrade. Go into Terminal and type:

    sudo /Applications/TextEdit.app/Contents/MacOS/TextEdit /etc/hosts
    You will be prompted for your password, but you won't see anything if you type. This is normal, just put it in and press enter. TextEdit will appear.

    Above where it says localhost, enter a new line and type:

    Code:    gs.apple.com
    so that now, it looks like this:

    # Host Database
    # localhost is used to configure the loopback interface
    # when the system is booting.  Do not change this entry.
    ##      gs.apple.com               localhost    broadcasthost
    ::1                        localhost 
    fe80::1%lo0          localhost
    (That space between the numbers and the letters is a TAB)

    Now save and quit. You can quit Terminal as well.

    (This net bit is taken from the pocketables forum: http://forum.pocketables.net/showthread.php?t=566)

    Your iPod touch should now be in DFU mode, iTunes will tell you that it's in recovery mode and must be restored to use it. This is good.

    Alt-Click (or Shift-Click for Windows) the "Restore" button in iTunes, and navigate to the 3.1.2 firmware for your device. Click restore and it should now go and do it's thing.

    Please, let me know if this works for you.
  15. MarhiiNumba3 macrumors newbie

    Jul 6, 2010
    When you say "go into Terminal" What is that?
  16. winston1995 macrumors member

    Oct 6, 2009
    Gold Coast, Australia
    Sorry, should have made that more clear. If you're on a Mac, the command prompt equivalent is called Terminal. It's found in the Utilities folder inside the Applications folder on your hard drive
  17. Kafluke thread starter macrumors member

    Jun 20, 2010
    Yeah, I've since discovered this and I'm currently running OS4 on my mc model and its tethered JB. (Better than nothing!)
  18. Grasp macrumors newbie

    Jul 25, 2010

    I noticed this. apple puts up their error code meanings. I got a "9" which means data communication failed pretty much a "3194" does too. And i looked at my cord.. and guess what a very small rip at the end, so your frustration might just be because of the cord. But i got mine to work anyway, basically this is easy.

    plug ipod into computer
    Turn off
    Hold sleep/off button on top left down and home button at the same time for 10 seconds (seems to work for me)
    Let go of ONLY the sleep button and count to 20 to be extra careful. your ipod should be in DFU mode. if not done before when "finding" this software it'll show on the bottom right. "New software found. Ipod(DFU)" something like that.
    Download your Generation and software at http://www.felixbruns.de/iPod/firmware/
    Mine is a 2G and this firmware seems to work -> 2.1.2. I figured hey holy **** lets use the default firmware for my generation (i got it with) and it worked. so...ok..
    hold shift and click on restore, and look for the firmware you just downloaded. I found if your screen goes white it means it should work and you did DFU mode right. Less explaining is...

    DFU Mode
    Download Firmware from 3rd party website
    Shift + Click Restore
    Open Firmware
    Oooh **** white screen :(
    Yay! apple
    And factory settings
    Hopefully this works cuz i just registered to post this lol not like others who register for a question :cool:
  19. Grasp macrumors newbie

    Jul 25, 2010
    oh and..

    This helps too..
    If your cheap and on a budget like me, jailbreak temporarily, look up what to use etc.
    Cause you can use DTunes to download music. Thats a pro. to a method that "isnt" well advised at a site that might not allow to such suggestions. so ill put this for fun

    So a con is jailbreaking could also cause memory corruption..but it also does protect from automatic crashes...I heard that..sbsettings...helps.
  20. mphel6 macrumors newbie

    Jul 25, 2010
    Can anyone plz tell me how to do this with Windows?
  21. djarpit macrumors regular

    Jun 9, 2009
    this is the shiiiiii

    cant wait to go home and try it out
  22. Kafluke thread starter macrumors member

    Jun 20, 2010
    All that post is saying is to redirect your hosts file when downgrading so Cydia's server does the authentication using your shsh blobs on file. If you don't have your shsh blobs on file for the particular firmware that you are trying to downgrade to, IT WON'T WORK.

    It doesn't matter what process you follow. I keep seeing, "This worked for me by following these steps..." blah blah blah.

    People, just because you followed some steps to get your ipod to downgrade doesn't mean that if someone else follows those steps it will work!

    The ONLY reason that you are allowed to downgrade is because you were smart enough to save your shsh blobs to either your computer or to Cydia's server DURING THE TIME THAT APPLE WAS SIGNING THEM.

    In other words, if you didn't click "make my life easier" on Cyida homepage back when the firmware that you are trying to downgrade to was the current firmware by apple, your screwed. It doesn't matter what steps you use or what downgrade link you used to find the firmware, if you have shsh blobs on file, it works, if you don't, no dice.

    With most people you don't know until you try. So some hose hound on this forum gets his ipod downgraded and next thing you know there is a big thread on how he "got it to downgrade by simply following these steps", the noobs get all excited and the replies start to hit and usually look like this, "I followed your guide but I'm getting an error".

    The original posters will follow up with, "Well it worked for me".

    It worked for the original poster because he had shsh blobs on file so that process didn't error out for him but it will for everyone else that doesn't have these shsh blobs on file.
  23. smugglepuff macrumors newbie

    Jul 28, 2010

    Where do you recieve your firmware. I tried everything, going into host and adding the line but when I tried my 3.1.2 firmware it still gives me the error.HELP!
  24. Kafluke thread starter macrumors member

    Jun 20, 2010
    Which (if you have been reading this thread and others) tells me that you don't have 3.1.2 shsh blobs on file. AGAIN, it has NOTHING to do with where you download the firmware. You CANNOT downgrade unless you saved you shsh blobs for 3.1.2. You just may be screwed for now (Until there is a JB for 4.0.1) If you want a link to where I get firmware files then use this:


    (all these firmware files are confirmed legit and working so if somebody tells you, "the 3.1.3 fimware is corrupt...yadda, yadda, yadda) they don't know what they are talking about. It just means that they can't downgrade to that specific firmware because they don't have shsh blobs on file so they tell everyone else that the firmware for download from that site doesn't work.)
  25. kiro484 macrumors newbie

    Aug 3, 2010

Share This Page