iPod Touch TOTALLY DEAD?

Discussion in 'iPod' started by JarScott, Jun 29, 2016.

  1. JarScott, Jun 29, 2016
    Last edited: Jun 30, 2016

    JarScott macrumors 68040

    JarScott

    Joined:
    May 19, 2011
    Location:
    United Kingdom
    #1
    My girlfriend found a 4th gen (I think) 8GB iPod Touch at hers which wouldn't switch on. We tried leaving it plugged in all day to see if it would accept a charge, still nothing. I've connected it to my MacBook and opened iTunes, can't get it to respond even to put into DFU mode. I've tried all the buttons press variations and the iPod doesn't give so much as a peep.

    Is it completely dead? Is there anything else I could try?

    Edit: Decided to put it down to a lost cause. We don't need it and didn't even know it existed until yesterday. Just thought it was odd that it would be completely dead beyond salvaging.
     
  2. Belgique macrumors member

    Belgique

    Joined:
    May 6, 2016
    Location:
    Ocala, Floridah
    #2
    Had same issue....bought product called DEOXIT...its in a spray
    can ...sprayed the connector on the ipod and the cable.
    It worked and now I use it in the car for music. YOu can buy it on Amazon.
     
  3. evamoree macrumors member

    evamoree

    Joined:
    Jun 29, 2016
    #3
    Try taking it to a Genius Bar to see if they can get any sign of life out of it, but doubt they will.
     

Share This Page