is microsoft office 2011 working with mavericks?

Discussion in 'Mac Apps and Mac App Store' started by njain, Oct 22, 2013.

  1. njain macrumors member

    Aug 12, 2011
    Has anyone who has updated to mavericks tried to use office 11 and seen that it works?
  2. eekcat macrumors 6502a

    Apr 5, 2010
  3. scaredpoet macrumors 604


    Apr 6, 2007
    Working fine here as well, so far. It might help if you tell us what trouble you're having, if any.
  4. ikrisss macrumors newbie

    Oct 23, 2013
  5. Velin macrumors 65816


    Jul 23, 2008
    Hearst Castle
    Working great.

    If any of you are having trouble, especially on an older machine, do a clean install of Mavericks. Save your data, wipe boot drive, install Mavericks, migrate your data back.

    Also, to save time, after you install Office 2011, here is the latest update file, Link.
  6. Deguello macrumors 6502

    Jun 29, 2008
    All of the Office apps are working for me (Office 365).
  7. AustinIllini macrumors demi-god


    Oct 20, 2011
    Austin, TX
    I had no problems either...outside of the usual Microsoft slowness garbage.
  8. hoodedwarbler12 macrumors regular

    Oct 24, 2012
    Working fine for me. But I just got Pages to try using it instead of Word for a while.
  9. Deguello macrumors 6502

    Jun 29, 2008
    Word and Excel don't seem any slower than Pages and Numbers. I haven't used Powerpoint or Keynote yet, other than to verify that they open.
  10. paulimer, Oct 25, 2013
    Last edited: Oct 25, 2013

    paulimer macrumors newbie

    Jan 3, 2013
    I got some strange issues.

    I want to open a word/excel file from a server using finder, but it says can't find application. But when I opened word/excel first then open the files from there, it worked.
    (added afterwards) *I have no problem opening a file from my own drive.

    My powerpoint files opened are stuck way up so the powerpoint toolbar is hidden up in the mac topmost toolbar. Can't move the windows around because the dragging area is way up there.
  11. WallaWalla macrumors newbie

    Nov 1, 2013
    Word isn't working

    I just got a new iMac and migrated everything from my Macbook except MS Office for Mac 2011. I used the product key to download it from MS. Both Excel and Powerpoint seem to be working, but when I tried to work on my Word docs, I got a message saying "This command is not available because the document is locked for edit", which of course, I didn't do. None of the Word features are working, it's basically read-only.

    I searched in Word's Help to Activate Product, but nothing came up, I also looked for the Office Activation Wizard, which also didn't seem to be there.

    Any thoughts on how I can get Word to work? Yes, I am using OSX 10.9.
  12. Macky-Mac macrumors 68030


    May 18, 2004
    And how about Office 2008? (I haven't updated to Mavericks yet and am trying to identify what other software I'll need to update)

    (yeah, I know 2008 is now ancient, but hey, it's done what I needed)
  13. CoMoMacUser macrumors 6502a

    Jun 28, 2012
    I have only Outlook 2011, and it's working fine. The rest of my suite is 2008, and all of those programs are working fine.
  14. Macman45 macrumors G5


    Jul 29, 2011
    Somewhere Back In The Long Ago
    2011 is all working fine for me, although there are a couple of updates...OP, if you have the autoupdated turned off, try running it to check you have them.
  15. sjinsjca macrumors 68000


    Oct 30, 2008
    No problems here.

    I did have to re-enter the product key on my wife's machine, but that was a clean install. My rMBP was just an in-place upgrade, and no issues.
  16. Gregg2 macrumors 603

    May 22, 2008
    Milwaukee, WI
    Are there any rumors of Office 2014? Since the previous version was 2008, that would be the same interval.
  17. Consultant macrumors G5


    Jun 27, 2007
    Got a screenshot of what happens? If not I would say it's due to a lying 1 post newbie.
  18. CoMoMacUser macrumors 6502a

    Jun 28, 2012
    Just noticed that the up/down arrows are missing in Outlook 2011's message list and in Word 2008.

    I'm not imagining that there used to be arrows, right?
  19. dianeoforegon macrumors 6502a


    Apr 26, 2011
    Try this fix for windows moving

    System Preferences > Displays > Resolution: select "scaled," then back to "best for display."
  20. dianeoforegon macrumors 6502a


    Apr 26, 2011
    Office 2008 works. Entourage has a minor issue where it opens in a new compose window when opened.

    Just like with Office 2011, some users are having no issues where other are having minor issues and a few users are having major issues.

    For anyone having an issue, you should test in a new User to see if the problem is in your User's folder or at the base level. If the applications don't open in the new User, then you need to look at your Mavericks install and possibly re-install Office. If the problem is in your User's folder it is more difficult to track down. Often it takes starting over in a new Identity for Entourage/Outlook or deleting .plist and cache files.

    Everyone needs to run Font Book and delete duplicate fonts. Remove font caches afterwards. Font Nuke is excellent for this.
  21. EVillalobos macrumors newbie

    Nov 4, 2013
    PPT crashing at presentation

    I've just installed the Mavericks and now the powerpoint crases when I try to enter in the presentation mode... any advice?
    Thank you.
  22. 50548 Guest

    Apr 17, 2005
    Currently in Switzerland
    Yes, works fine.
  23. jnlauderdale macrumors newbie

    Jun 10, 2011
    I continue to have issues with Safari and Internet Explorer functions that rely on Silverlight. Don't know which end isn't playing in the sandbox however.
  24. cybertek macrumors regular


    Aug 9, 2011
  25. CoMoMacUser macrumors 6502a

    Jun 28, 2012
    They're also missing from Chrome, Safari and other programs. Has that happened to anyone else? I don't see any settings for them in System Preferences.

Share This Page