Is there any real need to upgrade to 1.1.4?

Discussion in 'Jailbreaks and iOS Hacks' started by themitch, Mar 8, 2008.

  1. themitch macrumors member

    Joined:
    Feb 20, 2008
    #1
    I was just wondering if there was any real point to upgrading to 1.1.4?

    I have a 1.1.3 jailbroken/unlocked/activated 16gb iPhone with lots of apps and stuff on it and if I was to upgrade not only would i have reinstall any apps I wanted to continue using, but I would also have to do it on a friend of mine's too, who is not confident to do it themselves.

    Don't get me wrong, I'm happy to upgrade, but if there's a risk of stuff not working or it really doesn't give me anything, then I'm wondering what the point is?

    Thanks
     
  2. domness macrumors 6502a

    domness

    Joined:
    Jan 14, 2008
    Location:
    Sheffield, UK
    #2
    Safari is alot better to use. And it seems to have fixed the Locate Me and YouTube with Jailbreak which always didn't work for me.

    However, there are a large number of apps that don't work with 1.1.4 (every day more of them are compatible) so stick with 1.1.3 if you want.
     
  3. nickspohn macrumors 68040

    nickspohn

    Joined:
    Jun 9, 2007
  4. GFLPraxis macrumors 604

    GFLPraxis

    Joined:
    Mar 17, 2004
    #4
    Is it possible to use LocateMe with a T-Mobile unlock? It never worked for me and I just figured it was because I was on T-Mobile.
     
  5. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #5
    Install Navizon (that's how the app is called) from Installer. Then use it once to Locate you. After that, close it and Google Maps should start working. Uninstall Navizon if you'd like afterwards.
     

Share This Page