Is Winodws 7 hogging GPU resources that hurt game performance?

Discussion in 'Mac and PC Games' started by ozreth, Oct 24, 2010.

  1. ozreth macrumors 65816


    Nov 5, 2009
    I have been playing Final Fantasy XIV on my 2010 i7 MBP and have to set everything as low as possible and lower the resolution by a lot. Now I know this thing isn't a gaming powerhouse, but that seems a bit ridiculous.

    I read somewhere that for some reason while running Windows 7 in bootcamp it may be running a process that is hogging resources that could otherwise be used for FFXIV.

    Anybody have any insight?

    Thanks : )
  2. jav6454 macrumors P6


    Nov 14, 2007
    1 Geostationary Tower Plaza
    Turn off Aero feature. Also, if the background picture changes, set it to s steady pic. Also, close any programs that might be consuming CPU clock cycles and RAM resources.
  3. ozreth thread starter macrumors 65816


    Nov 5, 2009
    Thank you. Will do! Are these precessions I have to take because I am running win7 via bootcamp or things that you would advise even If I were running a PC? If the latter, than my poor game performance IS due to lack of power, yeah?
  4. roadbloc macrumors G3


    Aug 24, 2009
    Aero features should automagicly turn off when playing a game. This however, is not always the case.
  5. iWolf00 macrumors member

    Jul 7, 2010
    I believe it is too early for your MBP to have issues running any Pc game. You should have your Graphic setting at any game as High as possible and you shall get high fps for the next two years.
    I stopped using my MBP 3.1 for gaming under bootcamp one & half year back. It could handle most of the released game at moderate resolution from 2007 until end of 2008, but in 2009 it became sluggish and slow in running most of the games that had released at that year.

    I advice you look carefully at your MBP and see whether Windows has identified your GPU and check for GPU driver update. No way i7 MBP 2010 can have an issue in running new released game.
  6. cluthz macrumors 68040


    Jun 15, 2004
    Stock drivers are not really good in bootcamp.
    Upgrading drivers will alone give you 20% better performance.
    Also the GPU is underclocked to 500Mhz from 575. It's running 100% stable @600Mhz for me, and I've heard reports of people running it on 700Mhz+
    (I've never tried over 600Mhz)
  7. jakeguy99 macrumors regular


    Jan 21, 2007
  8. huck500 macrumors 6502


    May 10, 2004
    Southern California
    Also, while I was playing FFXIV (in the week after release), my brand new gaming rig with an overclocked Nvidia GTX 470 card and i7 processor (and the latest drivers) ran the game very poorly. It's just one of the many issues with the game itself, not your computer.

    My other issue with the game is that there's nothing interesting to do... have they fixed that yet?:(
  9. Dr. McKay macrumors 6502a

    Jan 20, 2010
    Belgium, Europe
    I've got Vista in Bootcamp and game performance is much better than OS X. Don't know about Win7 (have it on my dell laptop but don't use it for games).

    Make sure you download the latest drivers for your video card, don't use the ones supplied by Apple. I have a ATI Radeon 2600 HD Pro and when I first booted up Vista, my card was recognised as a Mobility Radeon 2600, a slower card. Installing the catalyst drivers from ATI's website soon fixed that...
  10. Sambo110 macrumors 68000

    Mar 12, 2007
    It's the game, not the computer. That game has horrible performance for everyone, even people who could max Crysis and such.
  11. EthanNixon macrumors 6502a


    Sep 30, 2007
    New Jersey
    Windows 7 will always out perform Mac OS X until companies like Nvidia and ATI rework their drivers and developers start keeping Mac in mind.

    However, Windows XP will yield the best performance but you give up DirectX 10, for the most part. Windows 7 performance is generally better than Vista's.
  12. Hastings101 macrumors 68020


    Jun 22, 2010
    I hate to be the bearer of bad news, but the 330m available in the MBPs is not all that great. There's also a chance that the game, because it's so new, isn't very well optimized yet.
  13. Heavenly macrumors member


    Sep 16, 2009
    Northwestern University
    Right click on an application, go to properties and in the compatibility tab check the box to disable desktop composition. That should do the trick :)

    BTW that's only for when the game or program is running, Windows will go back to Aero when you exit it.

Share This Page