Issues upgrading to OS high Sierra MP mid 2010

Discussion in 'Mac Pro' started by pidcin1, Nov 4, 2018.

  1. pidcin1 macrumors newbie

    pidcin1

    Joined:
    May 14, 2018
    #1
    Hello!
    I have a mid 2010 Mac Pro 5,1 12 core 2.93ghz model with the original HD Raddeon 5770 GPU running El Capitan and was hoping to upgrade to high Sierra but am having some issues.

    I download the high Sierra OS from the App Store and it will initiate and a screen pops up saying I need to upgrade the firmware, but the button to initiate it isn’t working. It does mention to turn the computer off and hold the power button until a chime is heard which I do do, however it still doesn’t work.

    I was wondering if anyone can walk me through this process. It would be greatly appreciated

    Nick
     
  2. pidcin1 thread starter macrumors newbie

    pidcin1

    Joined:
    May 14, 2018
    #2
    Is there a guide on here to assist me ?
    Or is it because of my GPU?
     
  3. h9826790 macrumors G5

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #3
    Try another hard drive (preferable use the original one).

    Or try start from clean OS installation.

    You may also try PRAM reset, and then run the HS installer again.

    Anyway, your GPU is good for this job.
     
  4. startergo macrumors 65816

    startergo

    Joined:
    Sep 20, 2018
    #4
    So in a powered off state if you long press and keep the power button pressed do you see the LED turning on? You have to keep the power button pressed (don't let go) until you hear the long beep and a restart. Normally just before the long beep you will see the LED start flashing (don't let go until you hear the long beep). After that you may see a white screen (you may not see any progress)but don't interrupt the process it should restart automatically when done
     
  5. flowrider macrumors 603

    flowrider

    Joined:
    Nov 23, 2012

Share This Page

4 November 4, 2018