Italian, no US, Italian again, NO ...US!!! (keyboard layout)

Discussion in 'Mac Basics and Help' started by lacornucopia, Oct 4, 2008.

  1. lacornucopia macrumors newbie

    Joined:
    Aug 16, 2008
    #1
    I live in Italy, use OS 10.5.5 and all programs in English. Will someone, SOMEONE PLEASE, tell me why my (flat aluminum) keyboard—for months now—continually reverts to Italian after I set, reset, reset and reset it again for US or US Extended?

    Please and thank you.
     
  2. g4cubed macrumors 6502a

    g4cubed

    Joined:
    Jun 2, 2004
    #2
    Just a guess, but what region is it set at? It could be a regional thing that keeps making it revert back.
     
  3. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #3
    I don't know why it happens, but if you go to System Preferences -> International -> Input Menu, you can select which keyboards appear in the keyboard menu. If you deselect "Italian" there, it should not be able to manage to pop up again.

    You should also check out System Preferences -> Keyboard and Mouse -> Keyboard Shortcut. If you look for the checkbox for "Input Menu", you'll see that you can use Cmd-Space or Cmd-Option-Space to switch to a different keyboard. Maybe you have turned that on, and every time you press Cmd-Option-Space your Mac switches to the other keyboard. If that is the case, just turn it off.
     
  4. lacornucopia thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #4
    Dear gnasher729,

    Thank you for your prompt response. I am very familiary with what you've sugggested but, unfortunately, nothing changes. The (American) keyboard always reverts to Italian the Imput Menu!

    ???

    ******************

     
  5. hughvane macrumors 6502

    hughvane

    Joined:
    Aug 25, 2008
    Location:
    Banks Peninsula, New Zealand
    #5
    When you go through the SysPrefs path to set the keyboard to American, lock the SysPrefs against further changes. See if that works.
     
  6. lacornucopia thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #6
    Dear g4cubed,

    Thank you for your prompt reply.

    The region has always been set for US, the keyboard is US layout, the Imput Menu is set for US with Italian unchecked. And yet . . .

    I've never understood why and it become very irritating at times. ???

    **************************
     
  7. lacornucopia thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #7
    Dear hughvane,

    Thank you for your response.

    Please advise: Where do I lock System Preferences? If I click on the Preference Panes' folder >Command I, all seems to be already locked. Or am I going to the wrong place.

    *********************

     
  8. hughvane macrumors 6502

    hughvane

    Joined:
    Aug 25, 2008
    Location:
    Banks Peninsula, New Zealand
    #8
    SysPrefs > Show All. Choose Accounts, which will show the padlock. However, if all your Prefs are already locked, that's why your keyboard keeps reverting to Italian even though you change the setting in International. So, if that is the case, unlock your SysPrefs, THEN change the keyboard setting to US etc, and THEN lock the Prefs once again. Hope that works for you.
     
  9. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
  10. lacornucopia thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #10
    Thank you, nermal!

    The keyboard is (I believe) the latest model, flat aluminum, acquired in the States last January.



     
  11. lacornucopia thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #11
    Thank you again, hughvane.

    I've done as you've suggested. Let's see what happens. But, if this is the case, how can we explain that the US setting remains for varied lengths of time of then and then, one day, again, the keyboard again automatically reverts to Italian?

    :confused:

     
  12. lacornucopia thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #12
    Italian, no US, Italian again, NO ...US!!! (keyboard layout)

    I wish someone knew the solution to my problem. Nothing suggested thus far works! :mad:


     
  13. lighthouse_man macrumors 6502a

    Joined:
    Mar 13, 2005
    #13
    If you have Italian as another input menu language in the International system preferences, make sure that the keyboard shortcut to go through the languages is not a shortcut that is similar to another shortcut that you use in a different program or hit by mistake. Change that and see.
     
  14. lacornucopia thread starter macrumors newbie

    Joined:
    Aug 16, 2008
    #14
    Dear lighthouse man,

    Thank you. My apologies but I really do not understand what you mean. I have US and US Extended checked in International. Nothing else (I have to continually uncheck Italian Pro. In Keyboard & Mouse shortcuts but have unchecked Imput Menu.

    ???

    ******************

     
  15. hughvane macrumors 6502

    hughvane

    Joined:
    Aug 25, 2008
    Location:
    Banks Peninsula, New Zealand
    #15
    I'm going to come in from left field here and suggest that you discard that Apple keyboard and try, just try, a generic Win keyboard, which should be readily available where you are. Cost? Maybe US$15 - US$20.

    As to brand - your choice - but it needn't be a 'name' one like Microsoft or Logitech. I have a Genius PS2 k/b which works admirably via adaptor, and am presently typing on a USB Chicony Excel (a what??). You will need to make some minor adjustments to your usual typing habits but 95% of Win keystrokes are the same.

    Maybe it'll work round the language problem, I really can't predict that, but if it does, your frustration is over (only to be replaced by something else!!).
     

Share This Page