iTunes 11 won't update iOS apps.

Discussion in 'Mac Apps and Mac App Store' started by botsmack, Nov 30, 2012.

  1. botsmack, Nov 30, 2012
    Last edited: Nov 30, 2012

    botsmack macrumors member

    Dec 16, 2008
    Birmingham, AL, USA
    Ever since I downloaded iTunes 11 yesterday it won't upgrade my iOS apps. Clicking on the "Check For Updates" button or pressing CMD+R did nothing — no feedback. In prior versions it would either let me know how many apps had updates or it said there were no updates needed. This doesn't happen anymore.

    Then at some point during the day it decided to say there were 5 apps that had updates. Keep in mind, it never actively alerted me to this. A 5 just popped up next to Apps and the update button changed to say "5 Updates Available". Clicking on the button still doesn't do anything.



    You could also go to an app that had an update and it would change the text of the button for its download to say "Update". Not in this version. Here's iCab Mobile which has an update, but obviously my iTunes doesn't think so.




    I've closed and re-opened iTunes multiple times. I've rebooted the computer. Nothing works. The other issue is that the button that says "Get More Apps" doesn't do anything either.

    [Editted to add]
    Looks like I'm not the only one now:
  2. Osullivan1 macrumors 6502

    Aug 1, 2011
    Go to the Apps section of your library, and click where it says "XX updates available". You'll be presented with a lovely iTunes 8 like page, where you can download all updates or individual ones.

    Strange you can't update apps through their store pages though... :/

    Hope that helps :)
  3. botsmack thread starter macrumors member

    Dec 16, 2008
    Birmingham, AL, USA
    That's what I tried to do. It still won't work.
  4. gr8tfly, Dec 2, 2012
    Last edited: Dec 2, 2012

    gr8tfly macrumors 603


    Oct 29, 2006
    ~119W 34N
    For me, the button worked once after updating to iTunes 11. After that, it seems unresponsive. The "Get More Apps…" button does go to the Store.

    Edit: Doh. Experienced as I am, I had a "doh" moment and forgot I hadn't tried restarting iTunes. After relaunching, the button now works and brings up the normal update window.

    Edit: 11/2/12
    Went to check for updates, and again it was unresponsive (app open overnight). Relaunching iTunes fixes it - but only apparently temporarily.
  5. iynque macrumors newbie

    Nov 6, 2006
    Same problem

    I'm having the same problem since updating to iTunes 11 yesterday.

    Restarting iTunes/my Mac does not fix it.

    Off to Google further... :(
  6. iynque macrumors newbie

    Nov 6, 2006
    Oh, okay iTunes...

    ...and now it works just fine with no changes.

    I'm guessing this is just a problem connecting to Apple's servers.

    To anyone who ends up here in the future, just try again another time. If it doesn't work after a day or two you'll have to figure something else out :p
  7. MattProductions macrumors newbie

    Dec 7, 2012
    I guess I found a solution/fix.

    1) Restart iTunes
    2) Disconnect your iDevice and try updating then.

    It worked for me, so try it out!
  8. chrisrosemusic1 macrumors 6502a


    Jan 31, 2012
    Northamptonshire, England
    I'm downloading 105 app updates as we speak. Automatic downloads doesn't always work for me though :confused:
  9. dmmaus, Jan 4, 2013
    Last edited: Jan 4, 2013

    dmmaus macrumors newbie

    Dec 26, 2012
    Sydney, Australia
    I've been having this problem for about a week now. The number of apps that iTunes 11 tells me needs updating just keeps growing. No matter what I do, restarting iTunes, rebooting, plugging and unplugging my iPad: when I try to download an update, it says it's downloading, then processing the file as usual, but then the updated version just doesn't appear. Apps which change icons with update (e.g. Smurf's Village) don't change to the new icon, and iTunes still says I have updates to download.

    Getting very frustrated - I haven't been able to update any apps for a week!

    EDIT: More info: When I use "Check for available downloads..." from the menu, it tells me I have no updates available. But when I go to the Library|Apps pane, the button at the bottom tells me I have all these updates available, and clicking that takes me to the page where I try in vain to download the updates. The "Get more apps" button takes me to the app store as expected.

    As far as I can tell, downloading the updates actually downloads the updates, iTunes just doesn't replace the old versions with the newly downloaded versions.

    EDIT2: Argh! Mea culpa. I neglected one small detail...

    I migrated from Windows to a new iMac recently. I thought I'd done a successful app update since, but looking at the evidence now, I guess I mustn't have. It turns out the problem was my iTunes Media/Mobile Applications folder wasn't set with write permission for me! I changed the folder permission, and it's working fine now. That's an odd thing to have happen when migrating data from a Windows PC (using Apple's Migration Assistant)... I've found a few other folders had weird permissions on them too.

    Well, maybe this will help someone else in the same situation!
  10. sagecelt macrumors newbie

    Jul 6, 2012
    Well, I've tried closing, disconnecting, restarting, re-connecting and the problem remains.

    The Apps page in the Library says 5 updates are available but when I click on the button it goes to the next page where it says "No Updates Available"!

    Ridiculous! What the hell is wrong with the current version of iTunes?
  11. old-wiz macrumors G3

    Mar 26, 2008
    West Suburban Boston Ma
    Same problem here after going from iTunes 11.0.1 to 11.0.2 .. Under 11.0.1 there was no issue. With 11.0.2 the "check for updates" button does nothing. Sometimes restarting iTunes resolves the problem.
  12. Reen macrumors newbie

    Feb 22, 2013
    same problem here.. have done all the rebooting etc over and over but still nothing. very agravating:mad:
  13. Zeldain macrumors member

    Feb 11, 2011
    Sorry for the necro, but having the same problem... latest version of iTunes and iOS, the option to Update no longer exists... only Get More Apps.

    Quitting iTunes doesn't work. Grrr.
  14. old-wiz macrumors G3

    Mar 26, 2008
    West Suburban Boston Ma

Share This Page