iTunes 12 not grouping album compilations?

Discussion in 'Mac Apps and Mac App Store' started by m021478, Oct 27, 2014.

  1. m021478 macrumors 6502

    Joined:
    Nov 23, 2007
    #1
    Prior to iTunes 12, if you selected a handful of songs and batch edited their metadata, specifying that they were part of a compilation, then iTunes would automatically group those tracks together and display them as a single album in your library, even if each track was by a different artist. This seems to have changed in iTunes 12 or the view option to group compilations is eluding me...

    I recently ripped some of my old "Now That's What I Call Music" discs, and this is what my iTunes library shows me:

    [​IMG]

    As shown in the image below, you can clearly see I have two tracks tagged with the same album, and marked as part of a compilation, but they still show up separately in iTunes:

    [​IMG]

    And this happens regardless of my view settings, or whether I am looking at the tracks in a playlist or directly in the iTunes Library:

    [​IMG]

    [​IMG]

    Obviously what I'd like to have happen here is for all tracks from each "Now That's What I Call Music" album to be shown as a single album listing in iTunes. Anyone have any suggestions?
     
  2. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #2
    iTunes uses 4 fields to determine which albums sort together:
    • Album
    • Album Artist
    • Sort Album
    • Sort Album Artist
    As long as all tracks have matching information in those tags, the album will sort together. So for albums with various artists, put the individual artist name in the Artist field, and put "Various Artists" in the Album Artist and Sort Album Artist fields. The album will sort together. If it doesn't immediately, remove the album from your library and re-add it.
     
  3. m021478 thread starter macrumors 6502

    Joined:
    Nov 23, 2007
    #3
    Dude... friggin' incredible that you managed to chime in with the exact solution to my problem literally within 1 minute of my initial post. You're a rock star second to none! Thank so much for your help!
     
  4. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #4
    Sorry it took me so long. I'm getting old and slow! :D
     
  5. m021478 thread starter macrumors 6502

    Joined:
    Nov 23, 2007
    #5
    I'll let it slide this time... just don't let it happen again ;)

    [​IMG]
     
  6. fernandofg macrumors newbie

    Joined:
    Jul 12, 2014
    #6
    Hi GGJstudios, one question, whats happens if you put the name of the album instead Various Artists in Album Artist field?

    In this particular case, put in Album Artist field: Now That's What I Call Music instead Various Artists

    Or in case of a soundtrack (OST), put in Album Artist field: 8 Mile Soundtrack instead Various Artists

    Thanks in advance
     
  7. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #7
    It doesn't matter what you put in the Album Artist field, as long as it's exactly the same information for all tracks in the album.
     
  8. fernandofg macrumors newbie

    Joined:
    Jul 12, 2014
    #8
    Thanks for your answer, I have one last question,

    I will use Album Artist field from now on but when sorting titles with ''The'' ... For example ''The Aviator'' how can avoid The Aviator be sorted in ''A'', I really want to be sorted in ''T''

    I can't find an option or setting to fix this,

    I am using iTunes 11.4.0.18

    Thanks in advance

    [​IMG]
     
  9. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #9
    You can "Get Info" on a song or group of songs and go to the Sorting tab to edit the Sort Album or Sort Album Artist fields to your preference.
     
  10. fernandofg macrumors newbie

    Joined:
    Jul 12, 2014
    #10
    I don't get it, why in the first place is missing ''The'' in Sort Album Artist?
    Should I get to ''Get Info'' and fix album by album, one by one? I have a lot of albums with this issue...

    Is there another way to edit in bulk in iTunes or in Mp3Tag?

    Thanks in advance

    [​IMG]
     
  11. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #11
    The reason it's like that is that the natural sort order will ignore "The" and "A" leading words in titles, as they're not meaningful words to sort on. If you prefer to sort by those, there is a way to make bulk changes.

    Doug's AppleScripts for iTunes is a great resource for managing your iTunes tags and files.

    The following script will help you copy from Album to Sort Album and from Album Artist to Sort Album Artist. You may need to modify the script to access the sort tags, but it should be a simple process.

    This Tag That Tag v4.2
     
  12. fernandofg macrumors newbie

    Joined:
    Jul 12, 2014
    #12
    Thanks a lot
     
  13. macfilm macrumors regular

    Joined:
    Nov 11, 2007
    #13
    Hi, I'm having the same issue but the above advice has not solved it for me. I have one track hanging lose from the rest of the album, I select both and enter the same album title, artist, album artist but it just won't join up with the rest of the album.

    Any help? iTunes 12.
     
  14. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #14
    Read post #2 in this thread.
     
  15. MonkeyDavid, Feb 7, 2015
    Last edited: Feb 7, 2015

    MonkeyDavid macrumors newbie

    Joined:
    Aug 5, 2011
    #15
    Strange Get Info in iTunes 12

    I believe what you are looking for is "Album is a compilation of songs by various artists." This allows you to preserve that artist names and sorts and everything, but group them.

    Ahh, but where is it? The Get Info has been redesigned in iTunes 12.1 and it seems to be missing. But in fact, in one of the worst design decisions I've seen in iTunes (and, man, that's a long list), you have to scroll down within the Get Info box. Of course there is no indication that's possible, no scroll bars or anything. I use a trackpad, so I just did the two finger scroll while looking at the "Details" tab in Get Info, and there it was. Just select all the songs in the album, click Get Info, then click that box, and they'll be grouped.
     
  16. kornys macrumors newbie

    Joined:
    Feb 10, 2015
    #16
    Thank you! I was trying to remove an album mis-tagged as a compilation, and your comment was the only hint I could find for this bizarre UI decision. Sigh. When my IPod classic eventually bites the dust and I'm forced to move to some other hardware, I'm going to enjoy deleting iTunes from my system...
     
  17. the tortoise macrumors newbie

    the tortoise

    Joined:
    Feb 10, 2015
    Location:
    London
    #17
    I found this thread through searching this problem on Google and after literally years of lurking this site and the forums I have finally registered and made an account just to thank you for this solution. I was having the exact same issue and as you point out, low and behold, just out of sight is the exact checkbox I need, with absolutely no indication of where it was hiding. UI design lunacy.

    Utterly infuriating, but thanks again for solving it for me and for anyone else that finds it.
     
  18. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #18
    Someone who I would like to thank a thousand times found this hint: If you hold the alt or option key while you select "Get Info" from the popup menu, you get the old style "Get Info" dialog and everything is back to normal!
     
  19. beatmolecular macrumors newbie

    Joined:
    Feb 14, 2015
    #19
    Just Scroll the Window

    http://i60.tinypic.com/2rnag6x.jpg


    Just scroll down, and the option is there. I thought apple just forget the option but the option still there. (And put "Various Artist" is only a "solution").
     
  20. jerryhope macrumors newbie

    Joined:
    Feb 16, 2015
    #20
    Compilations on iPhone

    I am new to this site-- this request probably belongs elsewhere please redirect if need be
    My iPhone 6 and my old ipod both show Compilations along with Artists & songs as a sort or selection option. However the songs contained in the compilations group, do not show up in the Songs group. The songs DO show up in iTunes Library along side all songs.. How can I merge compilations so that when searching songs on iPhone & ipod, ALL songs show up ?? When playing all songs in the songs group, the songs in compilations never play
     
  21. keeper macrumors 6502

    Joined:
    Apr 23, 2008
    #21
    This is really great but if you use Apple Music with iCloud music turn on and Apple don't store the Album Artist it will just overwrite it to show nothing.
     
  22. adamklo macrumors newbie

    Joined:
    Sep 14, 2015
    #22
    This is my question, exactly! (I think). I created an account just to follow-up.

    So, on my iTunes, I have a billion compilations (soundtracks, et al). I have them check as a compilation and on my iPod Classic, when I go to Albums iwill show one entry for the album (V/A - Chimes of Freedom). However on my iPhone 6 in any music app, when I go to Album and it will appear. If I go to Compilations, it will show 75 entries (one for each track) listed as V/A - Chimes of Freedom and they are sorted by the Artist name. When I changed the Album Artist and Sort Album Artist to "Various Artists" there is no change.

    Interestingly enough, another album, V/A - Maiden Heaven, shows up as a single Album entry, even though the tagging is EXACTLY the same as other comps. The artist is the individual artists, the album is the V/A album title, and even with Album Artist blank, it still shows up as a single entry. However, when I search for a specific artist from the album (Black Tide) it does not show up in Artist or Album sort. So if I want to listen to Black Tide sing 'Prowler', I have to go to Songs, Comps or search, even if I have other Black Tide albums that show in Artist or Album view.

    Sorry for that. I'm the worst.
     
  23. Bino1970 macrumors newbie

    Joined:
    Nov 5, 2014
    Location:
    New York City
    #23
    I just started to have this issue myself, but the difference is, I've always known what to do. I have always had Various Artist listed in the album artist section for soundtracks and the actual artist if it was a compilation by one artist. However, within the last 2 two weeks when I view "Artist" in the Playlist tab, I get a long list for Various Artists which used to be complied together via whatever soundtracks, etc. they're on. Some of the compilations I have for a single artist i.e. Ray Charles, are suffering from the same glitch. I've removed the Album Artist information and re-added it. I've checked, removed, reviewed, album, album artists, sort album artist, sort artist. I've un-checked compilation and re-checked it. I've restarted my Mac. I've re-downloaded iTunes. I removed some of the files from iTunes and re-added them. Nothing works. It's driving me crazy. Everything was fine (in this case) for years! Also, I don't get how Apple doesn't realize that some compilations are from one artist and not various artists. Screen Shot 2016-01-12 at 6.25.05 AM.png
    Screen Shot 2016-01-12 at 6.33.43 AM.png
     
  24. rhett7660 macrumors G4

    rhett7660

    Joined:
    Jan 9, 2008
    Location:
    Sunny, Southern California
    #24
    Are you using the Sort fields or just the album artist and album fields? From the looks of your screen shot, it looks like AAF and AF. If you are not using the "Sort" fields, what happens when you put the album name in? It should work. This is how I have all of my Various Artist tracks listed and they group by album just fine. IF I do a search based on Artist, they will still show up as one line item with total files underneath.
     
  25. Bino1970, Jan 12, 2016
    Last edited: Jan 15, 2016

    Bino1970 macrumors newbie

    Joined:
    Nov 5, 2014
    Location:
    New York City
    #25
    Thanks for your reply. I was using the sort fields. I just removed the information recently in an attempt to fix the problem. I filled sort items back in. Didn't fix the issue. Ray Charles shouldn't be listed 3 times as if he's 3 different artists. I've sent a feedback report to Apple. I know I'll never get a response.
     

Share This Page