iTunes Remote won't work

Discussion in 'iOS Apps' started by bndoarn, Jul 15, 2008.

  1. bndoarn macrumors 6502a

    Mar 16, 2008
    i can't get the Remote application to work. i open it up and select add library and it gives the the passcode but in iTunes it doesn't prompt me for a passcode or anything, nothing happens. i'm running on Windows XP SP3, "Look for iPhone & iPod Touch Remotes" is enabled under preferences, firewall is turned off, i've uninstalled then reinstalled the app, i've reset the iPod (held down home and sleep/wake). i don't know what else to do. i called apple support and was on the phone for an hour and got nowhere.
  2. CommanderData macrumors regular

    Dec 1, 2007
    Maybe a stupid question, but do you have WIFI turned on on your iPhone, and is it actually connected to the same wireless network that your PC is? If you're in an apartment complex with a hundred different "linksys" access points you'll have to rename your AP to something easier to identify to be sure that both the PC and iPhone are connected to the correct one.

    Also, you mentioned the Windows XP firewall is off, but do you have any others active? Zone alarm, Norton, etc?
  3. bndoarn thread starter macrumors 6502a

    Mar 16, 2008
    my WiFi is turned on on my iPod and my PC isn't wireless, it's wired but it's hooked up to the DSL modem which is connected to my linksys router and my router is the only one my iPod picks up. and i don't think i have any other security programs
  4. DaveGee macrumors 6502a

    Jul 25, 2001
    Well... I dunno if this is a similar issue but...

    I first cranked up the Remote for the first time yesterday... and it found the iTunes without issue... I typed in the passcode and all went off without incident.

    Left the iPod Touch untethered over night on my desk...

    This AM I tried to use the remote and I got 'looking for itunes library' (not sure of the exact wording) and it just sat there...

    I then went to 'add itunes library' and then click edit and proceeded to delete my itunes library. I then tried to re-add it but it didn't work... I then re-tethered the iPod to the computer and tried once again to add the itunes library and this time it worked just fine... I dunno what when on but we'll see what happens after I leave this idle for some time...

  5. bndoarn thread starter macrumors 6502a

    Mar 16, 2008
    i got it now:D. all i had to do was connect my PC to my router. before only my modem was connect to the router.
  6. movielover21 macrumors newbie

    Nov 12, 2007
    Good to hear!

    I was having a similar problem, but I already had my modem connected to my router.

    It was the firewall causing problems. I had to configure the firewall to allow my iPhone's MAC Address , and bingo it worked!

    Have a great day!
  7. ChrisN macrumors 65816


    Aug 27, 2007
    Demarest, NJ
    Can someone help me connecting my remote to my mac. I have an iMac that is connected to my extreme via ethernet and I can't get my iphone to connect to my itunes. Can anyone help?

  8. techage14 macrumors regular


    Aug 4, 2007
    I had the same problem with my iPod touch.
    I had the iPod connected to my iTunes library but, nothing happened.
    I read a post somewhere and found out that my firewall was blocking
    the connection to my iTunes library. So, I went to System Preferences > Security > Firewall and clicked on the 'Allow all incoming connections' button.
    And, presto! My iPod was able to connect to my iTunes library wirelessly.
    The only thing that I don't like about this is that I have to keep my firewall open to all incoming connections!! It makes me nervous.
  9. ChrisN macrumors 65816


    Aug 27, 2007
    Demarest, NJ
    Nope, didnt work for me.

  10. Full of Win macrumors 68030

    Full of Win

    Nov 22, 2007
    Ask Apple
    I don't know if this might help - but here is my story.

    I connect using some funky proxy settings on my MacBook, and I had to change it to the default settings before it would work. I then switched back to the proxy I have to use, and it still works.
  11. Soreo macrumors regular


    Jul 1, 2008
    I have the same exact problem- remote won't see my library and my library won't see my iPhone. So I don't really know what to do.
    iPhone and comp both connected to same wireless router- I'll try turning off my firewall.
  12. badgerman macrumors 6502a

    Jun 9, 2008
    me neither on PC, turning off firewall doesnt seem to help.

    Its strange as VNC lite seems to work fine...

    ANy suggestions anyone?
  13. b3nmitchell macrumors newbie

    Aug 23, 2008
    I HAD the same problem... This was my solution

    I had the same, or at least very similar problem. The difference was that I got the remote working, but when I restored my phone and tried to get remote working the second time, Itunes didn't prompt me for a passcode.

    I tried everything here, no dice.

    But here is what DID work for me (hopefully it will help you too)

    I went to Edit > Preferences > Advanced

    Then on the 'general' tab about two thirds down the page next to the checkbox that says "look for iphone & iPod touch Remotes" was a button


    I clicked that button and confirmed that I wanted itunes to forget all remotes.

    Then I launched the 'Remote' app on the iphone and added library, the PASSCODE PROMPT showed right up!

    Hope that helps someone else!
  14. naoc2k macrumors newbie

    Aug 25, 2008
    I Found The Solution.............

    Hi there..... While looking for a solution why my iphone didn't found my itunes library I tried this.......

    1. Go to System Preference / Sharing / Firewall
    2. Check Itunes Music Sharing

    And that tethered my iphone with my Itunes..... that basically open connections for itunes in your firewall leaving the rest blocked. Also make sure that in itunes the checkbox for Looking for Iphone and Itouch is enable. Hope that this helps any one. In my case it did....... Good day everyone......

    --Iphone 3g
    --MacBook Pro 2.4
  15. toolbox macrumors 68020


    Oct 6, 2007
    Australia (WA)

    OH thanks this worked a treat!!
  16. RUShane08 macrumors newbie

    Apr 15, 2009
    Anti-Virus Firewall

    Make sure to check your anti-virus software firewall. For instance, my McAfee security had itunes on "outbound access only." I had to change the setting to full access; problem solved.
  17. JAT macrumors 603

    Dec 31, 2001
    Mpls, MN
    Anybody have further thoughts on this? I can't see anything causing a problem. It worked yesterday, today it doesn't. And when I last fiddled with this, maybe 3 weeks ago, I couldn't get it to work. Frankly, I don't know why it worked yesterday, that seems to be the anomally, unfortunately. It usually hangs at "connecting to library".

    Mac Mini Intel Core Duo
    iPod Touch 16GB (1st gen)
    Actiontec DSL modem, GT701-WG (standard Qwest with g wireless)
    OSX 10.4.11, with all updates including last week's
    iPod and modem: also most current firmware
    Firewall: Off
    iTunes: set to look for remotes, and set to open at boot since it is my server for the house
    Airport Express: set only for Airtunes for remote speakers

    I can get to the internet on the iPod. I can use iSilo's funky ftp system to access my Mac. It's just Remote that fails of all the apps I have that are networkable.

    Oh, and the iTunes server always works with a laptop, and the Airtunes work if I physically use the Mini to play. Just Remote fails. It's starting to piss me off, I wouldn't have bothered with the Express if I didn't have the iPod and Remote.

    I even try deleting the library from Remote and setting it up again. iTunes instantly recognizes it every time. But it still won't connect once set up.
  18. ihunter macrumors newbie

    Jun 18, 2009
    Another experience with IPod/remote - make sure Wifi is strong!

    • Wifi on mac and ipod to (fairly) distant wireless access point.
    • Ipod gives code, type it into mac and mac gives up after a while.
    • All things checked (firewall etc.) - seem OK, but no libraries.
    • Moved the ipod downstairs, very close to access point.
    • BINGO - works well.

    HTH Somebody

    Ian Hunter
  19. tmboyd3114 macrumors newbie

    Sep 13, 2009
    How I got mine to work

    I noticed most post have all Apple/Macs. I have Vista, McAfee and Defender. I thought it was the McAfee so I tried allowing the program, etc. When that didn't work, restored my McAfee settings, turned off the Defender and it (remote) launched right away! Hope this helps!! :D
  20. jkontente macrumors newbie

    Jul 14, 2010
    Could somebody help!

    I had been intensively using iphone Remote Application for over a year without any problems whatsoever. I have over 150 Gb of music on my itunes library and Remote is a life saver. I am a very big fan of the app. Unfortunately, I had a system breakdown in my computer due to a virus attack a month ago and I had to reinstall Windows to my computer. Since then, when I open remote application on my iphone and ask to add library, the code on the iphone screen appears but my iphone does not appear on the device list in itunes.

    I don’t have any problems synchronizing my iphone with itunes when they are connected with the cable. More interestingly other applications on my iphone such as “Air Mouse” and “RemoteX” can easily connect wirelessly and work with my computer. I have uninstalled and reinstalled itunes (alltogether with bonjour, quicktime, itunes support etc. as thoroughly explained on the support page). I also uninstalled and reinstalled the remote application both on the computer and on the iphone.

    My configuration details are as follows:

    iphone 3g
    Windows xp Professional sp3 on HP Compaq nx7400 lap-top.
    All connected on airties rt205 router.
    Windows firewall is disabled.
    Eset nod32 anti virus program is disabled.
    Both my iphone and the computer are on the same network.
    No other computers on the same network.
    On itunes, “Edit/Preferences/Devices/Look for iphone remotes” is active. “Share my library on my local network” is active.

    Remote app. on my iphone can connect to other itunes libraries in other computers without any problems. When I try to connect itunes on my computer with my sisters iphone it still doesn’t work. So there must be something wrong with the itunes on my computer. I have been trying to solve this problem for a month now. Could you please help me?
  21. soulman99 macrumors newbie

    Dec 14, 2010
    Finally fixed it

    My remote app was working fine on both my ITouch and IPhone 4g. I was using it to control streaming of music from my ITunes library to speakers around the house usingh Airplay. Then a few days ago I couldn't connect to my remote library. I tried everything on the forums to no avail. ITunes would prompt for a passcode and then just hang and fail to connect.

    My solution was to simply switch off my Netgear router and switch it on again and then everything worked fine. No idea why this worked but I can't believe I didn't think of doing this before messing with ports/firewalls etc. and all the other suggestions.
  22. CAT4X4 macrumors newbie

    Dec 18, 2010
    iTunes Remote wont work

    @soulman99 THANK YOU SO MUCH!!!!!! i dunno why i didnt think of that either ....working now woo hoo !!! THANKS AGAIN .:)
  23. MariusInMD macrumors newbie

    Dec 28, 2010

    Your problem EXACTLY describes mine!! Any luck!? :cool:
  24. OutSpoken macrumors 6502a

    Jun 9, 2009
    Thanks @soulman99

    I was racking my brain for weeks to get this thing to work, reading all the troubleshoots and even called applecare! and pretty much gave up because nothing helped, until this evening when I updated to 10.6.6 and thought i'd give it one last go and whaddayouknow... it worked for the first time!:eek: I didn't even need to enter a passcode! So i thought great, but then after playing around with it for a few minutes, all of sudden it stopped pairing.:(

    But just now I tried thee old turn off and on trick on my router and its working again :D
  25. Haroldj macrumors newbie

    Mar 27, 2011
    My solution

    After about an hour of frustration I finally found a solution to the remote can't connect issue. I have a windows 7 pc and iPhone running iOS 4.2.1 and while my iPad would connect my iPhone would not both on 4.2.1 after repeatedly entering the 4 digit passcode I realized that homesharing was fighting with the remote app to make the connection so I turned off the wifi on my iPhone opened the settings menu in the remote app and deleted the connection to my pc, *since I had already entered my home sharing info into the remote app I closed and reopened the app and it connected immediately hope this helps :)

Share This Page