iTunes unnecessarily syncs many tracks to iPhone apparently at random

Discussion in 'Mac Apps and Mac App Store' started by digitaldave, Jul 3, 2017.

  1. digitaldave macrumors regular

    digitaldave

    Joined:
    Apr 6, 2006
    #1
    I have an odd issue with iTunes... When I connect my iPhone to sync the library (e.g. I've imported a new CD), iTunes will apparently randomly decide it wants to sync a load of extra tracks (usually by album, often many hundreds of tracks) that shouldn't need updating as they should already be on the iPhone, and haven't been played in a long time (so it shouldn't be updating things like play counts). I've had a couple of instances recently where I haven't been able to listen to albums because they haven't been downloaded to the iPhone, which I assume is something to do with this. I'm currently running:

    iTunes 12.6.1.25
    macOS Sierra 10.12.5
    iOS 10.3.2

    iTunes is set to sync the complete music library when I click the sync button when the iPhone is connected.

    As far as I can tell, I don't have an Apple Music account...

    Can anyone help with this? It's starting to get annoying!

    Thanks,

    Dave.
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Have you got the option to ‘fill available space’ selected under the music tab??
     
  3. digitaldave thread starter macrumors regular

    digitaldave

    Joined:
    Apr 6, 2006
    #3
    Thanks for the reply.

    I can't see that setting anywhere in iTunes. When I go to the music tab under settings with the iPhone connected, I get the following options:

    Sync Music (this is ticked)
    Entire music library (selected)
    Selected playlists, artists, albums and genres (not selected)
    Include videos (not selected)
    Include voice memos (not selected)

    Dave.
     
  4. gnasher729 macrumors P6

    gnasher729

    Joined:
    Nov 25, 2005
    #4
    If you sync the entire library, it will sync music until your phone is full. Now if your phone needs storage, for example because you take a photo, they iPhone might look at your music and say "I can remove that to get some empty space, I can always sync it again". If you then make more space available, iTunes will fill the space again.

    I'd say create a playlist with everything you want on your iPhone, and sync that playlist only.

    If you don't have much space available, there is a setting that will compress your music to 128 Kbit/s instead of the usual 256 Kbit/s, so it takes half the space but at somewhat lower sound quality. The syncing is a lot slower, so you'd want to sync a playlist to avoid re-syncing.

    PS. iTunes _will_ sync information about "genius" play lists that lets you play one song, and then pick songs similar to that. That should happen quite quickly. Look for something to disable genius play lists.
     
  5. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #5
    There's your culprit. Should be pretty obvious!
     
  6. digitaldave thread starter macrumors regular

    digitaldave

    Joined:
    Apr 6, 2006
    #6
    Thanks for the replies. However, I'm not sure they will solve the problem. Here's the details of the storage on my iPhone...

    Total: 128gb
    Used: 65.52gb (of which 56.09gb is music, my entire music collection)
    Available: 56.09gb

    So, the phone had always had my complete music collection on it, and even with it all there, there is still plenty of space left, so I shouldn't need to change to 128kbps, and shouldn't have to just out a sub set of my music on.

    My issue is that it never used to do this, and I don't understand why it's uploading tracks to the iPhone that are already there. And I don't understand why some albums were unavailable when there has always been plenty of room for them.
    --- Post Merged, Jul 4, 2017 ---
    Not really, see my post above about available space...
     
  7. T'hain Esh Kelch macrumors 601

    T'hain Esh Kelch

    Joined:
    Aug 5, 2001
    Location:
    Denmark
    #7
    Ah, I misunderstood your problem then. Do you by any chance have iTunes Match activated?
     
  8. digitaldave, Jul 4, 2017
    Last edited: Jul 4, 2017

    digitaldave thread starter macrumors regular

    digitaldave

    Joined:
    Apr 6, 2006
    #8
    No problem, I wrote the original post in a bit of a hurry, so may. It may not have been clear, sorry about that.

    I'll check iTunes Match later, but I'm fairly sure I don't have it enabled.

    If I can't get to the bottom of this, I might just switch to managing the library on the iPhone manually, I guess that would solve things...
     

Share This Page