Jailbreak / Activate / Unlock EVERY iPhone version with ZiPhone

Discussion in 'iPhone' started by Vasileios, Feb 11, 2008.

  1. Vasileios macrumors regular

    Vasileios

    Joined:
    Oct 28, 2005
    Location:
    Greece
    #1
    - Unlock / Change Imei (ONLY on 4.6 BL (112 and 113 OTB).
    - Jailbreak on ANY OS version.
    - Activation on ANY OS version, except for youtube on 1.0.X.

    Tested on a v1.1.1 BL 3.9. Restored via iTunes to v1.1.3 - Ziphoned and then anySim 1.3 NOW it's on v1.1.3 with baseband 04.03.13_G FULLY working!!!

    Check this out: http://www.iclarified.com/entry/index.php?enid=655
     
  2. ert3 macrumors 6502a

    ert3

    Joined:
    Dec 10, 2007
    #2
    Thats great now only if there was a mac port or perhaps a mac port or perhaps a way to do this on windows without iTunes.

    Infact does anyone know if i where to use a windows computer that does not have iTunes installed or has synced with this phoneif it would work. I think i am going to give it a try.
     
  3. ert3 macrumors 6502a

    ert3

    Joined:
    Dec 10, 2007
    #3
    Tried in windows XP with no itunes to no avail (probably because i did not let drivers install)

    Tried in XP with itunes(not running just installed) and allowed for drivers to install.

    Worked like a charm, my only wondering is if the unlocking now means i need to restore before update to avoid brick.

    I started with a 1.1.2 AT&T OOTb non hacktivated iPhone running 1.1.3 at the time of attempt.
     
  4. Sobe macrumors 68000

    Sobe

    Joined:
    Jul 6, 2007
    Location:
    Wash DC suburbs
    #4
    If only we had a forum for hacks/jailbreaks...man that would be so cool.
     
  5. liberty4all Guest

    liberty4all

    Joined:
    Jan 7, 2007
    #5
    The Mac port worked fine for me on a PPC w/10.5.2, and you have to use iTunes 7.4.2 (does not work on newer iTunes, does not work on 10.4.11)

    Get the files here (this .zip has the Mac binary):
    http://upload2.net/page/download/i9ZRMsnJAvUqX5A/ZiPhone.zip.html

    Get old iTunes from http://oldapps.com and use Pacifist to install it.

    Do a chmod 777 on the .dat file if you have problems, and be sure to change directories to the ZiPhone folder before running!

    Usage: ziphone [-u] [-a] [-j] [-i imei]
    -u: Unlock (Only for 4.6 BL)[Using Unlock can fix many dead basebands]
    -a: Activate
    -j: Jailbreak [TRUE JailBreak for 1.1.3]
    -i: Change IMEI Code (Only for 4.6 BL)
    -v: Verbose boot (debug)

    Cheers!

     
  6. hard-case macrumors regular

    hard-case

    Joined:
    Jul 10, 2007
    #6
    YMMV, but while this did "jailbreak" the phone, it also "broke" my Yahoo mail. When broken I can authenticate the account just fine, and can send mail just fine, but receiving mail gives me a server connection error, that the username and password are incorrect. The workarounds I found both failed.....running Yahoo mail in Safar then trying to check in Mail did nothing and installing the Youtube patch from Installer broke YouTube.....
     
  7. hexonxonx macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #7
    Jailbreaking along with unlocking breaks the locate me in maps.
     
  8. liberty4all Guest

    liberty4all

    Joined:
    Jan 7, 2007
    #8
    Use iTunes to restore to 1.1.3, then use ZiPhone, everything should work just fine -- mine does.

     
  9. liberty4all Guest

    liberty4all

    Joined:
    Jan 7, 2007
    #9
    Run Navizon or Locate Me from the installer to fix the map locate me feature...

    Be sure you have 1.1.3 stock restored, before doing ZiPhone (i.e. did not do the soft-jailbreak first -- if so, restore to stock 1.1.3 first)

     
  10. hexonxonx macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #10
    Yes, I will try your ideas there. I did run Ziphone from a fresh install, then restored from a backup.

    I just downloaded Navizon and that fixed the Locate me. Locate me in installer didn't fix it.

    Thanks for the help.
     
  11. citybythebay macrumors newbie

    Joined:
    Feb 12, 2008
    Location:
    San Francisco, CA
    #11
    This ziphone sucks REAL bad! PLEASE HELP!!!

    This is ridiculous! I have a refurbished 4gb week 47 OTB Iphone running 1.1.3. I do a fresh restore of 1.1.3 to my iPhone from iTunes. I put my iPhone into Recovery mode and I load ziphone and type ziphone -j and hit enter. It finds the iPhone and says wait 45. The iPhone eventually comes out of Recovery Mode and reboots into normal mode. Everything looks like it went fine, no error messages however Installer does not appear on my screen. Ziphone sucks royally and I hope iPhone DEV can do a more PROFESSIONAL job at creating a working patch. Is there ANYONE who may know what is wrong? I would greatly appreciate it.

    Thanks
     
  12. liberty4all Guest

    liberty4all

    Joined:
    Jan 7, 2007
    #12
    Ensure you are using iTunes 7.4.2, and try the updated 1.1 ZiPhone version here:

    "New features:
    no more need for recovery mode!
    no more "difficult" things :)
    just run ziphone and it will do everything for you :)"

    http://zibree.blogspot.com/2008/02/ziphone-11-out-mac-version-too-link.html

    http://rapidshare.com/files/91327136/ZiPhone.zip.html


     
  13. jpga13 macrumors newbie

    Joined:
    Feb 12, 2008
    #13
    I got the new ZiPhone to run on my mac but I get an message that seems to continue to cycle while installing:


    BSD root md0, major2, minor0

    Any help would be appreciated! Thanks!
     
  14. liberty4all Guest

    liberty4all

    Joined:
    Jan 7, 2007
    #14
    Which OS version, CPU and iTunes versions?


     
  15. jpga13 macrumors newbie

    Joined:
    Feb 12, 2008
    #15
    OSX Leopard, iTunes 7.6, Macbook Pro

    I'm using the latest version of Ziphone with the mac version included.

    I used the ziphone -j -v so I could watch it run on my ipod and it has that message over and over.
     
  16. TurboSC macrumors 65816

    TurboSC

    Joined:
    Aug 4, 2007
    Location:
    California
    #16
    Ive yet to try this, but i'm hearing mixed feelings as of now.
     
  17. oldimac macrumors regular

    Joined:
    Jan 18, 2008
    #17
    Apologize for the stupidity of my question but.....

    How do you do this so it will work with T-Mobile? (No AT&T here).

    Thanks :eek:
     
  18. nickspohn macrumors 68040

    nickspohn

    Joined:
    Jun 9, 2007
  19. ViPa macrumors 6502a

    Joined:
    Dec 4, 2007
    #19
    im using mac osx and when i type in the ./ziphone it keeps saying "permission denied" ..what am i doing wrong

    edit, heres the exact message:
    my-comp-macbook:ZiPhone mycomp$ cd ~/Desktop/ZiPhone
    my-comp-macbook:ZiPhone mycomp$ ./ziphone
    -bash: ./ziphone: Permission denied
     
  20. jpga13 macrumors newbie

    Joined:
    Feb 12, 2008
    #20
    You need to reset permissions and run from Admin account but it doesn't matter until they fix the BSD root error
     
  21. liberty4all Guest

    liberty4all

    Joined:
    Jan 7, 2007
    #21
    Those having trouble should try the 1.0 files from the upload2.net link above in this thread -- that version worked like a charm for me -- 10.5.2, G4 PPC, iTunes 7.4.2...

    Or, you can try 1.2:
    http://zibree.blogspot.com/
     
  22. hexonxonx macrumors 601

    Joined:
    Jul 4, 2007
    Location:
    Denver Colorado
    #22
    I got this to work as promised on two of my 1.1.3 iPhones. It unlocked and jailbroke both of them. Only problem was that YouTube didn't want to work anymore on my 16GB iPhone so I restored it back.

    You just can choose to jailbeake only, you have to do it all or nothing. If you jailbreak only, installer doesn't get added.
     
  23. ViPa macrumors 6502a

    Joined:
    Dec 4, 2007
    #23
    how do i do that? i only have one account on my computer, and i believe it should be the main admin lol
     
  24. HOiYA macrumors member

    Joined:
    Feb 13, 2008
    #24
    Anyone had any luck with only running ziphone with -a and -j? For me, the phone boots up but no connection to ATTWS. I am running the iPhone with a pre-existing Cingular (ATTWS) sim.
     
  25. liberty4all Guest

    liberty4all

    Joined:
    Jan 7, 2007
    #25
    YouTube works fine on my 1.1.3 Jailbroken iPhone, and Installer *did* get added!

     

Share This Page