Java Update unsigned application error

Discussion in 'Mac Programming' started by jamroman, Jun 16, 2012.

  1. jamroman macrumors newbie

    Jun 16, 2012
    I recently downloaded the the Java 2012-004 update. I am trying to open an application and the error message says, "Unsigned application requesting unrestricted access to system." The application was working fine before I updated Java.

    Can anyone please give some guidance to getting around this?


  2. gnasher729 macrumors P6


    Nov 25, 2005
    So you wrote a Java application, and you now get this error message. It should be obvious that it is a huge security risk if any Java application gets unrestricted access to the operating system. That's what code signing is for: You tell Apple you who are, they give you a key to sign your applications, and because they know who you are, they can send either their lawyers or some ninjas around if your signed application does anything nasty.
  3. vdmk2006 macrumors newbie

    Jun 19, 2012
    I had the same issue

    Hi jamroman,

    I had the same issue and a few days ago I managed to fix it.
    So here is what worked for me.

    I launched the Java Preferences app which is located at Applications->Utilities.
    Then went to the Security tab and under "Signed content from these sites runs whiteout prompting" deleted the url of the problematic java.
    After then i relaunched it and everything worked again.

    I hope this helps you solve your issue
  4. silpheed macrumors newbie

    Jun 21, 2012
    This worked for me.
    Thanks vdmk2006. Saved me a bunch of time trying to figure this out. :)
  5. mistapony macrumors newbie

    Mar 15, 2008

Share This Page