Just aquired a A1186-2180 MacPro, difficulty installing OS

Discussion in 'Mac Pro' started by mrrhtuner, Apr 13, 2016.

  1. mrrhtuner, Apr 13, 2016
    Last edited: Apr 14, 2016

    mrrhtuner macrumors newbie

    Joined:
    Apr 14, 2012
    #1
    Hey guys, yesterday I was able to pickup a MacPro A1186 EMC 2180 for a decent price ($160.00).

    It didn't come with a hard drive so I took to the forums to plan out my next steps. I tried to install a Sandisk SSD drive but the SSD doesn't mate well with the MacPro drive holder and my 3.5" adapter that I have doesn't work as nice as it should.

    I threw in a seagate 7200rpm drive, used Transmac to create the El Capitan image on my windows machine.

    I plugged both in, turned on the unit and held down the ALT/Option key.

    The screen gave me a icon for installing El Capitan and then a loading bar appeared. The bar went about halfway and then prompted me with a circle and a line through it without any messages.
    I dug around on the net last night trying to figure it out and seem's others have had this issue before.

    What I did to try to remedy this was to remove the drive, delete all the partitions and set the drive as GPT.
    That didn't work. I am unsure if I need the ones windows hard drive to be formatted in a specific manner to be able to install the OS?

    Could my USB drive be not formatted properly? I did the same thing a few days ago when I was putting Leopard on a usb stick and it worked fine.

    Thank you
     
  2. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #2
    Never mind, it looks like the 2180 is an early 2008, which does support El Capitan.
     
  3. mrrhtuner thread starter macrumors newbie

    Joined:
    Apr 14, 2012
    #3
    Thanks chrfr for confirming that.
    I did some reading last night and thought my macpro was a 2009 but now I see it's a 2008 and El Capitan should work on it.

    Thus is why I'm a bit confused, does the drive have to be formatted or some kind of base partitions created? Hard to believe...but anything could be possible.

    Is there a way to find out why the Mac is hanging up on that error? Some kind of code I can try to pull with a configuration?
     
  4. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #4
    Yes, a new disk needs to be partitioned as GUID in Disk Utility to boot El Capitan. The OS X installer will not format or partition the disk itself, so open Disk Utility from the menu where you select to install OS X.
     
  5. CapnDavey macrumors 6502

    CapnDavey

    Joined:
    Apr 11, 2015
    #5
    do you have an older downloaded installer like before april 16th if so get a new one they had a certificate expire in most of them big bo bo from Apple
     
  6. mrrhtuner thread starter macrumors newbie

    Joined:
    Apr 14, 2012
    #6
    CapnDavey,

    I'm fairy new to Mac's really. I have an iMac I was able to repair but it's quite outdated (iMac G5 20").

    Are you suggesting to get another .dmg image? Maybe I'll try a previous Mac OSX version prior to El Capitan.
     
  7. mrrhtuner thread starter macrumors newbie

    Joined:
    Apr 14, 2012
    #7
    So last night it got me thinking. I did more reading on this prohibitory error and tried to tackle my usb stick.

    I have a 16gig lexar usb drive. Normally I was using TransMac to prepare the usb drive and copy El Capitan onto the USB drive.

    Didn't work.

    Next I tried to prepare the USB drive as a GPT drive rather then MBR and then use Transmac to put the image on the drive and try to use it.

    Didn't work.

    I'll pull the hard drive out today and test it again to make sure it's GPT. I know the drive works fine, windows detects it and it's silent.

    This is a Sata 3 drive, I hope that wouldn't be an issue...would it?

    I am also getting the previous Mac OSX image from work so I'll give that a try later.
     
  8. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #8
    Try using your iMac to make your USB installer.

    Format your hard drive is GUID!!!

    SATA 3 drives works fine.
     
  9. mrrhtuner thread starter macrumors newbie

    Joined:
    Apr 14, 2012
    #9

    The iMac that I is a G5 20" running leopard 10.5.8.
    So I would be best to move the .dmg image to the iMac and try to make it from there?

    Formatting my MacPro drive for GUID, can I hook up the drive to the iMac using a sata to USB adapter and get it formatted that way?

    Sorry for all the newbish questions, I'm trying to research this as we go along also.


    Edit: I found out how to partition to GUID on the iMac:

    http://forums.macrumors.com/threads/how-do-i-format-guid-for-a-hardrive.418136/


    I'll follow this to format the drive for GUID in windows also:

    http://www.lomcn.org/forum/showthread.php?73416-Format-to-GUID-Using-Windows
     
  10. scott.n macrumors 6502

    Joined:
    Dec 17, 2010
    #10
    Simplest thing to do would be to buy a DVD copy of Snow Leopard, install it, then upgrade to El Cap through the App Store.

    Alternatively, try and borrow a friend's Mac running a more recent OS and create the USB installer using it.

    You can try copying the DMG to your iMac and creating the USB installer on it, but according to this article the createinstallmedia command bundled in the installer is only supported in Lion+. (There's some other info in that article about creating the installer in Snow Leopard, though, that might be relevant.)
    --- Post Merged, Apr 14, 2016 ---
    Additional question, how did you manage to get an El Capitan .dmg without another Mac running 10.6.8 or later? I would be very hesitant installing from a copy downloaded outside the App Store.
     
  11. pastrychef macrumors 601

    pastrychef

    Joined:
    Sep 15, 2006
    Location:
    New York City, NY
    #11
    You can make your USB installer using Disk Utility. I think that 10.5.8 should be able to do it...
     
  12. mrrhtuner thread starter macrumors newbie

    Joined:
    Apr 14, 2012
    #12

    Okay fella's, so here's where I'm at.

    I used my iMac G5 to create Yosemite dmg usb boot disk.
    I restarted my MacPro...it would do the same thing as El Capitan.

    Believing it's no longer a USB issue, I downloaded Snow Leopard, put that on a flash drive using my windows desktop and Transmac and popped it in.

    Snow Leopard started the installation and thankfully it gave me the installation options.

    As I clicked "next", it showed me no hard drive listed to install the OS on. This made me confirm my suspicions that something with the partition/drive setup I didn't do.

    [​IMG]



    I was able to use Disk Utility to create the partition as I learned from a link above and got the process started :)


    [​IMG]



    Now to learn more about this unit :)
     

Share This Page