Keyboard randomly stops working

baryon

macrumors 68040
Original poster
Oct 3, 2009
3,470
1,253
Sometimes I'm trying to type something and I realize that nothing's getting typed when I press the keys. I don't know what causes this and when exactly it happens, but so far I have not been able to make it go away unless I reboot.

When the keyboard stops working, it's completely dead: Not only can I not type, but key combinations like [ Cmd + W ] and [ Alt + Arrow keys ] for swapping Desktops doesn't work either. As I remember though, the light on Caps Lock still works normally.

Within one week it has happened to me twice so far, and I rebooted each time and that fixed it.
 

wadey

macrumors newbie
Oct 21, 2008
1
0
a working keyboard is important

I'm having the exact same problem with Lion. One time I tried putting the computer to sleep and bringing it back but the keyboard still did not work (and I could not type password to get back in).

The next time it happened I logged out of my account and the keyboard started working again on the login screen. Can you confirm the same behavior?

Also, maybe we can find out if a specific app is causing this. I believe that I was using either MacVim or iTerm2 both times this happened to me, can you correlate with that?
 

bmauter

macrumors member
Sep 3, 2010
37
3

chrisrk7

macrumors newbie
Mar 29, 2010
1
0
Same issue

I have a 17" MacBook Pro from 2007 (OSX 10.4.11) that's doing the same thing: the keyboard arbitrarily decides to stop working and I usually have to reset to fix it. A couple times I was able to regain use simply by going to a different program. I never had this problem before, but in the last month or so it has stopped working about 8 or 9 times.

I don't know if it's related, but in the past couple days I noticed a significantly slower processor speed, one that leaves me staring at the spinning rainbow of doom far too often for far too long and it is starting to drive me crazy. I don't mean to derail this thread, I just don't know whether or not it could be relevant to diagnosing the problem and thought I'd rather be safe than sorry, so-to-speak.

Help!
 
Last edited:

viruz.360

macrumors newbie
Nov 10, 2009
3
0
I'm having this exact same problem.

Sometimes it happens just randomly, but it also happens anytime I switch to Dashboard using ctrl-left.

I've resorted to just opening Activity Monitor (using only the mouse...) and killing the Dock process.

I'm using a fresh install of Lion on my Late 2008 MacBook Pro.

edit: I narrowed down the problem:

I disabled Dashboard as per this hint: http://www.macworld.com/article/46236/2005/08/disabledashboard.html

Now, If I press crtl-left, dashboard doesn't appear but the keyboard still freezes.
I also noticed that it freezes when pressing crlt-right (but not ctrl-up/down).

I suppose this has something to do with spaces (but AFAIK you can't disable spaces in Lion).

edit: I attached a small applescript-app to kill the Dock (easier than going to activity monitor everytime).

Also, do any of you use a DisplayLink device with your mac? There might be a link between the DisplayLink drivers and the keyboard lockup problem.
 

Attachments

Last edited:

quietstormSD

macrumors 6502a
Mar 2, 2010
978
218
San Diego, CA
I had this problem with a late 2007 Macbook Pro 15" model. I read in a forum somewhere where someone had a similar issue and it appeared that a ribbon cable beneath the battery apparently warped or became more lose. The simple fix was to place a sticky-note folded up placed in between the copper-ish cable and the battery and carefully close the battery. This worked for me. If you have a unibody Mac this obviously won't work since you can't remove the battery.

This person appears to have the same or similar problem.

http://lbarclay.wordpress.com/2009/01/29/macbook-pro-trakpad-and-keyboard-not-working/
 

MasterHowl

macrumors 65816
Oct 3, 2010
1,017
17
North of England
I'm having this exact same problem at the moment as well. It happened once a week with Lion, but it happenes at least once a day with ML.

I've got a mid-2009 15-inch MBP. So frustrating.

Anyone got a fix?
 

plumsauced

macrumors newbie
Mar 6, 2015
1
0
try pressing alt 5 times

Hi Guys,

Try pressing alt five times - this enables and disables the "mouse keys" function which disables the keyboard.

I have to credit this to brownknee at mac forums: http://www.mac-forums.com/forums/os-x-operating-system/278436-keyboard-stops-working-photoshop.html#post1436578

https://support.apple.com/en-ca/HT203157

I thought this was an issue related to photoshop, and have been searching for a fix for a long time, so happy to share this. Just found brownknee's answer today and thought I'd share.
 
Last edited:

-tunes-

macrumors newbie
Aug 20, 2013
7
0
None of the above solutions have worked for me. Whenever typing in Word, Apple Mail, Text Edit, or any other text app including filling in text fields in Safari, typing abruptly stops. I can go do a new window and it works. I can open another text app and it works. I am starting wonder if any of the following apps might be the culprit:

Keyboard Maestro
Typinator
Karabiner
Seil

If anyone shows up here looking for a solution to this issue maybe this information will help us narrow down what the issue is.
 

handcoding

macrumors newbie
Jul 12, 2017
1
0
Dallas, Texas
I am starting wonder if any of the following apps might be the culprit:

Keyboard Maestro
Typinator
Karabiner
Seil

If anyone shows up here looking for a solution to this issue maybe this information will help us narrow down what the issue is.
-tunes-: I’m also seeing this problem, and if you’d be interested, I’d be up for working together to try to figure out what’s causing this. For what it’s worth, here’re some of the input-related apps running on my machine:
  • BetterTouchTool
  • Karabiner
  • Keyboard Maestro
  • LaunchBar
  • PopClip
  • Shortcat
  • Stay
  • SteerMouse
  • TextExpander
P.S. If it makes any difference, I’m running 10.11.6.
 

Cookiepress

macrumors newbie
Sep 15, 2019
1
0
Sometimes I'm trying to type something and I realize that nothing's getting typed when I press the keys. I don't know what causes this and when exactly it happens, but so far I have not been able to make it go away unless I reboot.

When the keyboard stops working, it's completely dead: Not only can I not type, but key combinations like [ Cmd + W ] and [ Alt + Arrow keys ] for swapping Desktops doesn't work either. As I remember though, the light on Caps Lock still works normally.

Within one week it has happened to me twice so far, and I rebooted each time and that fixed it.
This only happens to me on FB. It has happened to me almost every day in the last several months. I have to log out of the program and go back in and it works for a little while then I have to do it again.