laggy MBP 15'' after only a month...

Discussion in 'MacBook Pro' started by PurpleShaman, Oct 24, 2010.

  1. PurpleShaman macrumors member

    Joined:
    Sep 18, 2007
    #1
    i purchased my base 15'' MBP around a month ago. everything was pretty good until around a week ago. I installed a couple of plugins for firefox, and things have been pretty laggy recently. Browsing site like ESPN have become choppy and even scrolling around the iTunes store has been laggy. I uninstalled Firefox and it's still still laggy with Chrome and Safari. Is there any way I can manually uninstall plugins? I feel like this might have something to do with Flash...How can I fix this?

    thanks!
     
  2. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #2
    Have a look at Activity Monitor ( Applications / Utilities / ) and select All Processes and sort by CPU to see what the culprit may be.

    image below uses sorting by CPU as an example
    [​IMG]


    To properly uninstall applications:

    from Best way to FULLY DELETE a program?
     
  3. Frosties macrumors 6502a

    Frosties

    Joined:
    Jun 12, 2009
    Location:
    Sweden
    #3
    Check to see if you have a document trying to print that can not be done. It is a usual suspect in cases like these.
     
  4. AnodizedFish macrumors member

    Joined:
    Jul 19, 2010
    #4
    To uninstall apps, I think it's better to use CleanMyMac :p
     
  5. jav6454 macrumors P6

    jav6454

    Joined:
    Nov 14, 2007
    Location:
    1 Geostationary Tower Plaza
    #5
    Might be failing HDD... if everything in your system (like CPU load, RAM usage) checks out, it might be your HDD is failing.
     
  6. stylinexpat macrumors 6502a

    stylinexpat

    Joined:
    Mar 6, 2009
    #6
    Did this happen before you got Chrome? I would get rid of Chrome. Firefox and Safari are good enough.
     

Share This Page