Last APP syncable version of iTunes not syncing apps

JackP

macrumors member
Original poster
Jun 3, 2009
49
0
I’m still using IOS 10 as I have a bunch of 32bit apps that are mission critical.
I am aware that Apple removed the ability to sync apps in the last few versions of iTunes, so I am still using iTunes 12.6.53 – the last version to support app sync.

So now I am trying to sync some apps from my iTunes library that were legally purchased and downloaded under my existing App Store account some time ago. These apps no longer are maintained by the developer and are not in the App Store any longer to download directly to the device.

When I try to sync them with any of my IOS devices running (non jailbroken) IOS 10.x I get a message that iTunes is not authorized to sync these items and I should go to Accounts – Authorize this computer. I have authorized and deauthorized/reauthorized the computer several times but still get the message.

When the computer is really not authorized clicking on the app produces a dialog box to authorize the iTunes account. When I manually authorize the computer from the iTunes menu clicking on the app no longer asks me to sign in to the account as you would expect, but trying to sync the still says that the computer is not authorized.

I also installed iTunes 12.6.53 on a Windows PC (originally tried on a Mac) and get the same error so I don’t think it is a glitch on the specific machine. I have a bad feeling that Apple is blocking it on their end some how.

Any ideas, workarounds or other way to get my legal apps in MY LEGAL phone?
 
Last edited: