Latex on Terminal Mac OS 10.4.9

Discussion in 'Mac Programming' started by ScKaSx, Sep 10, 2007.

  1. ScKaSx macrumors regular

    Feb 27, 2006
    Hi All,

    I used to have a PowerPC running 10.3.9 which I had running Latex from the terminal quite successfully. I had commands latex, pdf2latex, etc.

    I recently upgraded to a MacBook Pro now running 10.4.9 sporting the Intel Chip. I am trying to gettiing OOoLatex and latex to work from the command line. However, $PATH cannot locate latex or pdf2latex commands. I have Fink and have tried installing the two packages: tetex and tetex-texmf, all to no avail. I was wondering if anyone has had this problem or knows how to solve it. Thanks much.

  2. ScKaSx thread starter macrumors regular

    Feb 27, 2006

    Note this problem originated when I was trying to get OOoLatex to work from the command line following the steps on this site:
    Any insight would be appreciated!

  3. Cromulent macrumors 603


    Oct 2, 2006
    The Land of Hope and Glory
    Seems pretty simple. Download the binary and run ./ from the terminal.
  4. jtalerico macrumors 6502

    Nov 23, 2005
    Helpful.. Really.. lol

    Anyway... in the terminal

    > echo $PATH

    > locate pdflatex

    Find where pdflatex is located.. and add it to your $PATH. in your .bashrc or whatever shell you are using.

    Since I am still on a PPC mine is located..

    but there is a i386 version one directory down...
    drwxr-xr-x 259 root wheel 8806 May 20 17:45 i386-apple-darwin8.6.1
  5. ScKaSx thread starter macrumors regular

    Feb 27, 2006
    thanks for the earlier posts

    however... I don't even have pdflatex and latex to locate in my directory anywhere. And yes I suppose I could download the binary and install it but I would much prefer to go through fink. I guess my question is what should I ask fink to install for latex functionality (fink install ?). Thanks again,

  6. jtalerico macrumors 6502

    Nov 23, 2005
    So you are telling me the command "latex" is located no where?

    Did you try updating the locate db? If you have installed latex i am sure it is installed somewhere.

    Anyway, I installed latex from binary... What is wrong without using Fink?
  7. ChrisA macrumors G4

    Jan 5, 2006
    Redondo Beach, California
    So you want to know where Fink put the executable so you can add it to PATH? Try Spotlight. It'll find it for you.
  8. AlmostThere macrumors 6502a

  9. ScKaSx thread starter macrumors regular

    Feb 27, 2006
    Hi Guys,

    thanks for all the help. I'm still working on the solution.

    I think I wasn't clear enough, but I thought by using "fink install tetex" it would install all the necessary latex files for me. However there have been two problems:

    1) Fink fails to compile the gd package bundled in tetex with the following error:
    "Failed: phase compiling: gd2-2.0.33-3 failed"
    Since it stops there it fails to compile the following:
    *I've tried installing these files individually through fink and they give the same error message that it fails to compile. Anyone had this problem before?

    2) If the latex and other associated latex commands are in one of those packages then I don't even have latex installed. Or I need to "fink install ?" something else to get it. The most obvious command that came to me was "fink install latex" but naturally that didn't work.

    Anyways, thanks again for all your help, I'll keep plugging away at it or just try the MacTex install. I guess I feel like I did this before with fink so I should be able to do it again.

  10. AlmostThere macrumors 6502a

    Doesn't fink use apt-get install tetex for pre-compiled binaries?

    May need a preceding 'sudo'
  11. ScKaSx thread starter macrumors regular

    Feb 27, 2006
    okay so I tried "sudo apt-get install tetex"

    and I get the following error:
    "Sorry, tetex is already the newest version.
    You might want to run `apt-get -f install' to correct these:
    Sorry, but the following packages have unmet dependencies:
    tetex-base: Depends: t1lib5-shlibs but it is not going to be installed
    E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution)."

    Any clue what this means?

  12. AlmostThere macrumors 6502a

    Have you got installed (and importantly, installed before you installed fink)?

    It should be in /Applications/Utilities
  13. ScKaSx thread starter macrumors regular

    Feb 27, 2006
    Yes I do, and it was installed before Fink

  14. mward333 macrumors 6502a


    Jan 24, 2004
    Just to offer my two cents here: I must put in a vote for trying MacTeX:

    I've used fink and also the TeXLive distribution itself (before MacTeX) for many years, but I finally gave up on both of those....

    The MacTeX installation of LaTeX has everything that a Mac user could want in a TeX/LaTeX distribution. I just had to recommend this to you. I type absolutely everything in LaTeX, and MacTeX is the installation that I rely upon. Easy, fast, worry-free..... Life is too short to do anything different. Give it a try!

    Good luck to you. Again, sorry for just inserting my two cents here!
  15. Eidorian macrumors Penryn


    Mar 23, 2005
    And if you're going to go the MacTeX route I suggest this mirror.

    It's fast.
  16. andes200 macrumors newbie

    Apr 24, 2009
    Latex on Terminal Mac OS 10.4.9

    make sure to restart your shell, so that path is updated to wherever your latex binaries are.

Share This Page