Leopard CPU High Usage

Discussion in 'macOS' started by cell-gfx, Oct 25, 2007.

  1. cell-gfx macrumors member

    Joined:
    Oct 18, 2007
    Location:
    Auckland, New Zealand
    #1
    I have two processes, ATSServer and mdworker that between them are taking about 50% total CPU under Leopard. Anyone got any ideas?

    Pic here.
     
  2. hotdamn macrumors 6502

    Joined:
    Jan 24, 2007
    Location:
    Ottawa, ON, Canada
    #2
    i'm running the 559 beta and those processes are lower than 1%.
    Are you experiencing any general slowness? Is it ALWAYS like that?
     
  3. robbieduncan Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #3
    ATSServer is the server for Apple Type Services. Either it's trying to do something like cache a lot of font details (do you have a lot of fonts installed or it's broke).

    mdworker is likely something to do with Spotlight. If this is on a new install then I'd consider this normal.
     
  4. Catfish_Man macrumors 68030

    Catfish_Man

    Joined:
    Sep 13, 2001
    Location:
    Portland, OR
    #4
    mdworker is definitely spotlight. It'll calm down once it's done indexing.
     
  5. cell-gfx thread starter macrumors member

    Joined:
    Oct 18, 2007
    Location:
    Auckland, New Zealand
    #5
    Ah, yes. I do have a few fonts and yes, new install with a lot of files (including a nearly full 300Gb external drive).

    In fact, I have just spotted this - The Spotlight icon is animated while it's indexing. Very subtle, but handy!

    Oh, and Jing works in Leopard too!
     
  6. cell-gfx thread starter macrumors member

    Joined:
    Oct 18, 2007
    Location:
    Auckland, New Zealand
    #6
    Wow! After realising that this problem was related to the Spotlight process, I clicked on the icon in the toolbar and got the following readout :

    [​IMG]

    How long to index?!
     
  7. simontarr macrumors 6502

    simontarr

    Joined:
    Sep 4, 2006
    Location:
    England
    #7
    ZOMG! Tahts liek longer than te life of teh UNIVERISE to index!!
     
  8. Nutter macrumors 6502

    Joined:
    Mar 31, 2005
    Location:
    London, England
    #8
    Note also that 50% means 50% of one of your CPUs, so you're not out of juice just yet...

    EDIT: Er, now that I look at your screen shot, I see that you already know that.
     
  9. IscariotJ macrumors 6502a

    Joined:
    Jan 13, 2004
    Location:
    UK
    #9
    Slightly OT, but what's the calender?
     
  10. cell-gfx thread starter macrumors member

    Joined:
    Oct 18, 2007
    Location:
    Auckland, New Zealand
    #10
    The calendar is part of iStat Menus, an excellent monitoring tool that also gives you quick access to networking tools and activity monitor too! Oh, and it's free. Grade A!
     
  11. JasonD macrumors newbie

    Joined:
    May 16, 2006
    Location:
    Annapolis, MD
    #11
    iStat also has a widget if you'd rather do that.
     
  12. cell-gfx thread starter macrumors member

    Joined:
    Oct 18, 2007
    Location:
    Auckland, New Zealand
    #12
    Well, having left my machine indexing all night, it's still going. It's now not even giving me an estimate of finishing. Anyone else having this problem?
     
  13. Mindcrime macrumors regular

    Mindcrime

    Joined:
    Oct 24, 2003
    Location:
    Houston, Texas
    #13
    That's 245,146 years.

    That's a pretty long time :eek:

    Maybe it's trying to index the Internet.
     
  14. cell-gfx thread starter macrumors member

    Joined:
    Oct 18, 2007
    Location:
    Auckland, New Zealand
    #14
    Check this video out. It shows the indexer still running at 10am today!

    I have tried adding and removing everything from the Spotlight preference pane, but it makes no difference.
     
  15. Mindcrime macrumors regular

    Mindcrime

    Joined:
    Oct 24, 2003
    Location:
    Houston, Texas
    #15
    Open the Activity Monitor and Force Quit the Spotlight indexing process, then reboot and try it again, perhaps.
     
  16. cell-gfx thread starter macrumors member

    Joined:
    Oct 18, 2007
    Location:
    Auckland, New Zealand
    #16
    I tried stopping and restarting the Spotlight service on my drives, but got an error trying to stop it on my main drive :


    iMac:Volumes cellgfx$ mdutil -a -i off
    /:
    Error: unable to perform operation. (-1)
    Indexing enabled.

    /Volumes/Optimus:
    Indexing disabled.
    /Volumes/Untitled:
    Error: invalid operation.
    No index.
     
  17. cell-gfx thread starter macrumors member

    Joined:
    Oct 18, 2007
    Location:
    Auckland, New Zealand
    #17
    That seems to have fixed it. Disabling the external drive allowed the internal one to finish indexing. I've restarted the index on my external drive and it's indexing now (with audible drive activity too!)
     
  18. cell-gfx thread starter macrumors member

    Joined:
    Oct 18, 2007
    Location:
    Auckland, New Zealand
    #18
    Nope - it's still badgered. Restarting on the external drive said 15 minutes to complete. I left it for hours and was left with a striped bar scrolling and no completion time.
     
  19. pieterd macrumors newbie

    Joined:
    Oct 28, 2007
    #19
    I have the same problem

    ATSServer is taking over 60%, mdworker 20%
    I'm not worried about mdworker (It'll slow down later on I guess)
    ATSServer is driving me crazy...
    Some people say it's due corrupt fonts... In my case there were 4 corrupt fonts. I removed them, but the problem persists..

    Anyone an idea to solve this? (Otherwise, I'll be forced to go back to Tiger...)
     
  20. Richard Flynn macrumors regular

    Joined:
    Sep 4, 2006
    Location:
    Sydney
    #20
    Make that MINUS 245,146 years (look closely at the screenshot!)…
     
  21. daveIT macrumors member

    Joined:
    Oct 25, 2006
    Location:
    AK, USA
    #21
    Too much porn? :p :D
     
  22. bierbuik macrumors newbie

    Joined:
    Oct 29, 2007
    #22
    possibly too many pdf files? e-books? the fonts in the e-book pdf files mess up atsserver.

    workaround: disable indexing on the directories containing e-books. you can do this by going to system preferences, spotlight, privacy and then press the '+' sign and add the directory location of the pdf e-books.

    i had the same problem. i moved al my e-book pdf's to a pdf directory that i excluded from indexing.

    in terminal do:

    cd e-books
    mkdir pdf
    mv *.pdf pdf

    now if you allow indexing on e-books folder and disallow indexing on pdf folder you can experiment like this:

    start activity monitor and order descending on CPU.

    in terminal do:

    cd pdf
    mv a.* ..

    this will make all pdf files starting with 'a' visible to the indexer. you can see both mdworker, mds and atsserver spring to life and consume cpu resources. these processes will eventually finnish but it takes a long time.
     
  23. ploink macrumors newbie

    Joined:
    Oct 31, 2007
    #23
    Thank you! You just saved my life! :D atsserver and mdworker went berserk right after I opened a new PDF file. Followed your suggestion and all is back to normal - yay! Thanks again :)
     
  24. punka macrumors newbie

    Joined:
    Nov 1, 2007
    #24
    Solution

    I had the same problem as you with the ATSServer going nuts and the indexing taking forever.

    The solution was wiping out Leopard's font cache. The process died down immediately!

    Try following the deletion list on Font Finagler's website (the app is broken in 10.5 at the moment). BUT instead of copy-pasting these files for deletion, type them in and tab-complete the names, as some of them have changed, and some are now entire directories.

    - Rick
     
  25. IscariotJ macrumors 6502a

    Joined:
    Jan 13, 2004
    Location:
    UK
    #25
    Thanks for that. Didn't realise it was such a useful piece of software.

    Been trying to find this thread for ages to see what the app was, then did a google search to find out why my atsserver was taking up all my cpu...

    Two answers, one thread :)
     

Share This Page