Leopard hangs on shutdown

Discussion in 'macOS' started by Steel Wheels, Oct 29, 2007.

  1. Steel Wheels macrumors member

    Steel Wheels

    Joined:
    Oct 29, 2007
    Location:
    The Land Of 10,000 Lakes
    #1
    I have a MacBook Pro 2.16 C2D that I just updated with Leopard. I noticed that occasionally the computer will hang when I attempt a shutdown. I didn't have this problem with Tiger so I assume it's a bug in Leopard.

    When I try a normal shutdown all I see is my desktop wallpaper and that little circular animated icon. I have to hold in the power button to force a shutdown.

    Has anyone else experienced this?

    Thanks,

    Gary
     
  2. msizzle64 macrumors 6502

    msizzle64

    Joined:
    Apr 8, 2007
    Location:
    Los Angeles, CA
    #2
  3. Steel Wheels thread starter macrumors member

    Steel Wheels

    Joined:
    Oct 29, 2007
    Location:
    The Land Of 10,000 Lakes
    #3
    I've walked away for about five minutes while the machine was shutting down only to come back and find it was still in progress. I guess I've never really waited longer than that. I just held down the power button to force it.

    I'm glad I'm not the only one experiencing this issue. Hopefully, it'll be fixed in an update soon.
     
  4. panoramical macrumors newbie

    Joined:
    Nov 1, 2007
    #4
    phew what a relief that mine is not an isolated problem. I'm running a MacBook (with leopard) 2.16Ghz 1Gb Ram...

    Try this. Try going shut down, and immediately closing the lid. See what happens. I've found that it actually shuts down in good time. I really hope Apple fix the problem though!
     
  5. mizzman36 macrumors newbie

    Joined:
    Jun 17, 2003
    Location:
    Canberra, Australia
    #5
    I have the same problem on both my iMac (2.8GHz) and MBP (2.33). My MacMini does not have this problem.

    The iMac and MBP both have pretty much the same software installed. The Mini has basically no extra software. I'm wondering if it may be software I'm running.

    By default, both machines start:
    Adium
    Skype
    Growl

    Any other sufferers running these items?
     
  6. Bigtree macrumors 6502

    Joined:
    Aug 7, 2007
    #6
    My iMac does the same thing. I'm not running any of those programs.
     
  7. polishmacuser macrumors 6502a

    polishmacuser

    Joined:
    Jan 17, 2007
    Location:
    Los Angeles
    #7
    same here i have a hang issue also when its actually done the screen is blank but when i close the lid the sleep light shows up for some reason then it shuts off does anyone have that problem?
     
  8. mizzman36 macrumors newbie

    Joined:
    Jun 17, 2003
    Location:
    Canberra, Australia
    #8
    Tonight (another 8 hrs in Oz) I'll have a look in console.app to see if there's something in the logs.

    If someone wants to look before me, that would be great.
     
  9. legaleye3000 macrumors 65816

    Joined:
    Jul 31, 2007
    #9
    Polishmacuser- Same thing happens with me... I have latest generation MBP.

    I shut down and the screen is black... BUT ITS NOT OFF!! I have to wait probably a full 10 seconds before it actually turns off.

    If I shut the screen before then (but while the screen is still black), it goes into sleep, while shutting down! Weird...
     
  10. creator2456 macrumors 68000

    creator2456

    Joined:
    Jul 10, 2007
    Location:
    Chicago
    #11
    My restarts after 12-24hrs uptime take at least 5 minutes since I upgrade to Leopard. I just tried a restart from the login screen after powering up from a shutdown...it still took a minute.

    I haven't been having any sleep issues since the upgrade.

    Lets just be glad a restart isn't necessary all that often and hope Apple gets a fix out quick.
     
  11. panoramical macrumors newbie

    Joined:
    Nov 1, 2007
  12. panoramical macrumors newbie

    Joined:
    Nov 1, 2007
    #13
    If anyone can help me with these, here's the error log...

    Sun Nov 11 13:11:01 2007
    panic(cpu 0 caller 0x001A7BED): Kernel trap at 0x3d773214, type 14=page fault, registers:
    CR0: 0x8001003b, CR2: 0x61657bc4, CR3: 0x0101b000, CR4: 0x00000660
    EAX: 0x007d0918, EBX: 0x61657674, ECX: 0x00507444, EDX: 0x032ea554
    CR2: 0x61657bc4, EBP: 0x15227cb8, ESI: 0x02c37000, EDI: 0x3d7753e8
    EFL: 0x00010206, EIP: 0x3d773214, CS: 0x00000008, DS: 0x00000010
    Error code: 0x00000000

    Backtrace, Format - Frame : Return Address (4 potential args on stack)
    0x15227ac8 : 0x12b0e1 (0x4555b4 0x15227afc 0x133238 0x0)
    0x15227b18 : 0x1a7bed (0x45e568 0x3d773214 0xe 0x45dd24)
    0x15227bf8 : 0x19e517 (0x15227c10 0x2be2c00 0x15227cb8 0x3d773214)
    0x15227c08 : 0x3d773214 (0xe 0x520048 0x2c50010 0x10)
    0x15227cb8 : 0x3d77176b (0x3d775428 0x2c37000 0x7e2fc8 0x3e75aa)
    0x15227ce8 : 0x3d7717ee (0x2c37000 0x7ee720 0x2c37000 0x98ef1c)
    0x15227d08 : 0x40aa2d (0x33d9e00 0x0 0x2c37000 0x3e81d9)
    0x15227d38 : 0x40b622 (0x2c37000 0x2e65500 0x0 0x2c37000)
    0x15227d78 : 0x40f74c (0x2c37000 0x29a8c40 0x0 0xffffffff)
    0x15227dc8 : 0x40f8ff (0x2c4bd00 0x7 0x1 0x3e840c)
    0x15227de8 : 0x619606 (0x2c4bd00 0x3 0x1 0x2bc2200)
    0x15227e08 : 0xbf3b02 (0x2c4bd00 0x3 0x0 0x2bc2500)
    0x15227e28 : 0xbf3c89 (0x2bc2200 0x633064 0x1 0x96a2e0)
    0x15227e68 : 0xbefe04 (0x2bc2200 0x5350c0 0x15227eb8 0x1361b0)
    0x15227ea8 : 0xbf18f1 (0x2ba5400 0xbf06e8 0x1 0x0)
    0x15227ed8 : 0x412cae (0x2ba5400 0x0 0x2ba5400 0x2ba5400)
    Backtrace continues...
    Kernel loadable modules in backtrace (with dependencies):
    com.baltaks.driver.DoubleCommand(1.6.5)@0x3d770000->0x3d775fff
    dependency: com.apple.iokit.IOHIDFamily(1.5)@0x7b7000
    com.apple.driver.AppleUSBHub(3.0.3)@0xbee000->0xbf8fff
    dependency: com.apple.iokit.IOUSBFamily(3.0.3)@0x60c000
    com.apple.iokit.IOUSBFamily(3.0.3)@0x60c000->0x633fff

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:
    9A581

    Kernel version:
    Darwin Kernel Version 9.0.0: Tue Oct 9 21:35:55 PDT 2007; root:xnu-1228~1/RELEASE_I386
    System model name: MacBook2,1 (Mac-F4208CAA)
     
  13. G4R2 macrumors 6502a

    Joined:
    Nov 29, 2006
    #14
    I've had a similar issue. I performed an archive and install on a Macbook.

    To those who are experiencing this issue, do you have either .Mac with iDisk synchronization active or Microsoft Office installed?

    For my problem, I had a feeling this is a synchronization issue. I've removed Microsoft's synchronization agent and corrected problems I had synchronizing iDisk (it probably self corrected after it was undergoing an endless synchronization but I essentially installed and uninstalled iDisk several times).
     
  14. theman macrumors 6502a

    Joined:
    Jul 26, 2007
    #15
    Mine takes a long time to shut down too. Tiger shut down in like, 2 seconds. It was amazing.

    Now, when I shut down, I get that spinny loading thing for like 20 seconds, and it sits on a black screen for another 20-30 seconds before powering off (or restarting).

    A couple times I have gotten this message that says something about Cache or Caching or something. Not sure what it said. Haven't gotten it for a while.

    I hope this gets fixed in 10.5.1 because I want to go back to showing off to my friends how fast OS X shuts down and starts up. Now my 3 year old cluttered PC blows it out of the water. :(

    This is on a SR MBP 2.2GHz. It has happened ever since I first did an erase and install. I do not have .Mac, iDisk.

    It is hard for me to know if any program is causing it because i have only restarted 7-8 times (just for updates and a couple times for bootcamp). but I am definitely sure it happened the first time i installed.
     
  15. John01021988 macrumors 6502

    Joined:
    May 11, 2007
    #16
    yeah same happens to me once in a while. Also when shutting down, sometimes Mail hangs, therefore not letting Finder shut down, making me go to activity monitor and quit the Window user process
     
  16. newmanc macrumors newbie

    Joined:
    Nov 2, 2007
    #17
    Similar issue here, it took 2 hrs to restart the OS last time, my machine is Macbook CD 2Ghz/2GB RAM.
     
  17. Isambard macrumors newbie

    Joined:
    Nov 2, 2007
    #18
    Fix to Leopard Hanging on Shutdown

    I too had the same problem on my iMac after installing Leopard but I seem to have found a workaround.....

    Turn off Automatic iDisk Synchronisation..
    (Right Click on your iDisk and reselect the option to turn it off)

    My iMac shuts down every time now! :)
     
  18. CorranQ macrumors newbie

    CorranQ

    Joined:
    Apr 5, 2007
    Location:
    México, D.F, México
    #19
    I'm about to try this iDisk solution as quite frankly I'm about to ditch mac.com that's proven all but useless to me, lol, but for the record. I did a console analysis on what's been going on and aside a FLURRY of startup errors that I'm betting slow down my computer's overall start-up (1st Gen Black Macbook 2.0 GHz), when shutting down it stalls because of:

    11/16/07 2:44:50 AM com.apple.SystemStarter[29] Shutdown failed: Cannot find license file. (-1,359:2 "No such file or directory")>

    To say the least I find such a complaint from my computer beyond interesting and well into bewildering... any thoughts? And does anyone know how I can clean up my start-up so that I'll stop having errors and it'll just smoothly boot?
     
  19. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #20
    My MBP doesn't completely hang, but the screen goes blank for a good 20 seconds before it shuts off or restarts.

    The screen never went blank (i.e. black, nothing there) when I shutdown on Tiger, or if it did it was only for a few seconds.
     
  20. joegomolski macrumors 6502

    joegomolski

    Joined:
    Apr 28, 2006
    Location:
    So CA
    #21
    Leopard hangs on shut down

    eureka!

    Several people have suggested turning off automatic sync for idisk.

    A number of people have reported this didn't work, it didn't work for me either, at first.

    I shut down with the power button, then pressed the power buttom to turn on the Mac Pro, and let my Mac Pro complete the startup cycle.

    Check to make sure idisk had automatic sync turned off.

    And repeated this routine several times.

    After the 2nd or 3rd hard power down. When I next shut down the Mac Pro, it shut down! Yea

    I have no idea wants going on, obviously I stumbled upon this solution.

    But if it worked for me, it might work for someone else.
     
  21. theman macrumors 6502a

    Joined:
    Jul 26, 2007
    #22
    Anybody notice any changes after 10.5.1? It's a little better for me, but still not like tiger... sadly.
     
  22. MichaelQ macrumors newbie

    Joined:
    Nov 17, 2007
    #23
  23. kwfl macrumors 6502

    Joined:
    Aug 20, 2007
    #24
    i have the same issue, yesterday i did fresh install to see no difference
    actually one, i instructed my MBP to shut down before i went to bed, in the morning, it is still at it is.
     
  24. yamill macrumors newbie

    Joined:
    May 14, 2008
    #25
    Home maded fix to shut down problem

    I have to G5 connected and the problem happen's only went i connect one to the other. I fund that went i eject the disk image and shut down the computer frezze. But if you do a Finder Relaunch before shut down it do it good.

    I hope this work for other until apple fix this the right way.
    Att. Hector Yamill Montalvo, From Puerto RIco
     

Share This Page