Leopard WebKit and YouTube


DeltaMac

macrumors G3
Jul 30, 2003
9,536
2,304
Delaware
Youtube dropped support for flash video, maybe a month or six weeks back.
You could try TenFourFox, I suppose.
 

MysticCow

macrumors 6502a
May 27, 2013
831
381
Make sure your default is HTML5 and not Flash. That, oftentimes, will solve the problem.

If it doesn't solve the problem, then use TenFourFox.
 

MatthewLTL

macrumors 68000
Original poster
Jan 22, 2015
1,684
18
Rochester, MN
I dont watch youtube on the browser. I have the YouView Safari exgtension. ClickToFlash never worked as it was claimed to for me. I have HTML5 as default but i never watch videos that way because i cannot play them full screen
 

Dronecatcher

macrumors 68040
Jun 17, 2014
3,066
2,510
Lincolnshire, UK
I dont watch youtube on the browser. I have the YouView Safari exgtension. ClickToFlash never worked as it was claimed to for me. I have HTML5 as default but i never watch videos that way because i cannot play them full screen
I've recently found YouView to be incompatible with lots of Youtube clips in the same way MacTubes went - inevitable I guess..shame.
 

MatthewLTL

macrumors 68000
Original poster
Jan 22, 2015
1,684
18
Rochester, MN
I've recently found YouView to be incompatible with lots of Youtube clips in the same way MacTubes went - inevitable I guess..shame.
I have noticed that too; But i would rather use YouView where i can watch videos full screen than a browser that can't do full screen.
 

Altemose

macrumors G3
Mar 26, 2013
9,089
444
Elkton, Maryland
I dont watch youtube on the browser. I have the YouView Safari exgtension. ClickToFlash never worked as it was claimed to for me. I have HTML5 as default but i never watch videos that way because i cannot play them full screen
Are you running the latest version of Leopard WebKit? Ensure YouView is on 0.5 and not 0.5.1 as the newer version has a bug which causes high CPU usage.
 

stewart1981

macrumors member
Sep 4, 2014
58
18
TenFourFox works like a dream for my wife on a daily basis on YouTube on G5. The dropping of flash has given the machine a new lease of life.

On a bizarre side note I've discovered I can watch BBC iplayer on the G5 in Stainless using whatever version of flash is built in. It isn't perfect but I can use the Radio 3 streaming via website and catch up with anything I've missed. I do use my windows laptop for that but it was just the discovery really shocked me as it refuses in any other browser.
 

MatthewLTL

macrumors 68000
Original poster
Jan 22, 2015
1,684
18
Rochester, MN
Are you running the latest version of Leopard WebKit? Ensure YouView is on 0.5 and not 0.5.1 as the newer version has a bug which causes high CPU usage.
I don't have any problem with 0.5.1. I did update LW to the one for Leopard/Snow Leopard as well as installed all the scripts that was included with it. Now I can see videos fullscreen in Safari but it still has a lag. And not being able to put it in 480p is annoying. TenFourFox DOES NOT work, HTML5 lags HEAVILY with TFF on my eMac and HTML5 dont work AT ALL on my MDD it lags on anything; TFF, LK, MacTubes, YouView the ONLY option i have on the MDD is the TFF's QTE
 

Altemose

macrumors G3
Mar 26, 2013
9,089
444
Elkton, Maryland
I don't have any problem with 0.5.1. I did update LW to the one for Leopard/Snow Leopard as well as installed all the scripts that was included with it. Now I can see videos fullscreen in Safari but it still has a lag. And not being able to put it in 480p is annoying. TenFourFox DOES NOT work, HTML5 lags HEAVILY with TFF on my eMac and HTML5 dont work AT ALL on my MDD it lags on anything; TFF, LK, MacTubes, YouView the ONLY option i have on the MDD is the TFF's QTE
With the YouView Extension (not plugin), selecting a YouTube link will pause opening the page and open separately in YouView. It works that way on my G5 and G4. Ensure the extension is enabled properly in Safari --> Preferences.
 

MatthewLTL

macrumors 68000
Original poster
Jan 22, 2015
1,684
18
Rochester, MN
With the YouView Extension (not plugin), selecting a YouTube link will pause opening the page and open separately in YouView. It works that way on my G5 and G4. Ensure the extension is enabled properly in Safari --> Preferences.
I know how YouView works in that regard, However YouView DOES NOT work on my MDD it works physically, but Videos lag with YouView. They lag with HTML5 as well that includes in a brower or using the Video Player option of MacTubes. The ONLY way i can even watch YouTube on my MDD is to use QuickTime via MacTubes setting or using the QuickTimeEnabler addon for TenFourFox.
 

MatthewLTL

macrumors 68000
Original poster
Jan 22, 2015
1,684
18
Rochester, MN
UPDATE: It appears now that there is no sound with LW on youtube. Also LW beachballs for a few seconds (mainly when here on MR and i got to post or reply to a thread. I'll start to type than it beachballs for about 5 seconds than stops and is usable again.. not a big deal just annoying as all hell.
 

Altemose

macrumors G3
Mar 26, 2013
9,089
444
Elkton, Maryland
I know how YouView works in that regard, However YouView DOES NOT work on my MDD it works physically, but Videos lag with YouView. They lag with HTML5 as well that includes in a brower or using the Video Player option of MacTubes. The ONLY way i can even watch YouTube on my MDD is to use QuickTime via MacTubes setting or using the QuickTimeEnabler addon for TenFourFox.
The lag issue is prevalent in 0.5.1. Even my G5 has that issue and downgrading should resolve the problem. My buddy Gavin still has 0.5 on the PowerPC Archive.
 

MatthewLTL

macrumors 68000
Original poster
Jan 22, 2015
1,684
18
Rochester, MN
The lag issue is prevalent in 0.5.1. Even my G5 has that issue and downgrading should resolve the problem. My buddy Gavin still has 0.5 on the PowerPC Archive.
Has nothing to do with 0.5.1. It has ALWAYS laged on the MDD (probably the 4MX card) even when i had version 0.4 on it
 

MatthewLTL

macrumors 68000
Original poster
Jan 22, 2015
1,684
18
Rochester, MN
I am just pointing out an issue that I know is in 0.5.1 that could be the cause of your problem.
I thought It was the problem too, However I really do think its the GPU i think the 4 MX is the bottleneck for videos since the PowerMac has more RAM than my eMac and the specs are identical except the fact the eMac has a 9200
 

Altemose

macrumors G3
Mar 26, 2013
9,089
444
Elkton, Maryland
I thought It was the problem too, However I really do think its the GPU i think the 4 MX is the bottleneck for videos since the PowerMac has more RAM than my eMac and the specs are identical except the fact the eMac has a 9200
I maybe wrong, but the GeForce 4 MX should have enough power to use YouView.
 

Intell

macrumors P6
Jan 24, 2010
18,872
368
Inside
Start with it at the lowest settings and work up until it starts to have problems. To stop the locking up, move it to the Trash and empty the trash. Then download a more secure and featureful browser.
 

MatthewLTL

macrumors 68000
Original poster
Jan 22, 2015
1,684
18
Rochester, MN
Start with it at the lowest settings and work up until it starts to have problems. To stop the locking up, move it to the Trash and empty the trash. Then download a more secure and featureful browser.
The most lowest setting in YouView is 480p still lags on that. No problems using QuickTime but forget HTML5, MacTubes on the "Video Player" option
 

redheeler

macrumors 604
Oct 17, 2014
7,408
6,976
With the proper settings, the GeForce 4 MX can playback YouView well.
Correct, 480p in YouView on my MDD is quite smooth. 720p starts to have problems, but I would expect that from such old hardware.