Leopard will not sleep?

Discussion in 'macOS' started by msharp, Oct 29, 2007.

  1. msharp macrumors regular

    msharp

    Joined:
    Jul 10, 2004
    #1
    I have a mbp SR 2.2, 2G ram. Just bought several weeks ago. I do not shut it down --- just let it sleep when I am not at home.

    However, after upgrading to Leopard, I found out that every time I come back home, or I wake up in the morning, the computer is not sleeping at all! I am pretty sure that it falls asleep when I leave (the little led starts breathing, fans stop spinning, etc).

    I've already turned built-in airport off, no network cable connected, and the "wake for network administrative attempt" from the "Energy Saver" in system preferences is turned off as well.

    I don't see any reason it wakes itself.

    Is there anyone has the same problem?

    Does it have something to do with Time Machine? I do have it turned on. So will it wake itself for the "hourly backup"?
     
  2. sierraquester macrumors newbie

    Joined:
    Oct 31, 2007
    #2
    Me too

    I have seen the same problem. In my case the computer never goes to sleep on idle. I must order it to sleep. It does not wake up on its own--it just never sleeps int he first place.

    At first I thought it was something I had added or changed but I've eliminated most of that. I do not think it is Time Machine because they specifically say TM will let the sleep "win". I've tried turning Time Machine off but still it does not sleep on idle. I'm not sure what else to try at this point.
     
  3. thestaton macrumors 6502

    Joined:
    Jan 19, 2006
  4. sierraquester macrumors newbie

    Joined:
    Oct 31, 2007
    #4
    Disabling spotlight allows Mac to sleep

    Update: I tried a bunch of things like disconnection all USB devices, turning off Time Machine, shutting down new widgets. None of this helped.

    Finally I tried disabling Spotlight (by adding all drives to its exclude list) and now my Mac goes to sleep again within a few minutes of the selected idle time.

    I'd like to know if this solves it for anyone else having the sleepless problem. If it works for you too maybe Apple has some work to do in Spotlight.
     
  5. majiktt macrumors newbie

    majiktt

    Joined:
    Oct 6, 2004
    Location:
    Tucson, AZ - USA
    #5
    I have the same problem since upgrading my Aluminum iMac to Leopard... it wakes up from sleep on its own... AND, it even powers on automatically from being turned completely off.

    I have no peripherals connected other than the keyboard and mouse that came with it. I can't figure this one out.
     
  6. millerrh macrumors 6502

    Joined:
    Sep 14, 2005
    #6
    Count me into this thread as well...my MBP won't fall asleep on its own. I always come back from a long time and it isn't asleep. I even tried removing all network cables and airport. Nothing. This is irritating. Please post responses if any solutions are known.
     
  7. theman macrumors 6502a

    Joined:
    Jul 26, 2007
    #7
  8. EAMacG macrumors newbie

    Joined:
    Nov 6, 2007
    #8
    New to the forum to try and resolve my sleep problem.

    I have a MacMini. When using Tiger it wouldn't sleep with a wireless keyboard and mouse connected - even when "don't wake up by bluetooth" was selected. Resolved by ditching mouse and keyboard. Then operated fine on new wired keyboard and mighty mouse (even though previous optical mice didn't allow sleeping).

    Now installed Leopard and different problem. Will not sleep at all with apple shortcut "alt-cmd-eject" Goes into sleep mode but kicks itself out as if trying to eject disc. It will sleep happily from apple submenu and pressing power button on MacMini itself.

    Does anyone know of a Leopard "sleep" keyboard short cut?
     
  9. marmite macrumors newbie

    Joined:
    Nov 6, 2007
    #9
    Disabling Spotlight had no effect

    I can get my macbook to sleep either by hotkeys or menu - but it usually kicks itself out of sleep after a few seconds. I installed to a clean volume.
     
  10. millerrh macrumors 6502

    Joined:
    Sep 14, 2005
    #10
    I think I figured out why mine isn't sleeping. Gmail.

    I was able to narrow this down to when Gmail is open, it prevents Leopard from automatically sleeping. I can still manually make it sleep. Also, this is only the "new" version of Gmail where your contacts show up on the left to chat with. If I switch to the old version, my computer will sleep.

    I've done a few sanity checks, but I think this is it. So all of you that are having troubles, check to see if you're using Gmail when these troubles happen.
     
  11. marmite macrumors newbie

    Joined:
    Nov 6, 2007
    #11
    Not Gmail for me - but menu is OK

    I'm not running Gmail, so that's not my problem. However I've made some progress too. I should say first that I run my macbook with an external monitor and keyboard; the lid is always closed.
    I've found that if I use the system menu to enter sleep then it's fine. However, if I use hotkeys (⌥⌘- eject) the system initially appears to sleep but after a few seconds it kicks itself out.

    I'd just like to add that despite all the negative comments around I like leopard and I've had few problems.
     
  12. ghettochild macrumors regular

    Joined:
    Jun 12, 2007
    Location:
    Bay Area, CA
    #12
    Seems to be a widespread problem. I have the same issues with my G4 PB after a clean install of 10.5. This is another Apple discussion thread concerning the problem (I've posted there under the same nickname as here).

    Everybody who experiences these problems make sure to submit feedback to Apple via the feedback form. I hope Apple will fix this ASAP, this is totally unacceptable.
     
  13. ghettochild macrumors regular

    Joined:
    Jun 12, 2007
    Location:
    Bay Area, CA
    #13
    This apparently wasn't fixed in 10.5.1. I still have the awake-from-sleep problems.

    Great job Apple, really.
     
  14. mavis macrumors 68040

    mavis

    Joined:
    Jul 30, 2007
    Location:
    Tokyo, Japan
    #14
    I don't know if this helps, but I noticed when I first installed leopard that Time Machine made hourly backups all night long, despite my iMac supposedly being asleep. I'm guessing TM wakes it up ...
     
  15. kevo0822 macrumors 6502

    Joined:
    Jul 13, 2007
    Location:
    New England
    #15
    I never had any problems with Leopard... until I updated to 10.5.1. I'm only having this one problem... but I think it's a pretty big deal. I shut my MBP down... like completely turned it off. I wake up this morning to find it on and waiting for me to log in.

    What if I'm carrying it in my backpack and it just turns on? The hard drive is just going to bump around everywhere while spinning.
     
  16. siren77 macrumors member

    Joined:
    Oct 11, 2007
    #16
    I'm having similar issues. And I think it only started after installing 10.5.1. If I put my MBP to sleep with the lip open, it wakes itself after sometime. If I close the lid, sometimes it'll wake itself and then go back to sleep since closing the lid forces it to sleep. I woke up one day to hear the MBP waking up and the drive spinning for a while, and then going back to sleep because of the closed lid. The only peripheral I have is a bluetooth mouse. I'm gonna try unchecking the option for bluetooth devices being allowed to wake the computer. Maybe that'll solve the problem. If not, it is most definitely due to the 10.5.1 upgrade.
     
  17. gavd macrumors 6502a

    Joined:
    Jan 30, 2006
    #17
    It's not due to 10.5.1 because my iMac G5 has this problem and has done since well before 10.5.1 was even available. There must be another cause for it - I just don't know what it is!
     
  18. siren77 macrumors member

    Joined:
    Oct 11, 2007
    #18
    Argh...well let's hope the bluetooth option fixes it for me. It just can't be good for the system to constantly wake and sleep.
     
  19. siren77 macrumors member

    Joined:
    Oct 11, 2007
    #19
    is this problem (self-waking from sleep) only in 10.5 or was it around in Tiger as well?
     
  20. roland.g macrumors 603

    roland.g

    Joined:
    Apr 11, 2005
    Location:
    One mile up and soaring
    #20
    My 2.8 iMac doesn't go to sleep unless I tell it to. I can tell b/c I have a Powermate plugged in set to turn off its blue light during sleep and it never shuts it off unless I tell the iMac to sleep.
     
  21. mzd macrumors 6502a

    Joined:
    Jul 25, 2005
    Location:
    Wisconsin
    #21
    same problem for me. new iMac, 10.5.1
    sleep from the menu bar works, as does pressing the power button.
    but the hard disc won't sleep on its own. screen goes black, and the hard disc spins down but after a minute it spins back up and just continues this cycle. my airport is off, as is bluetooth. this was never a problem in tiger.
    also, i don't have time machine on or any external discs plugged in.
     
  22. geeserver macrumors newbie

    geeserver

    Joined:
    Nov 1, 2006
    Location:
    PHX, AZ
    #22
    I have this stupid problem too. I did a upgrade from tiger but I was having this problem and keyboard not working. Now I did a clean install. Keyboard problems went away but still have the sleep problem. I even go to the Apple Icon and select sleep and its doing the same thing as the close lid. It will NOT sleep when I'm connect to AC. On battery (about 80% of the time) it will sleep.
    I can hear the rom drive making noise and the apple icon on the top of the book lighting up and the book heating up like crazy.

    This is getting old.... :mad:
     
  23. Pedro Estarque macrumors regular

    Joined:
    Dec 5, 2002
    #23
    Mine doesn't either MacBook Pro 15" 10.5.1
    And boot time is SLOW ( 1"20 sec from a ~25sec in Tiger )
     
  24. psonice macrumors 6502a

    Joined:
    Jul 22, 2005
    #24
    Obvious suggestion...

    Try rebooting the mac. I guess most of you have tried that, but I suggest it because I had this problem yesterday with an aluminium imac and 10.5.1. I always send it to sleep when i'm done with command-alt-eject, but I noticed yesterday that doing that would send it to sleep, but it would wake up 5-10 seconds later. Looking in the system logs, it appears that it did actually sleep, but something woke it up. I unplugged pretty much everything and shut down all my apps, and it still happened.

    Anyway, a reboot fixed it.
     
  25. Pedro Estarque macrumors regular

    Joined:
    Dec 5, 2002
    #25
    It's not just that. Mine won't go to sleep automatically at all.
    If I close the lid it does, but if I wait for it to go by itself it won't.
     

Share This Page