Link Clicks Not Working on iPhone 6

Discussion in 'iPhone Tips, Help and Troubleshooting' started by EEMAN13, Mar 25, 2016.

  1. EEMAN13 macrumors member

    Joined:
    Nov 15, 2013
    #1
    Today I noticed that when I click in a link in Safari on the iPhone it will not go to the webpage embed in the link and instead does nothing. When I do click on the link, it does quickly "highlight" the text (so I know the clicks are registering), but again, it does nothing. If I hold down on the link a list pops up and I can open the link in the new tab. I opened Chrome and am experiencing the exact same issue. I was on the iOS version just before 9.3. I upgraded to iOS 9.3 and the issue persists. I found something online that says to clear history and website data and hard restart the iphone but that did not help. I haven't dropped the phone recently nor have I exposed to to extreme environmental conditions or anything that I think would affect it's operation (hardware wise). Button presses everywhere else work just fine (opening apps, pressing a button in an app, etc). This issue essentially makes browsing the web on my phone impossible.

    Does anyone have any ideas on how to fix this?
     
  2. EEMAN13 thread starter macrumors member

    Joined:
    Nov 15, 2013
    #3
    Thanks, that looks like exactly the issue I'm experiencing. However, I had this problem before I upgraded to version 9.3. I'll follow the other thread and see what happens. Apple had better issue an emergency fix very soon because as mentioned by others in the thread you linked, it basically makes the phone unusable.
     

Share This Page