iOS 9.3: links in safari not clickable anymore

desonnaville

macrumors newbie
Original poster
Mar 21, 2009
26
9
Since I use iOS 9.3 (I was a public beta tester), in some betas links were not clickable in safari anymore. Beta 4 wasn't working, beta 5 was fine and now since beta 6 the problem got back.

Problem mostly exist when I try to google something from the search bar in safari. When I then try to click on a search result, safari dont respond and start to freeze. Then the app is closing and when I try it again, it freezes again.

I hoped on a solution with the official release of 9.3, however its still present. Its super annoying and I can't find a solution.

I already tried to delete data from safari and also did a hard reset.

Also problem seems to exist in Chrome and whatsapp as well (when someone sends me a link).

Who knows a solution?
 

6836838

Suspended
Jul 18, 2011
1,536
1,325
I thought it was just me. I've had to force restart Safari a few times since Beta 7 and it's still here.
 
  • Like
Reactions: Cacarrof

Shirasaki

macrumors G4
May 16, 2015
10,196
4,005
I have seen this also, although less frequently than you other guys see.
I am forced to use force touch to "peek" and open links, otherwise Safari will not respond tapping.
 
  • Like
Reactions: Cacarrof

jfiggy77

macrumors newbie
Mar 15, 2015
27
11
OMG!!!!!!!!!!!!!!!!!!! Finally it's not just me! I wrote a lengthy post a few weeks back about this same exact problem and only had one person respond with possible solutions. I even submitted beta feedback to Apple and no one responded. I have restored my iPhone 5 times in the past few weeks hoping to fix the issue. After a restore, my phone will be fine for a bit and then all of a sudden, the issue will appear. I even tried to install apps one by one and see if one of them was causing the issue. Everything worked just fine and then just of the blue, the problem occurred. It happens when I try to click links in mail and text messages and when I try to open links from a web search and when I try to open an article on the search screen and when I try to click a link in almost any other app. When I click the link in mail or the text message app, the app will freeze and I forced to force quit. I also found that changing the search provider to Bing, will allow me to open links in web searches. I am relieved to know that I am not crazy and this is indeed a serious problem. I was just about to restore my phone again and saw this thread and realized it's not worth it since I will have the same problem again until we find out what is causing it. It's not just an iOS 9.3 issue since the last restore I performed, I didn't install the 9.3 Beta and the problem happened on 9.21. I have even tried to disable 3D touch and that doesn't fix the issue. Meanwhile, my iPad ran every beta and has pretty much all of the same apps installed and i've never seen this issue on there. I am at am at a total loss because I have no idea what is causing it.
 
Last edited:

desonnaville

macrumors newbie
Original poster
Mar 21, 2009
26
9
OMG!!!!!!!!!!!!!!!!!!! Finally it's not just me! I wrote a lengthy post a few weeks back about this same exact problem and only had one person respond with possible solutions. I even submitted beta feedback to Apple and no one responded. I have restored my iPhone 5 times in the past few weeks hoping to fix the issue. After a restore, my phone will be fine for a bit and then all of a sudden, the issue will appear. I even tried to install apps one by one and see if one of them was causing the issue. Everything worked just fine and then just of the blue, the problem occurred. It happens when I try to click links in mail and text messages and when I try to open links from a web search and when I try to open an article on the search screen and when I try to click a link in almost any other app. When I click the link in mail or the text message app, the app will freeze and I forced to force quit. I also found that changing the search provider to Bing, will allow me to open links in web searches. I am relieved to know that I am not crazy and this is indeed a serious problem. I was just about to restore my phone again and saw this thread and realized it's not worth it since I will have the same problem again until we find out what is causing it. It's not just an iOS 9.3 issue since the last restore I performed, I didn't install the 9.3 Beta and the problem happened on 9.21. I have even tried to disable 3D touch and that doesn't fix the issue. Meanwhile, my iPad ran every beta and has pretty much all of the same apps installed and i've never seen this issue on there. I am at am at a total loss because I have no idea what is causing it.
I got the same thing. Also my iPad is working fine, however my iPhone isn't.

Did you also try to install your phone as new without a backup?
 

jfiggy77

macrumors newbie
Mar 15, 2015
27
11
Yes, every time that i've reset the phone, i've set it up as a new iPhone with no backup. It will work fine for a bit and then stop working all of a sudden. I am so relieved that I am not the only one experiencing this. I was seconds away from reset the phone again and reinstalling every single app one by one to see if I could find the cause of the problem and then I saw this post and realized there was no point in doing so since it's a real problem.
[doublepost=1458648474][/doublepost]BTW, this was my post a few weeks ago: https://forums.macrumors.com/thread...n-mail-safari-and-news.1959917/#post-22644282
 

markrath

macrumors member
Nov 23, 2011
45
39
Yes, every time that i've reset the phone, i've set it up as a new iPhone with no backup. It will work fine for a bit and then stop working all of a sudden. I am so relieved that I am not the only one experiencing this. I was seconds away from reset the phone again and reinstalling every single app one by one to see if I could find the cause of the problem and then I saw this post and realized there was no point in doing so since it's a real problem.
[doublepost=1458648474][/doublepost]BTW, this was my post a few weeks ago: https://forums.macrumors.com/thread...n-mail-safari-and-news.1959917/#post-22644282
[doublepost=1458660327][/doublepost]I am having problems beyond the links troubles. Safari starts top load a page then just freezes. This happens on both WiFi and LTE. I can update/download apps, get email, etc. But Safari is not happening :(
 
  • Like
Reactions: Bender007

iphnhelp

macrumors regular
Jun 16, 2010
243
34
I'm seeing similar. When I tap a link in Safari I see the grey box around the link, and it freezes there and I have to force quit.

In past betas I've had issued with Safari freezing and I've had to clear all history and cache, and that seemed to work. Maybe I'll try that. Has anyone tried that?
 

jfiggy77

macrumors newbie
Mar 15, 2015
27
11
That's exactly what happens to me....grey box around link and freezing. However clearing the history and cache doesn't fix the problem.

I'm seeing similar. When I tap a link in Safari I see the grey box around the link, and it freezes there and I have to force quit.

In past betas I've had issued with Safari freezing and I've had to clear all history and cache, and that seemed to work. Maybe I'll try that. Has anyone tried that?
 
  • Like
Reactions: xisto65

Rhonindk

macrumors 601
I am not getting the freeze so far however have run into a similar item.
On CNet and clicked a Twitter link. It opened no problem. When I went back to Safari, all that was displayed was a white Twitter headed Safari page. I had to back page to the original article.
Same issue on Verge. Same issue on ABCNews.
Safari has new problems..... :confused:
 
  • Like
Reactions: ahmede

tigerandyx9

macrumors newbie
Nov 14, 2015
6
6
London, UK
That's exactly what happens to me....grey box around link and freezing. However clearing the history and cache doesn't fix the problem.
This is happening to thousands ... look at Apple Communities
https://discussions.apple.com/message/29949888#29949888

While Apple recognises and fixes bugs there are various suggestions in same site

One is, links into...
"URLs not working in Safari or Mail after iOS 9.2.1."

"URLs not working in Safari or Mail after iOS 9.2.1."
Update as of March 22, 2016: You'll see in community questions that hyperlink problem with 9.2.1 carries on and on, and Apple has not yet responded to the thousands of views ... One consequence is the freezing...

... u can unfreeze (power off button until u get screen w wipe question, then press Home until it clicks, kills the culprit app and unfreezes) and/or... substitute temporarily some of the main Apple culprits as follows...

My temp solution of substituting Mail by CloudMagic and Safari by Chrome works great >90% of the time. I complement w Mercury and , of course, Mail & Safari.

For linked problems w Calender i am using Fantastic.

I also changed VPN app/service to one with no hyperlinks so it doesn't freeze my app when changing some settings. Instead of XXX i now use TunnelBear and it works consistently.

This has taken the pressure off me and I'm relaxed using my iPad again!

it's a big pain erasing, resetting and attempting to recover from all the different backups, iCloud, Dropbox, etc etc and at the end there are no guarantees that solution will hold longer term.
[doublepost=1458758280][/doublepost]
Since I use iOS 9.3 (I was a public beta tester), in some betas links were not clickable in safari anymore. Beta 4 wasn't working, beta 5 was fine and now since beta 6 the problem got back.

Problem mostly exist when I try to google something from the search bar in safari. When I then try to click on a search result, safari dont respond and start to freeze. Then the app is closing and when I try it again, it freezes again.

I hoped on a solution with the official release of 9.3, however its still present. Its super annoying and I can't find a solution.

I already tried to delete data from safari and also did a hard reset.

Also problem seems to exist in Chrome and whatsapp as well (when someone sends me a link).

Who knows a solution?
It's happening a lot with, it seems, the hyperlinking and affects Mail, Safari, etc seriously.

Some TEMPORARY solutions are in Apple's support communities :
https://discussions.apple.com/message/29949888#29949888


I just posted my "solution" in this forum thread and it is still working, about a month so far
Cheers and good luck!
 
  • Like
Reactions: Cacarrof

jfiggy77

macrumors newbie
Mar 15, 2015
27
11
I'm relieved to know that I am not crazy and that this is a known issue. I read the post in the forum you linked to and it's crazy because there is no pattern. I have a 128GB LTE & WiFi iPad Air 2 which had every 9.3 beta installed and to this date i've never had the issue. Meanwhile, some people in the forums have had the issue with their iPad Air. I have a 128GB iPhone 6s and I've have the issue since the 9.3 betas. I have reinstalled the OS 4 times and 2 of those times I didn't install the 9.3 beta. I've always setup the phone as new with no backup information being copied back. All four times everything was fine and dandy and out of the blue, the problem started. One thing I did notice is that most people who's iPhone was affected had an iPhone 6s with 128GB. Maybe it's only affecting these devices? Who knows. All I know is that it's an annoyance. It affects News links in spotlight, links in Mail, Links when Google is used as the search engine in Safari, Links in text messages, links in Whatsapp, Apps that try to open a web page for you to sign in. Basically, it's affecting enough aspects of the operating system to make it painful to use my phone. As a work around for now, I am using Bing as the search engine in Safari and i'm using Outlook as my mail client since I can set Chrome as the browser to open links. For any text messages I get with links, I forward them to my gmail account and open them in the Gmail app. More work than I wish, but it's the workaround that works for now. It's worth notting that I tried to use Chrome as my browser. Even in Chrome though, if you have Google set as your default web search service, links will not open when you perform a search so it's not just affecting built in iOS apps.



This is happening to thousands ... look at Apple Communities
https://discussions.apple.com/message/29949888#29949888

While Apple recognises and fixes bugs there are various suggestions in same site

One is, links into...
"URLs not working in Safari or Mail after iOS 9.2.1."

"URLs not working in Safari or Mail after iOS 9.2.1."
Update as of March 22, 2016: You'll see in community questions that hyperlink problem with 9.2.1 carries on and on, and Apple has not yet responded to the thousands of views ... One consequence is the freezing...

... u can unfreeze (power off button until u get screen w wipe question, then press Home until it clicks, kills the culprit app and unfreezes) and/or... substitute temporarily some of the main Apple culprits as follows...

My temp solution of substituting Mail by CloudMagic and Safari by Chrome works great >90% of the time. I complement w Mercury and , of course, Mail & Safari.

For linked problems w Calender i am using Fantastic.

I also changed VPN app/service to one with no hyperlinks so it doesn't freeze my app when changing some settings. Instead of XXX i now use TunnelBear and it works consistently.

This has taken the pressure off me and I'm relaxed using my iPad again!

it's a big pain erasing, resetting and attempting to recover from all the different backups, iCloud, Dropbox, etc etc and at the end there are no guarantees that solution will hold longer term.
[doublepost=1458758280][/doublepost]

It's happening a lot with, it seems, the hyperlinking and affects Mail, Safari, etc seriously.

Some TEMPORARY solutions are in Apple's support communities :
https://discussions.apple.com/message/29949888#29949888

I just posted my "solution" in this forum thread and it is still working, about a month so far
Cheers and good luck!
 
  • Like
Reactions: tigerandyx9

tigerandyx9

macrumors newbie
Nov 14, 2015
6
6
London, UK
I'm relieved to know that I am not crazy and that this is a known issue. I read the post in the forum you linked to and it's crazy because there is no pattern. I have a 128GB LTE & WiFi iPad Air 2 which had every 9.3 beta installed and to this date i've never had the issue. Meanwhile, some people in the forums have had the issue with their iPad Air. I have a 128GB iPhone 6s and I've have the issue since the 9.3 betas. I have reinstalled the OS 4 times and 2 of those times I didn't install the 9.3 beta. I've always setup the phone as new with no backup information being copied back. All four times everything was fine and dandy and out of the blue, the problem started. One thing I did notice is that most people who's iPhone was affected had an iPhone 6s with 128GB. Maybe it's only affecting these devices? Who knows. All I know is that it's an annoyance. It affects News links in spotlight, links in Mail, Links when Google is used as the search engine in Safari, Links in text messages, links in Whatsapp, Apps that try to open a web page for you to sign in. Basically, it's affecting enough aspects of the operating system to make it painful to use my phone. As a work around for now, I am using Bing as the search engine in Safari and i'm using Outlook as my mail client since I can set Chrome as the browser to open links. For any text messages I get with links, I forward them to my gmail account and open them in the Gmail app. More work than I wish, but it's the workaround that works for now. It's worth notting that I tried to use Chrome as my browser. Even in Chrome though, if you have Google set as your default web search service, links will not open when you perform a search so it's not just affecting built in iOS apps.
That's right...you need to do a long press in Chrome and then choose "open new tab" and then it works...as u said, all are affected
 
  • Like
Reactions: Cacarrof

schmegs

macrumors member
Nov 9, 2007
35
11
Burbank, CA
Yeah, this has been driving me nuts. I can partially fix the problem by disabling Javascript to fix a lot of links in Safari, but there are some pages I like that require Javascript. Also, that doesn't fix the problem of clicking links in Mail or other apps...
 
  • Like
Reactions: tigerandyx9

tatabox34

macrumors newbie
Mar 24, 2016
26
17
Hi, it started happening today, when I long tap a link to open it on background safari stops responding. I uploaded a video to youtube so you can have a better understanding of the issue.

I tried turning off the phone and I tried hard reset. Also I closed the ad-block and cleared cache of the Safari but nothing worked.


Edit: I tried restore but it didn't work either. Only thing left is Apple to release a fix, I hope that they're aware of the issue. Without Safari and Mail app 6s is only a shiney brick.

Edit 2:It also happens when I click a link on a third party app (like what's app) to open a pagemin safari. It gets stuck on the third party app and the app doesn't respond like the safari video I posted.

 
Last edited:
  • Like
Reactions: echo1877

Max(IT)

Suspended
Dec 8, 2009
8,551
1,661
Italy
Not happening on my iPhone 6S nor on my iPad mate

Long tab and the menu opens
 

Attachments

Last edited:

odoy

macrumors regular
Aug 4, 2015
119
41
Germany
Hi, it started happening today, when I long tap a link to open it on background safari stops responding. I uploaded a video to youtube so you can have a better understanding of the issue.

I tried turning off the phone and I tried hard reset. Also I closed the ad-block and cleared cache of the Safari but nothing worked.

It's an old bug since the first 9.0 beta/alpha.
It has nothing to do with the ad blocker and I can reproduce it on different iPhones. Just open a link in background after you safari don't use for a couple of hours.
In my case it's enough to kill safari. If the bug happen, you can see how the tab goes to the upper-left corner, instead of down-right.
Why I don't report this? It's not my job to improve their products. Where is apples quality assurance?
 
Last edited:

Mrfatboy

macrumors 6502
Dec 15, 2008
273
2
Safari is constantly crashing on me when I tap a link imam email, Tweetbot, etc.

Unbelievable. I should be never have updated to 9.3.

6s plus
 

eyeseeyou

macrumors 68040
Feb 4, 2011
3,051
1,430
I'm having this issue with links in the mail app also. Didn't start happening until I updated to the official 9.3 build. This is making it extremely difficult to use.

6s plus
 

koolzero

macrumors regular
Jun 30, 2010
115
10
Exact same issue for me. I beta tested 9.3 and never had any issues up until the final release version. I've hard restarted many times, turned off content blockers, reset network settings nothing has helped. Hope there is a fix soon.

Clicking on spotlight news headlines don't load either.

I have a 128GB 6.
 

eyeseeyou

macrumors 68040
Feb 4, 2011
3,051
1,430
Funny how this is making my "phone" almost unusable.

This is extremely frustrating considering this wasn't an issue until I updated to the official 9.3 build
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.