Lion doesn't automatically connect to internet

Discussion in 'Mac OS X Lion (10.7)' started by goombamd, Jul 23, 2011.

  1. goombamd macrumors member

    Joined:
    Apr 18, 2010
    #1
    Not sure if this is a "security feature" but when I turn on my mac, it doesn't automatically connect to the internet. I have to type in my keychain password and it still doesn't connect. Once I go to the wifi menu bar at the top right and click on my wireless network, then it connects. Kinda annoying. Any way to make it connect automatically on the HOME network?
     
  2. 184550 Guest

    Joined:
    May 8, 2008
    #2
    Sounds like a problem on your end.

    When I installed Lion I didn't encounter that problem. It recognized my wifi network immediately and connected. I didn't have to select my network and enter my password
     
  3. saguakid macrumors member

    Joined:
    Mar 4, 2011
    #3
    My iMac does not stay connect to wifi when computer goes to sleep,my macbook pro is ok,so when i wake it up then look for my wifi,how could i fix this
     
  4. wpotere Guest

    Joined:
    Oct 7, 2010
    #4
    Actually it looks a little like a bug. We have noticed on our two macs that the internet will connect automatically and sometimes we have to manually do it.
     
  5. ^^BIGMac macrumors 6502a

    ^^BIGMac

    Joined:
    Dec 10, 2009
    #5
    :mad:
     
  6. eddie832, Jul 24, 2011
    Last edited: Jul 26, 2011

    eddie832 macrumors newbie

    Joined:
    Jul 24, 2011
    #6
    My iMac was not connecting to Wi-Fi automatically when waking from sleep. Going to the Energy Saver preferences and checking "Wake for network access" seems to have fixed this for me.

    It's worth noting that my Macbook air does not have this problem. And "Wake for Wi-Fi network access" was checked by default.

    UPDATE: The iMac fix I described above is not working, my iMac still won't connect to wifi after waking from sleep.
     
  7. i.lilly macrumors newbie

    Joined:
    Jul 24, 2011
    #7
    The same thing is happening to me too! I have a late 2009 MacBook Pro. I never had a problem with auto connecting to my wifi network when I was running Snow Leopard. Any advice? It does not appear to be a network problem as the other computers in the house are able to auto connect (including one running lion).
     
  8. adityanag macrumors newbie

    Joined:
    Oct 28, 2009
    #8
    Same Problem

    2009 Macbook Pro, same problem. Never had an issue with Snow Leopard, and the other Macbook in the house (Snow Leopard), as well as a Windows laptop, and sundry phones have no issues.
     
  9. marmiteturkey macrumors 6502

    marmiteturkey

    Joined:
    Aug 27, 2005
    Location:
    London
    #9
    New macbook air 13, same problem. Won't automatically connect, often the first time I point it at my network it has a timeout error, then the second time it goes through.
    Same on every other network too.
     
  10. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #10
    2009 17" MacBook Pro. No problems at all. Your problem is not generic to Lion. This means that the problem is specific to either your computer or to your Wi-Fi network. Do you have a clue what that is?
     
  11. adityanag macrumors newbie

    Joined:
    Oct 28, 2009
    #11
    Nope. Everything was working fine till I installed Lion. No changes in the router config or anything else. The only variable that's changed is Lion.

    I deleted all my wifi profiles, and all the saved passwords from Keychain, rebooted, and let it detect again. It seems to be working better now, but there are still a few hiccups. Let's see.
     
  12. flyn01 macrumors newbie

    Joined:
    Aug 2, 2011
    #12
    Lion no longer connects to preferred network

    I had the same problem with "Lion" on my MacBook. I fixed it by:

    Open "System Preferences"
    Select "Advanced"
    Select the "Wi-Fi" tab
    Search for your preferred network and drag it to the top of the preferred network list.

    I deleted all the others from the many networks I've joined on my travels.

    Worked like a champ.
     
  13. cibergatox macrumors newbie

    Joined:
    Jul 4, 2011
    Location:
    Costa Rica
    #13
    Mid 2011 15" MBP Didn't connect immediately after waking while running Lion... So I tried this suggestion:


    I deleted some networks I never use, and I got connected like it did while running SL 10.6.8
     
  14. wpotere Guest

    Joined:
    Oct 7, 2010
    #14
    Still having the issue of it not coming back quickly after it has been put to sleep. I only have one network on the system...

    Very buggy to say the least.
     
  15. BostonBrawler macrumors member

    Joined:
    Jun 22, 2011
    #15
    It is definitely a Lion issue. Noticed it on my 2010 MBP17 after install, and new 13Air I got last week. Doesnt happen all the time, but mostly when I go into a new network area on my air.
     
  16. davidwarren macrumors 6502a

    Joined:
    Aug 28, 2007
    #16
    Yup, my new Air will not connect automatically from sleep. I have tried all the usuall fixes, seems to be a lion bug. I haven't had this issue since Tiger.
     
  17. tigres macrumors 68040

    tigres

    Joined:
    Aug 31, 2007
    Location:
    Land of the Free-Waiting for Term Limits
    #17
    Another thing you may find odd (or I did) was the transmit rate was decreased (or reported as decreased) by 30-50 on Lion vs. SL.

    On Lion, my home wifi transmit rate was 270, and on SL it is 300.

    Not sure if this has anything to do or help you on, but you can check your distance, and transmit rates to put that in your mix. (btw, hit option +click your wifi menu in toolbar)

    FWIW
     
  18. alpineraven macrumors newbie

    Joined:
    Apr 9, 2011
    #18
    I have the same problem with my MacBook late 2009 (Snow Leopard was perfect but Lion nah), obviously its a bug - it doesnt automatically connect to WIFI network and its a pain because I go approx 4-5 different WIFI networks including iPhone - Used to automatically connect after wake - now it doesnt - have to click on WIFI menu to get it connected... Annoying that have to do that. Also I do have timeout connection issues too.
    Cheers
    AP
     
  19. kingston, macrumors newbie

    Joined:
    Aug 2, 2011
    Location:
    canada
  20. mike21190 macrumors member

    Joined:
    Jul 1, 2008
    #20
    Don't want to hijack this thread, but I'm having a similar problem. My 2011 MBA connects to wifi without a problem after in sleep mode, but randomly as I'm using Safari pages stop loading. I check istat and there is nothing going in or out on the network at these times. I have to turn wifi off and on to get them to load again. It's happens quite often. Are you guys having this problem as well?
     
  21. jornalero macrumors newbie

    Joined:
    Aug 2, 2011
    #21
    Disconnect Time Machine Drive

    Found this temporary solution on another blog.

    I turned off Time Machine and disconnected my USB Time Machine backup drive. Had to do both. Now I have no problem staying connected to the Internet via WiFi and Lion.
     
  22. handheldgames macrumors 6502a

    handheldgames

    Joined:
    Apr 4, 2009
    #22
    From the MacPro forum: http://forums.macrumors.com/showthread.php?t=1202229

    In a fresh install of Lion 10.7(or upgrade from 10.6.8), after a wake from sleep,

    Both Ethernet ports on the MacPro have about a 45 second delay before they initialize and become active....

    After thinking it was a hardware issue, I've verified this doesn't happen on 10.6.8.

    Details from the console:

    7/30/11 10:35:48.000 AM kernel: 00000000 00000000 Intel82574L::timeoutHandler - has to reset the chipset once since there is still no link for the workaround

    7/30/11 10:36:13.000 AM kernel: Ethernet [Intel82574L]: Link up on en0, 1-Gigabit, Full-duplex, Symmetric flow-control, Debug [796d,af08,0c01,0200,cde1,3c00]
    __________________
     
  23. cokito macrumors newbie

    Joined:
    Jun 9, 2011
    #23
    Same prob. I never used time machine, it's off.
     
  24. littlebudha macrumors newbie

    Joined:
    Feb 24, 2009
    #24
    I was also having the same problem after installing Lion on my MacBook Pro. After turning off Time capsule, it works flawlessly.
     
  25. gentlefury macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #25
    My MacBook Air auto connects to wifi flawlessly...when I get to work I'm online and when I get home I'm online.
     

Share This Page