Lion right click delay?

Discussion in 'Mac OS X Lion (10.7)' started by LinMac, Jun 25, 2011.

  1. LinMac macrumors 65816

    Joined:
    Oct 28, 2007
    #1
    When I use the two finger tap (right "click", but no trackpad click), there seems to be a small delay of 1 or 2 seconds before any menu will appear. This happens in Firefox, Chrome, in the Dock, and even in Finder.

    Is there any way to fix this?

    Note: There is no delay when using single finger tap (left "click", but no trackpad click).
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    I'm not seeing this "issue." Are you on the latest dev preview?
     
  3. LinMac, Jun 25, 2011
    Last edited by a moderator: Jun 25, 2011

    LinMac thread starter macrumors 65816

    Joined:
    Oct 28, 2007
    #3
    Yes, I am on the latest developer preview with all updates from Software Update.

    I can recreate this on a Macbook Air Rev. B and a 2011 Core i7 Macbook Pro (one with RunCore SSD and one with official Apple SSD) both using File Vault.
     
  4. baryon macrumors 68040

    baryon

    Joined:
    Oct 3, 2009
    #4
    See if you have any other 2-finger gestures enabled. Maybe 2-finger double-tap to zoom in Safari, you should disable that if there is such an option.

    I know that in Snow Leopard, enabling drag lock causes the single click to have a slight delay, which is extremely annoying.
     
  5. registered macrumors member

    Joined:
    Feb 6, 2006
    #5
    Solution!

    Dearest LinMac and anyone else it concerns,

    I too had this problem, and believe me, I wanted to blow my brains out. It was THE MOST irritating thing about Lion for me, because I'd become so reliant on the right tap speed. I searched for solutions and it seemed no one had this problem. I wanted to revert to Snow Leopard.

    Disable "Smart Zoom" in the Scroll & Zoom panel in Trackpad in System Preferences. Your right taps will now respond as though they are powered by ten million thoroughbred horses on the highest mountain peak of the most distance and extraordinary planet.

    Your bud,
    R

     
  6. MikhailT macrumors 601

    Joined:
    Nov 12, 2007
    #7
    Disable the smart zoom in Trackpad options in System Preferences. It’ll get rid of the lag.
     
  7. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #8
    YES! Thank you! I really didn't mind it but it was an annoyance. I JUST noticed this too when playing with my mouse and realized that the menu appeared almost instantly with a mouse vs. a slight delay when using the trackpad! I guess disabling Smart Zoom makes sense because the software is trying to determine whether or not you want to zoom in something hence the delay.
     
  8. stankuo macrumors newbie

    Joined:
    Jun 21, 2009
    #9
    Thank you sir. This solves the 2 finger secondary issue immediately.
     
  9. iBreatheApple macrumors 68020

    iBreatheApple

    Joined:
    Sep 3, 2011
    Location:
    Florida
    #10
    Thank you so much!
     
  10. 3bs macrumors 603

    3bs

    Joined:
    May 20, 2011
    Location:
    Dublin, Ireland
    #11
    THANK YOU! That was driving me crazy and I thought there was something wrong with my laptop. I never used smart zoom anyway.
     
  11. radiogoober macrumors 6502a

    Joined:
    Jun 7, 2011
    #12
    bump, but wanted to thank you - this solved my right click issue with the trackpad
     
  12. Velorium macrumors member

    Joined:
    Aug 23, 2009
    #13
    Fixed my problems too, many thanks!
     
  13. roncool macrumors newbie

    Joined:
    Aug 8, 2013
    #14
    Mate, literally only made this account to thank you, I was so scared that my Macbook Pro was slowing down.
     
  14. PeteJames macrumors regular

    PeteJames

    Joined:
    Sep 11, 2010
    Location:
    England
    #15
    Disabling smart zoom worked for this same issue I'm having with mountain lion. Great, thanks!
     
  15. PghMike4 macrumors newbie

    Joined:
    Jan 14, 2013
    #16
    Thanks -- worked perfectly!
     

Share This Page