Lion special characters (holding key)

Discussion in 'Mac OS X Lion (10.7)' started by murdercitydevil, Jul 24, 2011.

  1. murdercitydevil macrumors 68000

    murdercitydevil

    Joined:
    Feb 23, 2010
    Location:
    california
    #1
    If you don't know this already, apparently there's a feature in Lion where pressing a certain key and holding it will pop up a small menu of special accented characters for that letter, for instance if I hold e, I can quickly select é. This would be great if I typed accented letters often. Except I don't. However, I often DO hold down a key to type things like "AAAAAAAAAHHHHHHH!!!!!" Well this option seems to be system-wide, affecting even Adium and Word, which is unacceptable. I can't even repeat non-accented characters like "Q," if I hold the key down it refuses to type more than one. How the hell do I turn this off?

    EDIT: I just found the solution. If you want to disable this, open terminal and type

    Reboot, and it will be back to normal. Holy crap how is this not an easily configurable option??
     
  2. NameUndecided macrumors 6502a

    Joined:
    Mar 28, 2011
    #2
    Thanks for the tip on how to turn it off. But I say, anything that encourages the use and/or study of multi-lingual communications in lieu of making it a little easier for people to write "Aaaaaaaah" and "Nooooooo!"'s is perfectly okay with me. (I kid. Sort of. ;) )
     
  3. Goldfrapp macrumors 68040

    Goldfrapp

    Joined:
    Jul 31, 2005
    #3
    Thanks for the tip. I disabled it right away.
     
  4. eyespii macrumors 6502

    Joined:
    Mar 8, 2008
    #4
    thanks so much for the tip! Amazing that there isn't an easily accessible option somewhere for this.
     
  5. WonkyPanda macrumors regular

    WonkyPanda

    Joined:
    Mar 29, 2010
  6. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #6
    Thanks for the tip.

    Just for fun, I thought I'd play with the key repeat settings. Guess what? Key repeat doesn't work at all. I tried the old standby of turning the feature off, then on; played with speed and delay - no affect. ('x' and 'd' were my test subjects)

    If anyone can try key repeat and confirm what I found (or, tell me they have it working), it would be appreciated.
     
  7. shrx macrumors newbie

    Joined:
    Jul 23, 2011
    #7
    well it seems to work but not in all applications. in firefox it still doesn't.
     
  8. murdercitydevil thread starter macrumors 68000

    murdercitydevil

    Joined:
    Feb 23, 2010
    Location:
    california
    #8
    That's what I thought too. Try holding down a key like "H" in FF with it enabled. It won't repeat.
     
  9. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #9
    Well, I did find a mode where key repeat does work: if you use the standard modifier key to get to a special character (such as opt-a), it'll repeat just fine.

    But, no key, whether it has optional characters or not (like a 'd' or 'x') will repeat if held by itself.
     
  10. mittgenstein macrumors newbie

    Joined:
    Dec 29, 2013
    #10
    nice info - and here is how to reverse it...

    hi,

    i actually had the opposite problem: my keyboard suddenly did not recognize the hold-key-function anymore. so going to the terminal and typing in

    defaults write -g ApplePressAndHoldEnabled -bool true

    enables the special characters option - which, btw, is a great tool for bilingual people... :D (don't forget to restart the computer...)

    cheers!
     

Share This Page