lion superdrive won't mount????

Discussion in 'Mac OS X Lion (10.7)' started by pitt1717, Aug 10, 2011.

  1. pitt1717 macrumors regular

    Joined:
    Jul 13, 2007
    #1
    not sure what the issue is but since i installed lion my superdrive stopped working. If i open disk utility i see the super drive and can see star wars disk underneath but i have to manually mount it.
    but once i do, dvd player won't play it.. has anyone else run across this and have a fix, please help

    thanks
    vinnie
     
  2. waxwing1 macrumors newbie

    Joined:
    Dec 30, 2008
    #2
    Same here but for other "external" drives too

    I have the same problem with the SuperDrive. I also have to manually mount any USB flash drives inserted. My internal HDD are all fine. Been pulling my hair out since I frequently rip audiobooks from CD and have to remount every time I insert a new drive.

    Did you find a solution?
     
  3. waxwing1 macrumors newbie

    Joined:
    Dec 30, 2008
    #4
    Another solution

    Thanks. I called Apple. In the process of trouble shooting, we created a new user account, logged into it, and noticed that the drives (CD/DVD, USB thumb, external USB drive, external eSata drive) all mounted. I closed the account and logged back into my main account and suddenly they all mounted. Strange but creating the new account seemed to do the trick for me.

     
  4. pitt1717 thread starter macrumors regular

    Joined:
    Jul 13, 2007
    #5
    actually been meaning to post (been a long week)

    i repaired permissions no luck, then i rebooted and then it started working. alls fine now, if it happens again, i will try you link
     
  5. Turian.Spectre macrumors regular

    Turian.Spectre

    Joined:
    Aug 31, 2010
    #6
    glad yours works. I have a problem myself. I think it might be related to this thread however nothing has helped me yet. I'm writing a message on apples discussion forum now. I doubt it will bring any results. I'm starting to seriously think of downgrading back to Snow Leopard. this is the first bad experience i had with mac OS ever! reminds me of my windows days. remember those? when you had to spend hours/days to fix something? The reason I got a mac is to have a computer that just works, even though i do not know how. have a look at my post, and let me know if you have any ideas? thanks.
    http://forums.macrumors.com/showthread.php?t=1209927&highlight=
     
  6. costarec macrumors newbie

    Joined:
    May 18, 2014
    #7
    mounted drive "returns" when logging off

    I've gone through a similar experience with my superdrive. When I would insert a music CD the superdrive wouldn't even show up in iTunes, and I could not see the drive in Finder. I could see it in Disk Utility but there was nothing I could do with it from there. I was logging off to try the solution posted here about logging in as another user. I had iTunes running and when logging off, OSX told me iTunes was blocking the logoff and did I want to force the logoff. Then iTunes displayed the CD that had already been inserted in the SuperDrive and everything worked normally form there.

    So, I guess I'm suggesting that you just try opening iTunes, insert your music CD in the drive (it isn't recognized in iTunes or Finder - this is the problem), and simply attempt to log off.

    --hope this helps.
     

Share This Page