Lion wont boot after failed update

Discussion in 'Mac OS X Lion (10.7)' started by insomniac321123, Apr 29, 2011.

  1. insomniac321123 macrumors 6502

    Jan 23, 2006
    I tried installing the update today. During the installation it stalled and hung at "moving items into place". After a couple hours, I forcibly shut down the computer. Now it will not boot. I can get into the gray screen but it hangs there and wont progress. I have tried booting into safe mode (holding shift). The loading bar comes up, it makes it about a quarter of the way and reverts to no loading bar and a spinning indicator. Before I reformat and reinstall, is there anything I can try? I have a SL partition on the same disk, so I have access to the lion disk.

    And before anyone asks, I do have a backup, its not a huge deal to reinstall, it would just be simpler to fix it.
  2. wpotere, Apr 29, 2011
    Last edited: Apr 30, 2011
  3. jake4ever macrumors regular

    Jul 2, 2009
    Ma'on La'oved, Hadera, Israel
    I had to reset my entire computer.
  4. insomniac321123 thread starter macrumors 6502

    Jan 23, 2006
    I was able to salvage the instal by booting into SL and finding the .pkg called "lionswupdate.pkg" in the updates folder of the root library. I ran it in SL and selected the lion partition as the target. I am back up and running.
  5. daneoni, Apr 29, 2011
    Last edited: Apr 29, 2011

    daneoni macrumors G4


    Mar 24, 2006
    Could you provide the exact file path to this pkg file because there is no such pkg in my updates folder. Mine updated successfully but simply refuses to boot. It freezes at the Apple logo spinning gears screen and the gears just stop spinning and fans ramp up.

    Edit: Nevermind. Just gonna nuke the entire partition. Twas fun whilst it lasted.
  6. alexryans macrumors member

    Nov 10, 2010
    Exact same issue here. Are you, by any chance. using a 2011 MBP? My iMac's updated fine, but I get this issue only on my MBP.

    I've tried reinstalling DP2 and then upgrading to the new build twice now and get the same issue - only way I can get around it is to completely reinstall DP2, but not install last night's update.

    It's so frustrating, because everything feels snappier and more responsive on my iMac - I'd love it on my MBP.
  7. alexryans macrumors member

    Nov 10, 2010
    Hmmm...I wonder if it's incompatible with 2011 MBPs, then. I have friends who have 09/10 MBPs and the update has installed with no issues for them.

    The only thing that's making me reserve judgement on its incompatibility is Apple pushing it out to '11 MBPs and not making any comments in the 'About This Update...' section of the Software Update. It seems very lax on their part.
  8. tourada macrumors regular

    Feb 27, 2011
    Same thing for MB 2009. Had to reinstall Lion and right now I won't update until it is resolved.
  9. insomniac321123 thread starter macrumors 6502

    Jan 23, 2006
  10. TheralSadurns macrumors 6502a

    Jul 8, 2010
    Same issue here...
    2011 MBP. DP2 ran fine. The first DP2 Update did also work w/o a flaw. Just applying the last update destroyed and the Book freezes during the boot process as stated above.
    Gonna reinstall DP2...
    Really kind of lame this issue... but's a Dev Preview... things like that can happen...
  11. alexryans macrumors member

    Nov 10, 2010
    Just to chime back in on this one - as with the previous poster, the first update to DP2 worked flawlessly for me too. I wonder how/if we'll know when Apple fix the download...?
  12. Yamcha macrumors 68000

    Mar 6, 2008
    I had the same problem, I had to format and install again :p.. Not going to bother with the update yet..
  13. Fishrrman macrumors G5


    Feb 20, 2009
    I was experiencing the same problems as others after installing DP3.

    That is, installation seemed ok, UNTIL it got to to "moving items into place" after which it hung.

    I forced a restart, and ended up with the grey screen and spinning gear.

    I followed insomniac321123's suggestion:
    - rebooted to Snow Leopard
    - opened the root Library folder
    - opened the Updates folder and located the "lionswupdate.pkg"
    Note: it was located in a folder named "041-0870"
    The pathway is (root)/Library/Updates/041-0870/lionswupdate.pkg
    - double-clicked that, re-ran the installer app.
    - this time, when it got to the "moving items into place" segment, the task finished (in relatively short time) and I received "the installation was successful".

    After this, I was able to restart and get a "good boot" to 10.7 build 11A444d.

    Other observations:
    When I _shut down_ Lion the first time after the update, it seemed to take extra time, with quite a bit of disk activity. I'm going to _guess_ that the problem may be due to files that normally get written at shutdown to be read at the next boot. These would normally be read and pre-loaded before the finder loaded, but could not be, hence the spinning wheel that prevented the finder from loading.

    After I finally got a good boot after running the procedure above, and Lion corrected whatever it needed to correct at shutdown, subsequent shutdowns are "normal" again.
  14. insomniac321123 thread starter macrumors 6502

    Jan 23, 2006
    This was my experience exactly. I've been out of town, so I haven't been able to post very well.

    Thats one of the big perks of having a second, more stable partition. Besides having another OS to fall back on, you still have access to the disk of the problematic OS.
  15. tourada, May 2, 2011
    Last edited: May 2, 2011

    tourada macrumors regular

    Feb 27, 2011
    For all those having this issue (which seem to be A LOT) send a bug report. Hopefully with enough people having this issue, Apple will release a new software update that actually doesn't crash.

    Update: Bug submitted for Macbook 6,1 but anyone running other hardware that has the same problem should submit a bug report.
  16. Obispo8u macrumors newbie

    May 3, 2011
    Need Help

    Hi Guys,

    Same problem hung up on install, powered off and stuck on gray apple screen with spinning gear. I'd like to keep Lion, but am OK with SN L in the alternative.

    I am a rookie. No partition. Possible backup on an external hard drive. I have the SN L disc but want a work around.

    If I do a full reinstall with SN L will I lose my iTunes?

    I can get in through the disk utility, can I do anything from there?

    Please help and excuse my ignorance.

  17. Obispo8u macrumors newbie

    May 3, 2011
    Another Question

    I believe I do have a backup from 10 Apr that is a Lion back-up. Can I restore to that point and then partition and reinstall snow leopard?

    I want to be able to boot to either.

  18. daneoni macrumors G4


    Mar 24, 2006
    I found a temporary workaround for 2011 MBP owners. After doing the latest update, boot in SL and navigate to the Update folder mentioned above and delete the ProductMetadata.plist file. Then reboot and the Lion should boot as per normal

    Note that you'll have to do this every time you want to boot Lion which is strange but there you go. I'm typing this from the latest build of Lion on a 2011 MBP.
  19. deanrr macrumors newbie

    Jul 11, 2008
    I was having the same problem, moving the plist didn't help, but moving IO80211Family.kext out of the extensions folder has let me boot.
  20. deanrr macrumors newbie

    Jul 11, 2008
    Even after updating to the latest update released last night, it wont boot if IO80211Family.kext is in the Extensions folder, booting hangs on

    Created virtif 0xffffff80144b4e00 p2p0
  21. alexryans macrumors member

    Nov 10, 2010
    Moving the .plist didn't help me, either. Booting still hung on 'the wheel'. I tried installing the update again via my SL partition, but that was a no-go, either. I'm going to try this extensions thing and see if it makes any difference. I really hope so, because I'm running DP3 on my iMac and it's amazing!
  22. alexryans macrumors member

    Nov 10, 2010
    Moving the .kext out of the Extensions folder worked like a charm for me, but my WiFi won't work and it won't let me re-install the .kext!
    I'm just updating to DP3 on my 2011 MBP now, so I'll see if that solves the problem.

    At least I can boot into 10.7 now, so that's one good thing - last hurdle now is to get WiFi working once again.
  23. Atarikid macrumors regular

    May 14, 2011
    Yes, removing the IO80211Family.kext does let me boot also (MBP early 2011)
    No WiFi though. Strange this isn't fixed with DP3. This is a very obvious bug imo

    BTW Is it just me or ... but Lion DP3 is not working smooth (graphically I mean). Everything is not 'snappy' compared to SL.

Share This Page