Location arrow?

Discussion in 'iOS 8' started by pish6969, Sep 17, 2014.

  1. pish6969 macrumors regular

    Joined:
    Sep 10, 2014
    #1
    Just updated to ios 8. Now I have the location arrow up in top right of screen next to battery. I'm not running anything that should be using location services.

    Any way to get rid of this?
     
  2. Yun0 macrumors 65816

    Yun0

    Joined:
    Jun 12, 2013
    Location:
    Winnipeg, Canada
    #2
    go to the system location services where iad is etc & look at it..probably going to be spotlight suggestions
     
  3. SurefireObject macrumors member

    Joined:
    Aug 6, 2014
    #3
    It is just an outline? I have a constant outline up there. If it's the outline it means some app can use your location even when you're not using it. You can see which one in Settings.
     
  4. pish6969 thread starter macrumors regular

    Joined:
    Sep 10, 2014
    #4
    I turned off spotlight suggestions but its still there..??

    ----------

    Not an outline. Never had it show up unless I was using something with location services..just happened after ios8 update
     
  5. DMaki650 macrumors 6502

    DMaki650

    Joined:
    Jun 23, 2010
    Location:
    South Saint Paul, MN
    #5
    Look for anything Passbook related. I have the arrow and turned out a Passbook item had Auto Updates on. Also Google Wallet uses Geo Fencing which is always on unless you turn it off.
     
  6. Yun0 macrumors 65816

    Yun0

    Joined:
    Jun 12, 2013
    Location:
    Winnipeg, Canada
    #6
    well look at the others, what else is always on? also look at your app list, an app that broken on ios 8 can also constantly use location (american eagle app till recently when it was updated, bbm till this day..)
     
  7. jbachandouris macrumors 601

    jbachandouris

    Joined:
    Aug 18, 2009
    Location:
    Upstate NY
    #7
    Upgrades turn bluetooth on by default. I think iBeacon is what is using location services. Turn off Bluetooth and odds are it will go away.
     
  8. matttye macrumors 601

    Joined:
    Mar 25, 2009
    Location:
    Lincoln, England
  9. pish6969 thread starter macrumors regular

    Joined:
    Sep 10, 2014
    #9
    Bluetooth off..this going to drive me crazy!! All the settings are the same in location services from when I had ios7..so something new must be triggering this
     
  10. SurefireObject macrumors member

    Joined:
    Aug 6, 2014
    #10
    Are any of the arrows in Settings purple? That's the active one, if so.
     
  11. matttye macrumors 601

    Joined:
    Mar 25, 2009
    Location:
    Lincoln, England
    #11
    Look for something in the location services settings with an outline triangle - that's what's using your location.
     
  12. pish6969 thread starter macrumors regular

    Joined:
    Sep 10, 2014
    #12

    Google is purple..but I am not using google at the moment?

    ----------

    Nothing with outline triangle
     
  13. LXC101 macrumors member

    Joined:
    Feb 12, 2014
    #13
    I've been trying to figure this out as well and it's driving me nuts! :mad:

    Edit: I just tried unchecking Wi-Fi Networking and it went away. Call me a moron, but what's Wi-Fi Networking??
     
  14. TonyC28 macrumors 65816

    TonyC28

    Joined:
    Aug 15, 2009
    Location:
    USA
    #14
    I think the hollow arrow in the top bar just means to have location service set to on. I'm guessing that's new for iOS 8 since I've always had location services on but have never seen this.
     
  15. pish6969 thread starter macrumors regular

    Joined:
    Sep 10, 2014
    #15
    Mine is a white arrow to the left of the battery %. Is this on now for everyone with IOS8 that has location services turned on?

    I always thought that when the arrow was there, it was when you were using apps that needed your location services, but if you had them shut down, the arrow would be gone
     
  16. Morac macrumors 65816

    Morac

    Joined:
    Dec 30, 2009
    #16
    I have had the same problem since updating to iOS 8. I've also noticed that apps are showing up under the Battery Percentage that I haven't run.

    Doing some testing I've found that apps can use now location services when not running, even if they are set to disabled in the "Background App Refresh" screen.

    I've had a number of apps randomly launch as use Location Services. The worst being "Yahoo! Weather" which put up a permanent geofence even after I launched it, disabled current location and then killed the app. It was using 6% of my battery before I disabled it's access to Location Service data.

    The only way to stop apps from running in the background to grab location data is to set them to "Never" use Location Services. That effectively breaks a number of apps which need Location Services enabled to work.

    I have no idea why Apple made this change. It used to be easy to prevent an app from running in the background, simply disable it in the "Background App Refresh" screen, now it needs to be disabled both there and in the "Location Services" screen.

    I don't know what Apple was thinking making this change.
     
  17. pish6969 thread starter macrumors regular

    Joined:
    Sep 10, 2014
    #17
    I just did as you said but the arrow is still there? I have no clue what wifi networking is either..lol
     
  18. SurefireObject macrumors member

    Joined:
    Aug 6, 2014
    #18
    It's Google then. It uses your location when you're not using it. Unfortunately, there's no middle setting and it's either on all the time or off completely.
     
  19. Yun0 macrumors 65816

    Yun0

    Joined:
    Jun 12, 2013
    Location:
    Winnipeg, Canada
    #19
    wifi networking submits the mac addresses of wifi routers the phone detects around it, along with the location of the detected mac address to apple which helps improve location services, like how ipod touches & wifi only ipads get location, they dont have a gps baseband or cell data to communicate with towers to get location, all they got is wifi & thats how those devices are able to display location on a map without having cellular/gps, they use the crowd sourced wifi database
     
  20. pish6969 thread starter macrumors regular

    Joined:
    Sep 10, 2014
    #20
    Purple arrow --the description says icon will appear next to item when it was "recently" used.

    I'm talking about the icon on the home screen next to battery..that is showing up when it used to not show up

    ----------

    That sucks if this is the case
     
  21. TonyC28 macrumors 65816

    TonyC28

    Joined:
    Aug 15, 2009
    Location:
    USA
    #21
    I've tried a whole bunch of combinations of switching things on and off in Location Services and System Services. The only thing that seems to make that hollow arrow go away is turning off Location Services entirely.
     
  22. SurefireObject macrumors member

    Joined:
    Aug 6, 2014
    #22
    Just turn off Location for Google for a sec and see if the arrow in the status bar goes away.
     
  23. pish6969 thread starter macrumors regular

    Joined:
    Sep 10, 2014
    #23
    YOU NAILED IT!! I just turned it off and you were correct. Google was using it even when not using google..that sucks..now I turned it off and google now won't work without it.

    That being said..I appreciate all the help here
     
  24. DMaki650 macrumors 6502

    DMaki650

    Joined:
    Jun 23, 2010
    Location:
    South Saint Paul, MN
    #24
    Yeah I remember that being the main reason I stopped using the Google app cause the the location was always on.
     
  25. TonyC28 macrumors 65816

    TonyC28

    Joined:
    Aug 15, 2009
    Location:
    USA
    #25
    I found a different solution, at least for my problem. I turned off Traffic in System Services. That made the arrow go away for a few minutes but it came back. Then I saw that there was a purple icon with Apple Store. Looking at the info for that particular app it sounds like if you have the location services on for it you kinda have a permanent geofence on. I turned that one off and so far so good.
     

Share This Page