Location services indicator always on - waze?

Discussion in 'iOS 10' started by janeauburn, Oct 21, 2016.

  1. janeauburn macrumors 6502a

    janeauburn

    Joined:
    Nov 22, 2015
    #1
    iPhone 7 plus, ios 10.0.3, location indicator always on (not so on iPhone 6 Plus). I find that if I turn off Waze's "always" setting for location (there is only "always" and "never" for waze), the indicator disappears. But obviously you can't use Waze without location. Anyone know a solution? Thanks.
     
  2. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
  3. edlex macrumors 68000

    edlex

    Joined:
    Apr 14, 2010
    Location:
    Miami
    #3
    Same happens to me with waze. I only allow location when I'm going to use it because of this. It was that way with my 6+ and my 6S+ too.
     
  4. SoloStyle macrumors regular

    Joined:
    Oct 17, 2011
    #4
    At this point I'm just used to my location indicator always being on. I have apps which continuously use it like Nest and Waze. It's my understanding that they are not constantly polling the GPS location, but rather grabbing this info from where it's stored in the phone. I believe the way it works now is that the iPhone grabs a quick snapshot of your location every time you wake it, and stores this info. Other apps simply grab that or requests a new snapshot of their own, if needed.
     
  5. janeauburn thread starter macrumors 6502a

    janeauburn

    Joined:
    Nov 22, 2015
    #5
    Yes. Give it a shot and see if you see the same issue.
    --- Post Merged, Oct 21, 2016 ---
    I have a 6 Plus running IOS 9, and it doesn't happen. So I'm not sure whether it's related to IOS or the model of iphone. It happens with iPHone 7 plus and IOS 10.
    --- Post Merged, Oct 21, 2016 ---
    I'm just trying to minimize battery use. From what I read, having an app polling the phone constantly will drain battery quicker.
    --- Post Merged, Oct 21, 2016 ---
    Found the fix:

    From within the WAZE app:

    Settings -> General -> Location Change Reporting: Turn this OFF.

    Voila.

    Dumb app. But necessary.
     
  6. newellj macrumors 601

    Joined:
    Oct 15, 2014
    Location:
    Boston, MA, US
    #6
    Waze has always been a huge battery-burner for me. I'll give that last tip a try - thanks for reporting that.
     
  7. imorton macrumors 6502

    Joined:
    Aug 21, 2010
    #7

    I don't see that setting anywhere in my setting... ? :(
     
  8. mpavilion macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #8
    This happens with Waze if you have "Location change reporting" turned on. I'm used to it; don't even notice the persistent Loctation symbol any longer.
     
  9. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #9
    Where is that option? As another user mentioned, it doesn't seem to be in Waze settings.
     
  10. mpavilion macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #10
    Open the app itself; slide open the left-hand pane; hit the gear icon at the top; hit "General" under Advanced Settings -- "Location change reporting" is the fifth option down. The app needs this to be active in order to give you "time to leave" notifications.
     
  11. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #11
    No such option there (for me, and seemingly at least another user that mentioned the same earlier).
     
  12. mpavilion, Oct 21, 2016
    Last edited: Oct 21, 2016

    mpavilion macrumors 6502a

    Joined:
    Aug 4, 2014
    Location:
    SFV, CA, USA
    #12
    Odd; what version of the app do you have? (Mine is 4.13.0.4.)

    I've attached a screenshot (I'm on an iPhone SE, if that somehow makes a difference.)

    Btw -- this feature has been there for what feels like at least a year (I remember stressing out at first about this same issue -- the persistent "location services" symbol -- then forgetting about it). They may have changed the name at some point; maybe it was originally just called "Location reporting," or "Background location reporting"?
     

    Attached Files:

  13. TwoBytes macrumors 68020

    TwoBytes

    Joined:
    Jun 2, 2008
    #13
    I haven't got this feature too. Latest version of Waze..
     
  14. msingewald macrumors newbie

    Joined:
    Jul 13, 2008
    #14
    I know this is an older thread, but Google brought me here searching for this answer, so...

    Found the setting in the current version of Waze. It is under Settings > Advanced Settings > General. You will see Location Change Reporting

    This is version 4.26.0.4
     
  15. B737 macrumors 6502a

    B737

    Joined:
    Oct 22, 2008
    Location:
    Jersey Shore
    #15
    For those of you scratching your heads wondering where this setting is I have some intel...

    last night i was reading this thread, couldnt find "location change reporting", it wasnt there.
    this morning i used waze and set up a planned drive to a location so it would alert me when to leave.

    when i enabled the planned drive to the destination, waze asked me "you need to enable location change reporting to get alerts when to leave" i hit accept.

    then went into settings > general, and sure enough the option was now visible.
     
  16. roki1958, Sep 6, 2017
    Last edited: Sep 6, 2017

    roki1958 macrumors newbie

    roki1958

    Joined:
    Apr 2, 2010
    Location:
    Los Angeles
    #16
    Just added Waze. 7plus on latest iOS. I do not have the option to turn off "location change reporting" in my settings. When I planned a trip I got a message to change my settings in iOS Location for Waze to Always. No request about "location change reporting". I still have the flashing notice on top. This not acceptable to me.

    I touch the top of the screen to scroll to the top in all of my apps. But now I bring up Waze instead. The only ways I found to turn this off is by either force quitting the app or, in Waze, putting it in sleep mode.

    This does not give me much confidence in this app.
     
  17. KGB7 Suspended

    KGB7

    Joined:
    Jun 15, 2017
    Location:
    Rockville, MD
    #17
    Same here as well. The only time I use Waze is too see why there is traffic ahead.
     
  18. roki1958 macrumors newbie

    roki1958

    Joined:
    Apr 2, 2010
    Location:
    Los Angeles
    #18
    I found out that if you go to iOS Settings/ Privacy / Location Services / Waze and you change the setting to Always On, then the flashing bar at the top goes away. Seems to me it's Waze's way to make you set the Location Services to Always On.
     
  19. KGB7 Suspended

    KGB7

    Joined:
    Jun 15, 2017
    Location:
    Rockville, MD
    #19
    I have it set to While Using.
     

Share This Page