Logic Board Reset for A1316 27" LED Cinema Display

Discussion in 'Mac Pro' started by tikku22, Oct 6, 2016.

  1. tikku22 macrumors newbie

    tikku22

    Joined:
    Oct 6, 2016
    #1
    Hi Folks...

    I replaced the Logic Board ($160) on my A1316 pre-Thunderbolt 27" LED Cinema Display with a "guaranteed brand new OEM board" (their words, not mine).

    I downloaded the EDID Reset Tool. However, when I run the tool, the "Reset EDID" button is grayed out (unclickable) and is asking me to "Connect LED Cinema Display to begin." I've tried unplugging / re-plugging / re-booting the display and CPU but no change. As a result, there is no brightness control, no USB, and no camera. Audio controls are working and the display is on without intermittent black-out issues (for now).

    Any suggestions on what to do to get the display working fully?

    Thanks,
    Paras.
     
  2. h9826790 macrumors G4

    h9826790

    Joined:
    Apr 3, 2014
    Location:
    Hong Kong
    #2
    May be you have to open it up again and check the USB cable connection.
     
  3. tikku22 thread starter macrumors newbie

    tikku22

    Joined:
    Oct 6, 2016
    #3
    Thanks.. I opened it up and, unfortunately(??), the USB was connected securely into the Logic Board. Any other suggestions? I agree, I think it's something with the USB portion of the system. Perhaps the All-In-One Cable that I have previously reported as being problematic? But this time, I just put in a brand new cable a few months ago and am surprised that it would go bad already.
     

Share This Page