Mac Air (2012) wont boot anymore

Discussion in 'macOS Sierra (10.12)' started by simogoesos, Jun 25, 2017.

  1. simogoesos macrumors newbie

    Joined:
    Jun 25, 2017
    #1
    Hi Guys,

    First timer here! I have a macbook air 2012 model and it has been working like a dream for years. The other day either after installing a Datto backup application on it or a apple software update (not sure if the update did occur) the laptop started playing up. In the Finder, the document and other shortcuts were showing numbers N.80, B.85 etc instead of Documents, Icloud etc. I decided to reboot and since then the laptop wont boot back up again.

    I have booted into recovery mode and ran checkdisks etc and there doesnt appear to be an error with the HDD. When running the stratup in verbose mode it seems to just hang in a loop with messages about too many corpses????

    ANy suggestions? I have tried following all the suggestions on mac forums etc but i cant seem to get it to boot.

    Cheers,
    Simon
     
  2. treekram, Jun 25, 2017
    Last edited: Jun 25, 2017

    treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #2
    See if you can boot in safe mode. If you can, it's likely the Datto software.

    https://support.apple.com/en-us/HT201262

    What software update were you trying to install?

    If you can't boot in safe mode, you also might want to try to boot without connecting to a network and see if that makes a difference. The idea here is that perhaps the Datto software is connecting to the Internet and something is going wrong - I presume Datto does backup on the clould - I'm just presuming based on a quick read of what Datto is. (Or some other app is having a network issue.) If you can turn off your wi-fi router or try the following:

    https://apple.stackexchange.com/questions/249783/can-i-disable-wifi-on-boot-system-not-booting

    or you can search for some other method to temporarily disable Wi-Fi. If you're using an adapter to get wired Ethernet, you can just try disconnecting it and try booting. I think the commands in the link above may work in a Terminal in recovery mode (instead of single-user mode) as well.
     
  3. simogoesos thread starter macrumors newbie

    Joined:
    Jun 25, 2017
    #3
    I cant boot in safe mode, i get the same messages about too many corpses. i left the laptop on all weekend and it never got past this loop.

    I wasn't trying to do an update, i am just unsure if one had a reboot pending, i rarely reboot. As for the WIFI, i have tried booting without it being connected to the wifi but i haven't physically disabled the wifi or ethernet card.

    i am backing up my files in thnderbolt mode from another Mac and i guess i will try a full rebuild to see if that fixes the issue.
     
  4. treekram macrumors 6502a

    Joined:
    Nov 9, 2015
    Location:
    Honolulu HI
    #4
    After the backup, you can try single-user mode (command-S on start) and the WiFi disabling. If you can't get into single-user mode, it's likely that something got corrupted. You can also try resetting the NVRAM and running diagnostics.

    https://support.apple.com/en-us/HT204063

    I don't think you meant physically disabling the WiFi card, as that would mean opening up the computer. I would pay a visit to an Apple Store Genius Bar before doing that.
     

Share This Page