Mac Messenger and MSN Messenger won't work - help!!!!

Discussion in 'macOS' started by xsammiex, Jul 10, 2007.

  1. xsammiex macrumors newbie

    Joined:
    Jul 10, 2007
    #1
    Okay, I got a Mac OS X from my brother, we set up the internet on it and everything. I clicked on the messenger, but it won't work. It told me: Sign in to Microsoft Messenger failed because the service is not available or you may not be connected to the Internet.
    So I downloaded MSN Messenger for Mac, installed it, tried to sign in but again it said the same thing!!! Someone help me, how do I make it work?! :mad::mad::mad::mad::mad:
     
  2. tomoisyourgod macrumors regular

    Joined:
    May 3, 2007
    Location:
    Liverpool, UK
    #2
    Its a load of rubbish on the Mac... I use Adium
     
  3. kolax macrumors G3

    Joined:
    Mar 20, 2007
    #3
    I have no problems at all using MSN Messenger:Mac.

    Signs in all the time, never really had a problem. You are connected to the internet right?
     
  4. xsammiex thread starter macrumors newbie

    Joined:
    Jul 10, 2007
    #4
    yeah, i am. i don't get what's wrong with it :confused:
     
  5. Osarkon macrumors 68020

    Osarkon

    Joined:
    Aug 30, 2006
    Location:
    Wales
    #5
    Proxy settings perhaps? You haven't a proxy server have you? If you don't know then you probably don't.
     
  6. xsammiex thread starter macrumors newbie

    Joined:
    Jul 10, 2007
    #6
    no idea what a proxy is. this is like the first time i've used a mac so...:confused:
     
  7. mrkramer macrumors 603

    mrkramer

    Joined:
    Jul 11, 2006
    Location:
    Somewhere
    #7
    Did you install the Safari 3 Beta, that caused some problems with MSN messenger for me. also you could try repairing permissions in disk utility.
     
  8. xsammiex thread starter macrumors newbie

    Joined:
    Jul 10, 2007
    #8
    safari 3 beta.. i'll look for that, thanks :)
     
  9. Osarkon macrumors 68020

    Osarkon

    Joined:
    Aug 30, 2006
    Location:
    Wales
    #9
    You don't want to go looking for it, mrkramer said it caused issues. :p

    If you haven't installed it then it isn't going to be that.
     
  10. iCliché macrumors newbie

    iCliché

    Joined:
    Jul 8, 2007
    Location:
    Middle of nowhere
    #10
    Are you accessing the internet through wireless? If so, unplug your router wait 30 seconds and plug it back in. I get the same errors sometimes and resetting my router fixes it.

    Colin
     
  11. annukya macrumors newbie

    Joined:
    Oct 29, 2007
    #11
    I get the same problem!

    I have a brand new macbook and msn won't work, weirdly it works on my much older emac

    if someone has a solution please help!
     
  12. x8xsamuelx8x macrumors newbie

    Joined:
    Nov 15, 2007
    #12
    :d

    i have the same problem.

    i have a proxy, does that affect my msn?

    sam
     
  13. doobi18 macrumors 6502

    Joined:
    Dec 31, 2006
    Location:
    Sydney, Australia
    #13
    dont bother with messnger:mac. its ****.



    i like many others use adium

    some use others such as proteus, aMSN, just steer clear of mercury
     
  14. mtownron macrumors newbie

    Joined:
    Feb 7, 2008
    #14
    msn messenger for mac

    sounds like you need to move the install to your applications folder, click on it, when the icon appears in your dock, right click and set it to stay in your dock, then quit, and then start it from the dock, then log in, and it should work
     
  15. Nerala macrumors newbie

    Joined:
    Jun 12, 2008
    #15
    I have the same problem as well, but I have an ibook G4 running tiger, and I can't log into msn at all, using any client. I can't login using the mac messenger client, and I have a multi client called fire that won't let me login either. When I try to login it tells me that the sign-in failed because and tells me to check the screen name and password

    I know my screen name works as I can login to msn from my phone, or another computer or a web based client as well. I don't have any proxies set up, could it be I have the wrong port set up?
     
  16. evansmith macrumors newbie

    Joined:
    Oct 28, 2008
    Location:
    Cookeville, TN
    #16
    Peer Guardian

    Sounds like you're running Peer Guardian on your Mac, and you have checked the Microsoft list. Click on the PG icon on your top bar, go to Lists, and uncheck Microsoft. :apple:
     
  17. iknowgungfu macrumors member

    Joined:
    Jul 17, 2008
    #17
    I have the exact same problem as OP. Adium seems to be working now, but MSN messnger will not at all. It's a shame because Adium doesn't support webcam :(
     
  18. juanster macrumors 68020

    juanster

    Joined:
    Mar 2, 2007
    Location:
    toronto
    #18
    and mac msn does now? what since when??
     
  19. derryquinn macrumors 6502

    derryquinn

    Joined:
    Sep 29, 2007
    #19
    Eh, you do realise this thread is almost a year old...right?
     
  20. shoebag macrumors newbie

    Joined:
    Jan 4, 2009
    #20
    I am having the same problems as the OP.
    I am using Safari 3.2.1 and the latest Firefox (whatever version that is), i am also connected to the internet using a Belkin 54g Wireless Router.

    Can anyone help me? What do you guys suggest?

    Thanks for the help, i am a mac noob i only got my macbook yesterday!
     
  21. Cerebrus' Maw macrumors 6502

    Joined:
    Mar 9, 2008
    Location:
    Brisbane, Australia
    #21
    Do you have any secrity running? (AV, Firewall? Router ports??)
    Has it ever worked?
    Is there anyone else connected to the same router that is also having the same problem with Mac Messenger?
    Can you use any other IM software? PSI, Adium etc?

    I solved my neighbours issue by simply turning off the router for 30 secs, and then signing it back in. Try it, I guess.
     
  22. shoebag macrumors newbie

    Joined:
    Jan 4, 2009
    #22
    I only have the standard Mac firewall running, i don't know about the router set up though.
    I did try aMSN the other day, but it came up with the same problem :S

    If i try resetting my router like you say, will i have to do this every time?
    If so is there no other more permanent solution?

    Thanks
     
  23. rbassilian macrumors newbie

    Joined:
    Jan 28, 2009
    #23
    The problem has nothing to do with any of these. The issue is with Certificates. Mac used to allow private domains to install their root certificates on a Mac OS, but in their infinite wisdom they removed this feature in 10.5. Theoretically, you can still install a root cert on 10.5, but I still haven't been able to make it work. Meanwhile my Windows machines hook up to our messenger service just fine.

    Stop pretending people are stupid and that if they just fix their internet a mac will work perfectly. It doesn't work, it's got a gillion problems in it, and so far I've seen no efforts by Mac's support crew to play nice with Windows at all.
     
  24. Tony Conception macrumors newbie

    Joined:
    Apr 15, 2010
    #24
    Solution

    The problem is a firewall (provably in your adsl/wireless router) stopping connections to port 1863. Microsoft's MSN for windows try to connect at this port and if it doesn't succeed, it tries a traditional http connection on port 80. Microsoft MSN for Mac, aparently, doesn't do this).

    So you can try any of this 2 solutions:

    1) disable/low down firewall rules in yout adsl/wireless router;

    2) try a client who can be set to ust http connection. On Linux: aMsn, Pidgin, KMess, Emesene. On Mac I could get only aMsn working (I didn't find this setting on adium).

    Welcome.
     
  25. bluboi macrumors newbie

    Joined:
    Jun 17, 2010
    #25
    solution 2

    Since this thread is the top result on google when searching the problem I'll share the solution that works for me.

    "you may not be connected to the internet msn messenger" "msn messenger won't get past sign is" "msn messenger stuck at sign in"

    most likely problem, the browsers proxy settings:

    set safari as the default browser:

    open safari>safari>preferences>general>default web browser>safari


    Last step:
    disable proxies

    safari>preferences>advanced>(proxy)change settings>proxies>uncheck any checked boxes


    MSN is always kind of choppy and has lots of issues but this one is generally related to the browsers proxies being up. If this doesn't work check to see if you have tor, privoxy or any other third party proxy system installed, turn them off while using messenger.
     

Share This Page