Mac mini not detecting HDTV...

Discussion in 'Mac mini' started by amnichols10, Feb 8, 2011.

  1. amnichols10 macrumors regular

    Joined:
    May 19, 2008
    #1
    I just bought a mac mini and the plan was to run it through my tv using an HDMI cord. When I go to set things up. I get to the display section in "system preferences" and I started playing around with resolutions to see which would work best with the tv that I have. All the sudden the tv screen went black and now the tv doesn't detect the mac mini through HDMI. After restarting the computer the apple logo would come up and everything would start to boot and then it's like the tv and computer would drop the signal. I don't think that it's something that I done with the resolution.

    I checked and seen that this is a common problem, but I don't know how to fix this problem. Any advice is good advice and I really appreciate it.
     
  2. PiroPhosphoric macrumors newbie

    Joined:
    Oct 24, 2010
    #2
    ¿Handshaking vs Cable problem?

    It would help to solve your problem to know which TV set are you trying to connect to the mini, and if there other elements (splitters, etc).

    It seems to be a HDMI-handshaking problem. After shutdown the mini and the TV, take out all the cables and wait at least 10 seconds. Connect everything, put on the TV first, restart mini and wait.

    Anyway, it could be a cable problem (I have a similar issue that solves itself after changing HDMI cable).
     
  3. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #3
    may be a bad cable. try a new one. lots of low cost ones on ebay. or monoprice.com
     
  4. amnichols10 thread starter macrumors regular

    Joined:
    May 19, 2008
    #4
    The TV I have is in turkey (that's where I'm currently located). I'll keep you updated on the progress.
     
  5. Osamede macrumors 6502

    Joined:
    Oct 28, 2009
    #5
    I had a similar problem when I first installed an HDMI switch. I changed the switch to an older one and it worked.

    I have a sneaky feeling that maybe newer HDMI equipment is more strict about DRM rules on handshaking (aka HDCP) whereas maybe the older HDMI equipment ignored those flags.

    Some people say that if you go into the control panel of Mac Min and change sleep settings to display always on, this problem will go away. I have never investigated this since I already put in the new HDMI switch.
     
  6. amnichols10 thread starter macrumors regular

    Joined:
    May 19, 2008
    #6
    Thanks. All I had to do was reset the display setting (hold shift at startup) and I was good. Thanks for the reply though.
     

Share This Page