Mac Mini Ram upgrade question and beachball issue

Discussion in 'Mac mini' started by nizmoz, Dec 3, 2010.

  1. nizmoz macrumors 65816

    Joined:
    Jul 7, 2008
    #1
    We have a base Mac Mini which I believe is a late 2009 model (before they got the new 2010s), and it only has 2gb of ram. Will the ram out of my MacBook Pro 4gb 13" 2010 model fit this? Because I upgraded to 8gb of ram and the Mac Mini is doing the beach balls a lot lately and requires a restart to resolve it for a while. But at least twice a week we have to restart the Mini to solve that issue.

    Any ideas what might cause that too?
     
  2. Karnivore macrumors 6502

    Karnivore

    Joined:
    Apr 22, 2010
  3. fa8362 macrumors 65816

    Joined:
    Jul 7, 2008
    #3
    2GB of RAM is plenty for many activities, but not enough for some. What are you doing on the Mini when you get the beach balls?
     
  4. ejket, Dec 4, 2010
    Last edited: Dec 4, 2010

    ejket macrumors newbie

    ejket

    Joined:
    Sep 7, 2008
    Location:
    Canada
    #4
    I'd also like to know what activities would noticeably bog down a mini. I just bought a bare bones 2010 mini (2.4 GHz, 2G RAM) a couple days ago, mostly as a supplementary machine on a KVM for browsing and writing. I was just about to grab some upgrade RAM sticks when I stopped and wondered if I'd really need them. I decided that I'd wait and see. So far I don't think I do, but it's only been a couple days.

    Here's some things I won't be doing on this machine: video processing/encoding, 3d rendering, photoshop, audio processing, games. I usually only have a couple things open at a time as well. What else would bog down a mini?

    Getting additional memory is no big deal, but I won't bother if I can't use it.
     
  5. nizmoz thread starter macrumors 65816

    Joined:
    Jul 7, 2008
    #5
    Well this is still happening. Not sure what else to do other than wipe the box. It went away for a week or so, then came back. This is so frustrating. Anyone have any other pointers?
     
  6. California macrumors 68040

    California

    Joined:
    Aug 21, 2004
    #6
    The hard drive on the early 2009 mini's were only 120gb and 5400rpm, kinda crappy. I'd upgrade that and put at least four gigs of ram in it.

    I had the 2.26ghz mini for a while and put five gigs in it. (one four combination) with a five hundred gig hard drive. It ran great.
     
  7. philipma1957 macrumors 603

    philipma1957

    Joined:
    Apr 13, 2010
    Location:
    Howell, New Jersey
    #7
  8. Chase R macrumors 65816

    Chase R

    Joined:
    May 8, 2008
    Location:
    PDX
    #8
    Safari is a huge factor in Mac mini beachballing issues. It hogs a bunch of RAM. 2GB really isn't enough for Snow Leopard.

    Open up Safari and go to Safari -> Reset Safari...

    Reset everything. When you open Safari next and go into your bookmarks, it will ask you to "add webpage previews now?"... Hit ignore or cancel or whatever. Just eats up space.

    Go to Safari preferences and make sure that neither new windows, nor new tabs open up with Top Sites. Remove it from the bookmarks bar as well.

    Open up Terminal and type this in (disables Top Sites Completely):
    Code:
    defaults write com.apple.Safari DebugSnapshotsUpdatePolicy -int 2
    Then download Onyx.

    Go to the "Cleaning" section and clean out ALL the catches. Then restart the mini.

    Then go to the "Maintenance" section verify/repair permissions.

    Restart.

    Your mini should run A LOT better after doing all of this.

    Oh and are you running multiple accounts on your mini? If so, I would disable fast-user-switching... 2GB isn't really enough to support it. And if you use VLC, I have another suggestion that will make a HUGE difference.
     
  9. nizmoz thread starter macrumors 65816

    Joined:
    Jul 7, 2008
    #9
    It's 160gb HD.
     
  10. nizmoz thread starter macrumors 65816

    Joined:
    Jul 7, 2008
    #10
    We use Firefox on that machine and not Safari. But will give it a try anyways! Only one account.

    I will try your tips. I ran YAGU and it helped for a week then it came back.

     
  11. nizmoz thread starter macrumors 65816

    Joined:
    Jul 7, 2008
    #11
    Just did that. Seems to be running better. BTW, it has 4gb of ram as I just upgraded it recently. Didn't help much.
     
  12. Chase R macrumors 65816

    Chase R

    Joined:
    May 8, 2008
    Location:
    PDX
    #12
    Do you ever use VLC? If so, turn off "File Memory Mapping." It causes Macs to run VERY slow after a movie because it eats up all the RAM and pages memory to the hard drive.

    VLC -> Preferences... -> (click on "All" at the bottom) -> Input / Codecs -> Access Modules -> MMap -> uncheck the box that says "Use file memory mapping"

    Transmission also causes the same situation, though it's not as severe.
     

Share This Page