Mac Newbie - Time Machine problem

Discussion in 'Mac Basics and Help' started by JasonStonier, Jun 27, 2013.

  1. JasonStonier macrumors newbie

    Joined:
    Jun 27, 2013
    #1
    Hi guys, total mac newbie here. A friend gave me a dead macbook air first generation A1237, which I have fixed and it's running nicely. I'm on day 3 with it.

    I am intending to bootcamp Win XP as I need to use Corel Draw. That is not my problem: I've got all the guides for doing this and I am confident.

    My problem is that I am trying to do a Time Machine backup before I start because I don't have the OS disks or the installer for iWork '09 that are on the machine.

    I am trying to back up to an external USB SATA drive, and I have tried two different drives from different manufacturers (although both in the same type of usb/sata converter) and I get the same failure. Sometimes this is around 120MB in to the backup, twice it has got to nearly 2GB before failing.

    The pop-up I get on fail is "The backup was not performed because an error occurred while copying files to the backup disk". The disks are formatted with the mac journaled file system, and are otherwise readable. They check out ok in diskutil verify.

    Looking in Console and filtering for string backupd gives errors like:

    27/06/2013 08:59:27 com.apple.backupd[1142] Error: (-36) SrcErr:YES Copying /Library/Application Support/Apple/Mail/Stationery/Apple/Contents/Resources/Announcements/Contents/Resources/Baby.mailstationery/Contents/Resources/bg_pattern.jpg to (null)
    27/06/2013 08:59:37 com.apple.backupd[1142] Error: (-36) SrcErr:YES Copying /Library/Application Support/Apple/Mail/Stationery/Apple/Contents/Resources/Announcements/Contents/Resources/Picnic.mailstationery/Contents/Resources/napkin.jpg to (null)
    27/06/2013 08:59:44 com.apple.backupd[1142] Stopping backup.

    I have tried deleting the timemachine backup from the disk and starting again, and the result is the same.

    The machine is running 10.6.8 Snow Leopard. I am running as an administrator, the machine is on mains power, and is set to not sleep.

    Any help appreciated.
     
  2. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #2
    One thing that comes to mind is the partition table type. Time Machine needs to run on a drive partitioned using GUID. If it isn't (click on the device in Disk Utility and the partition map scheme will be displayed on the bottom of the window), you'll need to start fresh with a new partition to change the scheme. Note that doing so will erase all data on the drive.

    To do that, select the device from the sidebar, then the Partition tab. Click the "Options..." button and change the table type to GUID. Then, select "1 Partition", format as "Mac OS Extended (journaled)", and whatever name you like. Note the following step will erase all data on the drive. (You'll get warnings from Disk Utility also.) Click "Apply".

    Although it could be a failing drive, it seems unlikely in your case because you've tried two drives. So, one other reason I've had for similar errors has turned out to be an underpowered adapter. The original MBA has a high power USB port (1000ma iirc), so it should power an external drive ok. However, I've seen problems crop up when using an extension cable (it could cause a drop due to internal resistance) that were solved by using a short cable (sometimes, just a different cable at the same length would work :rolleyes:).

    If you have a different cable, give that a try. Or, connect an external power supply.

    If underpowered, you might hear the head load/unload cyclically (kind of like what a dying drive would do).
     
  3. JasonStonier thread starter macrumors newbie

    Joined:
    Jun 27, 2013
    #3
    Thanks for the reply.

    The partition type is GUID, and as you say it is unlikely to be a failing drive. The usb cable is a double-type with a short additional jumper cable for extra power, but of course on the MBA there's only one USB port (however I could power the drive off a USB wall adapter).

    What is interesting, though, is that I left the MBA on while I was out and came back to a completed, successful, Time Machine backup of 40GB which must have been a default scheduled one. All the (ten or so) others I tried were "back up now".

    Could be coincidence, but the odds are low.
     
  4. JasonStonier thread starter macrumors newbie

    Joined:
    Jun 27, 2013
    #4
    Rather than starting another thread, and related to this...

    My searching suggests that to restore a MBA on 10.6.8 from a time machine backup, I will need the OS disk, which I unfortunately do not have.

    Now I can in theory download it from a torrent site, but what is the licencing arrangement? Is there a product key (as in MS Windows) that I will need to use to do an install? Or rather, since I own a mac, am I licenced to have the operating system to go on it, thus downloading a generic OSX SnowLeopard iso file is all I need?

    Thanks.
     
  5. gr8tfly macrumors 603

    gr8tfly

    Joined:
    Oct 29, 2006
    Location:
    ~119W 34N
    #5
    Hard to say.

    But, just in case... If you have room on your other drive, I would suggest creating a partition on it for an image backup.

    I like to have at least two full backups. I usually have Time Machine running, then periodically (at a minimum, before an OS "dot" update) create an image backup on a different drive.

    I use Disk Utilty's Restore feature to create a bootable image of the internal to an external partition of the same or larger size. For Lion or later, DU will also create the Recovery HD partition on the target drive. You'll need to startup on a different partition to create the image (or restore from) - Recovery HD or another OS X install.
     

Share This Page