Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

FatherOfTwo

macrumors regular
Original poster
Jun 9, 2015
132
43
Since installing 10.12.4 Beta i'm no longer able to open / play video files, formats such as .mkv or .avi.

Every time I try and open one of these files I get a screen showing 'Verifying filename.mkv' - I guess if I leave it long enough the verification process will complete but not something you want to wait for.

Any ideas on what is going on? Guessing it is a known bug in 10.12.4

Thanks, Ian.
 

casperes1996

macrumors 604
Jan 26, 2014
7,527
5,698
Horsens, Denmark
Every time I try and open one of these files I get a screen showing 'Verifying filename.mkv' - I guess if I leave it long enough the verification process will complete but not something you want to wait for.
I assume that is with QuickTime - Have you tried viewing it with another player - maybe through iTunes or downloading VLC?
I haven't used .avi or .mkv on the beta, but .mov, .m4v, .mp4 and a few others work perfectly for me
 

az431

Suspended
Sep 13, 2008
2,131
6,122
Portland, OR
I assume that is with QuickTime - Have you tried viewing it with another player - maybe through iTunes or downloading VLC?
I haven't used .avi or .mkv on the beta, but .mov, .m4v, .mp4 and a few others work perfectly for me

Same issue with VLC, but they do open eventually.
 

dan9700

Suspended
May 28, 2015
3,347
4,824
It takes ages thats not good enough, why has the beta done this and what else is as good aa vlc and does every video file as vlc hasnt had update in yeara and even the new beta of vlc 3.0 does aame thing
 

casperes1996

macrumors 604
Jan 26, 2014
7,527
5,698
Horsens, Denmark
Same issue with VLC, but they do open eventually.

Just tried an mkv file with QuickTime recently (on beta 1 still), and not seeng any problems. Just opened immediately as normal. I have the Pro Video Codecs if that makes a difference (as per Final Cut and Motion)

What I am seeing however, is kernel panics every time I wake my computer from sleep (only after sleeping for half a day's time) That's pretty crummy
 

dan9700

Suspended
May 28, 2015
3,347
4,824
Just tried an mkv file with QuickTime recently (on beta 1 still), and not seeng any problems. Just opened immediately as normal. I have the Pro Video Codecs if that makes a difference (as per Final Cut and Motion)

What I am seeing however, is kernel panics every time I wake my computer from sleep (only after sleeping for half a day's time) That's pretty crummy
why does vlc have to verify cant i turn that off so opens instant, also does quicktime play every file like vlc
[doublepost=1486510527][/doublepost]
Just tried an mkv file with QuickTime recently (on beta 1 still), and not seeng any problems. Just opened immediately as normal. I have the Pro Video Codecs if that makes a difference (as per Final Cut and Motion)

What I am seeing however, is kernel panics every time I wake my computer from sleep (only after sleeping for half a day's time) That's pretty crummy
my quicktime wont play mkv and i have pro codec
 

casperes1996

macrumors 604
Jan 26, 2014
7,527
5,698
Horsens, Denmark
why does vlc have to verify cant i turn that off so opens instant, also does quicktime play every file like vlc

I've very little experience with VLC, but I think it reads a lot of necessary metadate, such as length, during the verification so that it's necessary. – Regarding QuickTime, I believe it just plays any file the OS has codecs for.

my quicktime wont play mkv and i have pro codec

Hm. Wonder how I get the QT codec for it then
 

WalterZheng

macrumors newbie
Feb 11, 2017
5
0
Since installing 10.12.4 Beta i'm no longer able to open / play video files, formats such as .mkv or .avi.

Every time I try and open one of these files I get a screen showing 'Verifying filename.mkv' - I guess if I leave it long enough the verification process will complete but not something you want to wait for.

Any ideas on what is going on? Guessing it is a known bug in 10.12.4

Thanks, Ian.
This bug (or not, let's just say it) happened to me days ago, and i find a solution to it.

Open up terminal.app and two ways to get rid of it:

1. Run this on your own risks to completely turn off the file quarantine, which works fine but effectively disable the Xproctect and Gatekeepers:

defaults write com.apple.LaunchServices LSQuarantine -bool NO
(Reboot is required)

2. Run this if you want to disable quarantine for files already downloaded in specific folders

xattr -d -r com.apple.quarantine ~/Downloads

(Works immediately, no reboot is required)

3. if you want to disable quarantine for specific files that already downloaded
xattr -d com.apple.quarantine your_file_path_and_file_name_here_like_~/Downloads/_abc.mkv
(Works immediately, no reboot is required)


PS:

1.
I just posted a thread there, in case that you need to read:

https://forums.macrumors.com/thread...ifying-check-dialog-on-opening-files.2032210/
2.
And the credits of this tip is kinda going to the author of these authors who had shown two ways to effectively get rid of that thing, which deserving reading:

http://hints.macworld.com/article.php?story=20091208050655947
http://rentzsch.tumblr.com/post/267379307/disable-and-recover-from-mac-os-xs-quarantine


Best.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.